From mboxrd@z Thu Jan 1 00:00:00 1970 From: Olivier MATZ Subject: Re: [PATCH v3 2/6] eal/memory: rename buf physaddr to buf iovaaddr Date: Wed, 25 Oct 2017 11:44:40 +0200 Message-ID: <20171025094439.ejolqdikenwjxwbl@platinum> References: <20170905103119.20511-1-santosh.shukla@caviumnetworks.com> <20171020123136.10557-1-santosh.shukla@caviumnetworks.com> <20171020123136.10557-3-santosh.shukla@caviumnetworks.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: dev@dpdk.org, thomas@monjalon.net, jerin.jacob@caviumnetworks.com, hemant.agrawal@nxp.com, anatoly.burakov@intel.com To: Santosh Shukla Return-path: Received: from mail.droids-corp.org (zoll.droids-corp.org [94.23.50.67]) by dpdk.org (Postfix) with ESMTP id 5BC397D19 for ; Wed, 25 Oct 2017 11:44:48 +0200 (CEST) Content-Disposition: inline In-Reply-To: <20171020123136.10557-3-santosh.shukla@caviumnetworks.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Hi Santosh, On Fri, Oct 20, 2017 at 06:01:32PM +0530, Santosh Shukla wrote: > Rename buf_physaddr to buf_iovaaddr > > Signed-off-by: Santosh Shukla > Reviewed-by: Anatoly Burakov > > [...] > > --- a/lib/librte_mbuf/rte_mbuf.h > +++ b/lib/librte_mbuf/rte_mbuf.h > @@ -411,7 +411,7 @@ struct rte_mbuf { > * same mbuf cacheline0 layout for 32-bit and 64-bit. This makes > * working on vector drivers easier. > */ > - iova_addr_t buf_physaddr __rte_aligned(sizeof(iova_addr_t)); > + iova_addr_t buf_iovaaddr __rte_aligned(sizeof(iova_addr_t)); If we want to avoid breaking the API for this release, we can use an anonymous union and keep both fields. Please don't forget to use RTE_STD_C11 (see commit 79d6f5fc58). We can announce the deprecation of buf_physaddr for later.