From mboxrd@z Thu Jan 1 00:00:00 1970 From: Olivier MATZ Subject: Re: [PATCH v3 2/6] eal/memory: rename buf physaddr to buf iovaaddr Date: Wed, 25 Oct 2017 11:55:24 +0200 Message-ID: <20171025095523.4ohzquvcscv44i5u@platinum> References: <20170905103119.20511-1-santosh.shukla@caviumnetworks.com> <20171020123136.10557-1-santosh.shukla@caviumnetworks.com> <20171020123136.10557-3-santosh.shukla@caviumnetworks.com> <4299450.srK9Y67Yii@xps> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: Santosh Shukla , dev@dpdk.org, jerin.jacob@caviumnetworks.com, hemant.agrawal@nxp.com, anatoly.burakov@intel.com To: Thomas Monjalon Return-path: Received: from mail.droids-corp.org (zoll.droids-corp.org [94.23.50.67]) by dpdk.org (Postfix) with ESMTP id CCB7B1B2D1 for ; Wed, 25 Oct 2017 11:55:35 +0200 (CEST) Content-Disposition: inline In-Reply-To: <4299450.srK9Y67Yii@xps> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Mon, Oct 23, 2017 at 10:15:02PM +0200, Thomas Monjalon wrote: > 20/10/2017 14:31, Santosh Shukla: > > Rename buf_physaddr to buf_iovaaddr > > > > Signed-off-by: Santosh Shukla > > Reviewed-by: Anatoly Burakov > > --- > [...] > > --- a/lib/librte_mbuf/rte_mbuf.h > > +++ b/lib/librte_mbuf/rte_mbuf.h > > @@ -411,7 +411,7 @@ struct rte_mbuf { > > * same mbuf cacheline0 layout for 32-bit and 64-bit. This makes > > * working on vector drivers easier. > > */ > > - iova_addr_t buf_physaddr __rte_aligned(sizeof(iova_addr_t)); > > + iova_addr_t buf_iovaaddr __rte_aligned(sizeof(iova_addr_t)); > > I really do not understand this naming scheme. > The "A" of IOVA means Address. So "addr" in iovaaddr is redundant. +1 ioaddr looks clearer than iovaaddr. It could also be io_addr or bus_addr. > > It seems that IOVA is a too much famous acronym to avoid it. > Unfortunately, there is no justification in the commit message. > For the record, my preference was "IO address". > > We could at least add an underscore in iova_addr. > > But I will apply it as is because nobody else complained. >