From mboxrd@z Thu Jan 1 00:00:00 1970 From: Gaetan Rivet Subject: [PATCH v1] doc: update deprecation notice of rte_devargs Date: Wed, 7 Feb 2018 10:26:10 +0100 Message-ID: <20180207092610.6593-1-gaetan.rivet@6wind.com> Cc: Gaetan Rivet To: dev@dpdk.org Return-path: Received: from mail-wm0-f65.google.com (mail-wm0-f65.google.com [74.125.82.65]) by dpdk.org (Postfix) with ESMTP id A0F941B35F for ; Wed, 7 Feb 2018 10:26:30 +0100 (CET) Received: by mail-wm0-f65.google.com with SMTP id j21-v6so21714835wmh.1 for ; Wed, 07 Feb 2018 01:26:30 -0800 (PST) List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" The declaration and identification of devices will change in v18.05. Remove the precedent deprecation notice Add new one reflecting the planned changes more accurately, updated for v18.05. Signed-off-by: Gaetan Rivet --- doc/guides/rel_notes/deprecation.rst | 27 ++++++++++++++++----------- 1 file changed, 16 insertions(+), 11 deletions(-) diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst index d59ad5988..07312f59a 100644 --- a/doc/guides/rel_notes/deprecation.rst +++ b/doc/guides/rel_notes/deprecation.rst @@ -8,18 +8,23 @@ API and ABI deprecation notices are to be posted here. Deprecation Notices ------------------- -* eal: several API and ABI changes are planned for ``rte_devargs`` in v18.02. - The format of device command line parameters will change. The bus will need - to be explicitly stated in the device declaration. The enum ``rte_devtype`` - was used to identify a bus and will disappear. - The structure ``rte_devargs`` will change. - The ``rte_devargs_list`` will be made private. - The following functions are deprecated starting from 17.08 and will either be - modified or removed in 18.02: +* eal: both declaring and identifying devices will be streamlined in v18.05. + New functions will appear to query a specific port from buses, classes of + device and device drivers. Device declaration will be made coherent with the + new scheme of device identification. + As such, ``rte_devargs`` device representation will change. - - ``rte_eal_devargs_add`` - - ``rte_eal_devargs_type_count`` - - ``rte_eal_parse_devargs_str``, replaced by ``rte_eal_devargs_parse`` + - removal of ``name`` and ``args`` fields. + - The enum ``rte_devtype`` was used to identify a bus and will disappear. + - The ``rte_devargs_list`` will be made private. + - Functions previously deprecated will change or disappear: + + + ``rte_eal_devargs_add`` + + ``rte_eal_devargs_type_count`` + + ``rte_eal_parse_devargs_str``, replaced by ``rte_eal_devargs_parse`` + + ``rte_eal_devargs_parse`` will change its format and use. + + all ``rte_devargs`` related functions will be renamed, changing the + ``rte_eal_devargs_`` prefix to ``rte_devargs_``. * pci: Several exposed functions are misnamed. The following functions are deprecated starting from v17.11 and are replaced: -- 2.11.0