From mboxrd@z Thu Jan 1 00:00:00 1970 From: =?iso-8859-1?Q?N=E9lio?= Laranjeiro Subject: Re: [PATCH v2 02/20] net/mlx5: handle drop queues are regular queues Date: Wed, 4 Jul 2018 08:44:24 +0200 Message-ID: <20180704064424.qmplbxgaxlqicbvl@laranjeiro-vm.dev.6wind.com> References: <1368a8720f3ec3c40e47a6b1d9ef1edf0f38a646.1530111623.git.nelio.laranjeiro@6wind.com> <20180703010703.GB38831@yongseok-MBP.local> <20180703071756.5fqggm5o77ytaptg@laranjeiro-vm.dev.6wind.com> <20180703170504.GA41721@yongseok-MBP.local> Mime-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit Cc: dev@dpdk.org, Adrien Mazarguil To: Yongseok Koh Return-path: Received: from mail-wm0-f67.google.com (mail-wm0-f67.google.com [74.125.82.67]) by dpdk.org (Postfix) with ESMTP id 30A9F1BE8B for ; Wed, 4 Jul 2018 08:44:29 +0200 (CEST) Received: by mail-wm0-f67.google.com with SMTP id z13-v6so4452387wma.5 for ; Tue, 03 Jul 2018 23:44:29 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20180703170504.GA41721@yongseok-MBP.local> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Tue, Jul 03, 2018 at 10:05:05AM -0700, Yongseok Koh wrote: > On Tue, Jul 03, 2018 at 09:17:56AM +0200, Nélio Laranjeiro wrote: > > On Mon, Jul 02, 2018 at 06:07:03PM -0700, Yongseok Koh wrote: > > > On Wed, Jun 27, 2018 at 05:07:34PM +0200, Nelio Laranjeiro wrote: > [...] > > flow_drop_queue is also confusing as it is a drop hash rx queue, it can > > be used without a flow as a regular queue. > > Renaming it to drop_hrxq. > > Not so much critical to me but the entry has a field having repeating name. > priv->drop_hrxq.hrxq and priv->drop_hrxq.rxq > Sounds still confusing... > > > > > +/** > > > > + * Release a drop Rx queue Verbs object. > > > > + * > > > > + * @param dev > > > > + * Pointer to Ethernet device. > > > > + * @param rxq > > > > + * Pointer to the drop Verbs Rx queue. > > > > + * > > > > + * @return > > > > + * The Verbs object initialised, NULL otherwise and rte_errno is set. > > > > + */ > > > > +void > > > > +mlx5_rxq_ibv_drop_release(struct rte_eth_dev *dev, struct mlx5_rxq_ibv *rxq) > > > > > > If rxq for drop is saved in priv->drop.rxq, then why does it have to get rxq > > > pointer as an argument? Looks redundant. > > >[...] > > > > Like for all hrxqs, indirection tables, rxqs, which are stored in priv > > inside a list or an array. > > However, the assumption is there's only one drop queue while the regular ones > have multiple instances. > > > Priv is used as a storage place which is only access through > > *_{new,get,release} functions. > > Yes, that's what I'm telling you. *_{new,get,release}() accesses priv, then why > the pointer (which is saved in priv) is needed as an argument? > > > This is also to keep a consistency between regular hrxqs, and drop hrxq also. > Not sure why that consistency has to be kept. > > int mlx5_rxq_release(struct rte_eth_dev *dev, uint16_t idx); > int mlx5_hrxq_release(struct rte_eth_dev *dev, struct mlx5_hrxq *hxrq); > > mlx5_rxq_release() takes index as the instances are stored in an array and > mlx5_hrxq_release() takes pointer as the instances are stored in a list. > > Then, what if there's only one instance and no need to search? > Not taking such an argument sounds more consistent... >[...] Even if I prefer to keep consistency about identical functionality (in this case creating an hash Rx queue), I'll make the changes to please you. Regards, -- Nélio Laranjeiro 6WIND