From mboxrd@z Thu Jan 1 00:00:00 1970 From: Bruce Richardson Subject: Re: [PATCH 2/2] build: establish an invariant machine type Date: Wed, 14 Nov 2018 11:52:56 +0000 Message-ID: <20181114115256.GB17424@bricha3-MOBL.ger.corp.intel.com> References: <20181114113453.24852-1-christian.ehrhardt@canonical.com> <20181114113453.24852-2-christian.ehrhardt@canonical.com> <1542195611.11515.10.camel@debian.org> Mime-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit Cc: Christian Ehrhardt , dev To: Luca Boccassi Return-path: Received: from mga18.intel.com (mga18.intel.com [134.134.136.126]) by dpdk.org (Postfix) with ESMTP id BCFF34CBB for ; Wed, 14 Nov 2018 12:53:00 +0100 (CET) Content-Disposition: inline In-Reply-To: <1542195611.11515.10.camel@debian.org> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Wed, Nov 14, 2018 at 11:40:11AM +0000, Luca Boccassi wrote: > On Wed, 2018-11-14 at 12:34 +0100, Christian Ehrhardt wrote: > > Add the machine definition 'baseline' which is special compared > > to 'native' (most optimized for current system) or any explicit > > type (external entity has to decide on the type). > > > > It defaults to the per arch agreed common minimal baseline > > needed for DPDK to reasonable work. > > > > That might not be the most optimized, but the most portable > > version while still being able to support the CPU features > > required for DPDK. > > > > Going forward this can be bumped up by the DPDK project, but it > > can never be an invariant like 'native'. > > > > Distributions and other needing portable code are expected to > > define the machine as 'baseline'. > > > > Signed-off-by: Christian Ehrhardt > > --- > >  config/meson.build | 21 +++++++++++++++++++++ > >  1 file changed, 21 insertions(+) > > > > diff --git a/config/meson.build b/config/meson.build > > index 1af305f46..23f612457 100644 > > --- a/config/meson.build > > +++ b/config/meson.build > > @@ -7,6 +7,27 @@ if meson.is_cross_build() > >  else > >   machine = get_option('machine') > >  endif > > + > > +# machine type 'baseline' is special, it defaults to the per arch > > agreed common > > +# minimal baseline needed for DPDK. > > +# That might not be the most optimized, but the most portable > > version while > > +# still being able to support the CPU features required for DPDK. > > +# This can be bumped up by the DPDK project, but it can never be an > > +# invariant like 'native' > > +if machine == 'baseline' > > + if host_machine.cpu_family().startswith('x86') > > + # matches the old pre-meson build systems default > > + machine = 'corei7' > > + elif host_machine.cpu_family().startswith('arm') > > + machine = 'armv7a' > > + elif host_machine.cpu_family().startswith('aarch') > > + # arm64 manages defaults in config/arm/meson.build > > + machine = 'default' > > + elif host_machine.cpu_family().startswith('ppc') > > + machine = 'power8' > > + endif > > +endif > > + > >  dpdk_conf.set('RTE_MACHINE', machine) > >  machine_args = [] > > Acked-by: Luca Boccassi > No objection in principle, but, for alignment with make build system, do we want to call this "default" instead? Given a clean slate, "baseline" is more descriptive, but make already uses "default" for this. Perhaps support both? /Bruce