From mboxrd@z Thu Jan 1 00:00:00 1970 From: Lukasz Krakowiak Subject: [PATCH v2 0/3] test: improve test coverage for power library Date: Wed, 3 Apr 2019 12:32:53 +0200 Message-ID: <20190403103256.21856-1-lukaszx.krakowiak@intel.com> References: <20190307135950.30738-1-lukaszx.krakowiak@intel.com> Mime-Version: 1.0 Content-Transfer-Encoding: 8bit Cc: anatoly.burakov@intel.com, dev@dpdk.org, Lukasz Krakowiak To: david.hunt@intel.com Return-path: Received: from mga14.intel.com (mga14.intel.com [192.55.52.115]) by dpdk.org (Postfix) with ESMTP id 7D88A1B129 for ; Wed, 3 Apr 2019 12:33:35 +0200 (CEST) In-Reply-To: <20190307135950.30738-1-lukaszx.krakowiak@intel.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" This patch rename test_power_acpi_cpufreq.c to test_power_cpufreq.c, remove prefix _acpi from UT power functions/test names, add UT for power turbo feature. --- v2: * coding style improved Lukasz Krakowiak (3): test: rename test_power_acpi_cpufreq.c -> app/test/test_power_cpufreq.c test: remove prefix _acpi from UT power function/test names test: add UT for power turbo feature app/test/Makefile | 2 +- app/test/autotest_data.py | 4 +- app/test/meson.build | 4 +- ...er_acpi_cpufreq.c => test_power_cpufreq.c} | 84 +++++++++++++++++-- 4 files changed, 83 insertions(+), 11 deletions(-) rename app/test/{test_power_acpi_cpufreq.c => test_power_cpufreq.c} (86%)