From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Burakov, Anatoly" Subject: Re: [PATCH 2/2] eal/vfio: cleanup getting group fd Date: Wed, 26 Sep 2018 13:34:21 +0100 Message-ID: <26f73861-6fac-065e-b550-219a4c365bea@intel.com> References: <20180917134643.103871-1-dariusz.stojaczyk@intel.com> <20180917134643.103871-2-dariusz.stojaczyk@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Cc: Alejandro Lucero , stable@dpdk.org, Dariusz Stojaczyk To: Darek Stojaczyk , dev@dpdk.org Return-path: In-Reply-To: <20180917134643.103871-2-dariusz.stojaczyk@intel.com> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 17-Sep-18 2:46 PM, Darek Stojaczyk wrote: > From: Dariusz Stojaczyk > > Factor out duplicated code. > > Signed-off-by: Dariusz Stojaczyk > --- > + > +int > +rte_vfio_get_group_fd(int iommu_group_num) > +{ > + struct vfio_config *vfio_cfg; > + > + /* get the vfio_config it belongs to */ > + vfio_cfg = get_vfio_cfg_by_group_num(iommu_group_num); > + vfio_cfg = vfio_cfg ? vfio_cfg : default_vfio_cfg; I tend to prefer being explicit rather than implicit (i.e. 'vfio_cfg == NULL' instead of 'vfio_cfg'). Otherwise, Acked-by: Anatoly Burakov -- Thanks, Anatoly