From mboxrd@z Thu Jan 1 00:00:00 1970 From: Ferruh Yigit Subject: Re: [PATCH v2 0/7] ethdev: add flow API object converter Date: Thu, 23 Aug 2018 14:48:37 +0100 Message-ID: <30a6f2d0-1f0c-c549-9fd1-7e1782990943@intel.com> References: <20180803132032.29038-1-adrien.mazarguil@6wind.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Cc: dev@dpdk.org To: Adrien Mazarguil Return-path: Received: from mga02.intel.com (mga02.intel.com [134.134.136.20]) by dpdk.org (Postfix) with ESMTP id 376762C38 for ; Thu, 23 Aug 2018 15:48:40 +0200 (CEST) In-Reply-To: <20180803132032.29038-1-adrien.mazarguil@6wind.com> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 8/3/2018 2:36 PM, Adrien Mazarguil wrote: > This is a follow up to the "Flow API helpers enhancements" series submitted > almost a year ago [1]. The new title is due to the reduced scope of this > version. > > rte_flow_conv() is a flexible replacement to rte_flow_copy(), itself a > temporary solution pending something better [2]. It replaces a lot of > duplicated code found in testpmd and removes some of the maintenance burden > that developers tend to forget (me included) when modifying pattern > item or actions (updating app/test-pmd/config.c to be clear). > > This series was unearthed in order to complete the implementation of > RTE_FLOW_ACTION_TYPE_ENCAP_(VXLAN|NVGRE) in testpmd [3] without having to > duplicate existing code once again. > > See individual patches for specific changes in this version. > > v2 changes: > > - rte_flow_copy() is kept, albeit deprecated, no API/ABI impact. > - Updated bonding PMD. > - No more automatic generation of rte_flow_conv.h. > > [1] https://mails.dpdk.org/archives/dev/2017-October/077551.html > [2] https://mails.dpdk.org/archives/dev/2017-July/070492.html > [3] Currently the command-line parser (cmdline_flow.c) is aware of these > actions, however config.c isn't. Flow rules with such actions cannot > be created and cannot be validated with PMDs that implement them. > > Adrien Mazarguil (7): > ethdev: add flow API object converter > ethdev: add flow API item/action name conversion > app/testpmd: rely on flow API conversion function > net/failsafe: switch to flow API object conversion function > net/bonding: switch to flow API object conversion function > ethdev: deprecate rte_flow_copy function > ethdev: add missing item/actions to flow object converter Patch needs to be rebased to target v18.11 (in map file), and indeed new APIs (rte_flow_conv) needs to be experimental. And needs to remove deprecation notice in this patchset. Also do you think does make sense to announce this change in release notes? Apart from above, any volunteer for reviewing actual implementation?