From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Monjalon Subject: Re: [PATCH v3 05/11] ethdev: add probing finish function Date: Wed, 23 May 2018 12:14:25 +0200 Message-ID: <3685038.uD5Rg6BZkV@xps> References: <20180509094337.26112-1-thomas@monjalon.net> <20180510235836.1099-6-thomas@monjalon.net> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7Bit Cc: dev@dpdk.org, matan@mellanox.com, arybchenko@solarflare.com, stephen@networkplumber.org, Keith Wiles , Jasvinder Singh To: Ferruh Yigit Return-path: Received: from out3-smtp.messagingengine.com (out3-smtp.messagingengine.com [66.111.4.27]) by dpdk.org (Postfix) with ESMTP id 52A122C8 for ; Wed, 23 May 2018 12:14:28 +0200 (CEST) In-Reply-To: List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" 23/05/2018 12:09, Ferruh Yigit: > On 5/11/2018 12:58 AM, Thomas Monjalon wrote: > > A new hook function is added and called inside the PMDs at the end > > of the device probing: > > - in primary process, after allocating, init and config > > - in secondary process, after attaching and local init > > > > This new function is almost empty for now. > > It will be used later to add some post-initialization processing. > > > > For the PMDs calling the helpers rte_eth_dev_create() or > > rte_eth_dev_pci_generic_probe(), the hook rte_eth_dev_probing_finish() > > is called from here, and not in the PMD itself. > > > > Note that the helper rte_eth_dev_create() could be used more, > > especially for vdevs, avoiding some code duplication in PMDs. > > > > Cc: stable@dpdk.org > > > > Signed-off-by: Thomas Monjalon > > Reviewed-by: Andrew Rybchenko > > Reviewed-by: Stephen Hemminger > > Hi Thomas, > > This change forces PMDs to call rte_eth_dev_probing_finish() to have them in > proper state. But this requirement is not very clear and documented, it is easy > to miss! > > Does it make sense update release notes and highlight to say all PMDs should > call rte_eth_dev_probing_finish(), directly or via helper functions? You want to make PMD developers aware of this change? It's not a new feature, and not an API change, so I don't know where to write it.