From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Monjalon Subject: Re: [PATCH v4 00/23] Decouple ethdev from PCI device Date: Fri, 23 Dec 2016 15:28:54 +0100 Message-ID: <3994780.tjQ5v5j6qv@xps13> References: <1482332986-7599-1-git-send-email-jblunck@infradead.org> <10047221.5fZJY41fdK@xps13> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7Bit Cc: dev@dpdk.org, shreyansh.jain@nxp.com, david.marchand@6wind.com, stephen@networkplumber.org To: Jan Blunck Return-path: Received: from mail-wj0-f178.google.com (mail-wj0-f178.google.com [209.85.210.178]) by dpdk.org (Postfix) with ESMTP id 363D03DC for ; Fri, 23 Dec 2016 15:28:55 +0100 (CET) Received: by mail-wj0-f178.google.com with SMTP id sd9so68449241wjb.1 for ; Fri, 23 Dec 2016 06:28:55 -0800 (PST) In-Reply-To: <10047221.5fZJY41fdK@xps13> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" 2016-12-22 16:26, Thomas Monjalon: > I think it would easier to read if RTE_PCI_DEV macro was introduced at > the beginning with container_of macro and used in the "localize patches". > So the patches > [PATCH v4 19/23] drivers: Replace per-PMD macros with rte_eth_dev_to_pci() helper > and > [PATCH v4 20/23] drivers: Use rte_eth_dev_to_pci() helper > could be squashed in the "localize patches". After a private discussion, I've understood that my proposal was stupid :) RTE_PCI_DEV is used when the ethdev field is converted from pci_dev to device.