From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Hunt, David" Subject: Re: [PATCH v5 1/3] examples/eventdev_pipeline: added sample app Date: Thu, 6 Jul 2017 11:39:19 +0100 Message-ID: <5693accf-67e0-cf97-dea5-dae7d21ff971@intel.com> References: <1498751388-41571-2-git-send-email-david.hunt@intel.com> <1498830673-56759-1-git-send-email-david.hunt@intel.com> <1498830673-56759-2-git-send-email-david.hunt@intel.com> <20170703035755.GA6275@jerin> <25452a77-c5ae-97e8-b41a-5dfcb9fb19a6@intel.com> <20170705052853.GA8031@jerin> <20170706033120.GA10973@jerin> <7987361f-935e-a689-103d-276fe3a4c36e@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Cc: dev@dpdk.org, harry.van.haaren@intel.com, Gage Eads , Bruce Richardson To: Jerin Jacob Return-path: Received: from mga14.intel.com (mga14.intel.com [192.55.52.115]) by dpdk.org (Postfix) with ESMTP id 4E3642B96 for ; Thu, 6 Jul 2017 12:39:23 +0200 (CEST) In-Reply-To: <7987361f-935e-a689-103d-276fe3a4c36e@intel.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 6/7/2017 11:04 AM, Hunt, David wrote: > > > On 6/7/2017 4:31 AM, Jerin Jacob wrote: > >> Note: >> Change application to new name. >> >> checkpatch.sh >> ----------------- >> >> WARNING:EMBEDDED_FUNCTION_NAME: Prefer using '"%s...", __func__' to >> using 'consumer', this function's name, in a string >> #294: FILE: examples/eventdev_pipeline_sw_pmd/main.c:178: >> + printf("# consumer RX=%"PRIu64", time %"PRIu64 "ms, " >> >> WARNING:EMBEDDED_FUNCTION_NAME: Prefer using '"%s...", __func__' to >> using 'worker', this function's name, in a string >> #453: FILE: examples/eventdev_pipeline_sw_pmd/main.c:337: >> + printf(" worker %u thread done. RX=%zu TX=%zu\n", >> >> total: 0 errors, 2 warnings, 1078 lines checked > > These are false positives. The text in the messages are not meant to > be the function name. > If anything, I would prefer to change the function names to have " > _thread"? > Or perhaps, better still, change the function names to verbs, i.e. produce() consume(), do_work(). Regards, Dave.