From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Monjalon Subject: Re: [PATCH] doc: announce driver name changes Date: Fri, 22 Jul 2016 16:20:16 +0200 Message-ID: <5742496.VNQb1jlzTk@xps13> References: <1468083394-94907-1-git-send-email-pablo.de.lara.guarch@intel.com> <57921D2E.20604@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7Bit Cc: dev@dpdk.org, "Mcnamara, John" To: "De Lara Guarch, Pablo" , "Yigit, Ferruh" Return-path: Received: from mail-wm0-f44.google.com (mail-wm0-f44.google.com [74.125.82.44]) by dpdk.org (Postfix) with ESMTP id A2E1A5599 for ; Fri, 22 Jul 2016 16:20:18 +0200 (CEST) Received: by mail-wm0-f44.google.com with SMTP id i5so68707943wmg.0 for ; Fri, 22 Jul 2016 07:20:18 -0700 (PDT) In-Reply-To: List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" 2016-07-22 14:15, De Lara Guarch, Pablo: > From: Yigit, Ferruh > > For physical net devices, driver name is same as folder name (mlnx5, > > ixgbe ...) > > > > For virtual net devices, driver name is folder name with "eth_" prefix > > (eth_pcap, eth_ring) > > > > Driver names for net devices looks consistent already, I don't know > > about crypto devices but if crypto driver names are inconsistent what do > > you think renaming crypto drivers only? > > Sure, as long as virtual Ethernet devices are consistent, I think it is ok. > My main intention here was to have consistent (and short) driver names, > to call rte_eal_vdev_init (or --vdev in command line). It is important to rename every drivers with net and crypto prefixes. The long term goal is to have a consistent command line specification to pass parameters to any device/driver (virtual or physical).