From mboxrd@z Thu Jan 1 00:00:00 1970 From: Maxime Coquelin Subject: Re: [PATCH v2 0/2] vhost: introduce rte_vhost_vring_call() Date: Tue, 2 Jan 2018 11:27:02 +0100 Message-ID: References: <20180102093136.28690-1-stefanha@redhat.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Cc: Yuanhan Liu , Tetsuya Mukawa To: Stefan Hajnoczi , dev@dpdk.org Return-path: Received: from mx1.redhat.com (mx1.redhat.com [209.132.183.28]) by dpdk.org (Postfix) with ESMTP id 2CD867D30 for ; Tue, 2 Jan 2018 11:27:11 +0100 (CET) In-Reply-To: <20180102093136.28690-1-stefanha@redhat.com> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Hi Stefan, On 01/02/2018 10:31 AM, Stefan Hajnoczi wrote: > v2: > * Add internal vhost_vring_call() helper function [Maxime] > > These patches eliminate code duplication for vhost_virtqueue->callfd users by > introducing rte_vhost_vring_call() (public API) and vhost_vring_call() > (librte_vhost-internal API). > > Stefan Hajnoczi (2): > vhost: add vhost_vring_call() helper > vhost: introduce rte_vhost_vring_call() > > lib/librte_vhost/rte_vhost.h | 15 +++++++++++++++ > lib/librte_vhost/vhost.h | 12 ++++++++++++ > examples/vhost/virtio_net.c | 11 ++--------- > examples/vhost_scsi/vhost_scsi.c | 6 +++--- > lib/librte_vhost/vhost.c | 21 +++++++++++++++++++++ > lib/librte_vhost/virtio_net.c | 23 +++-------------------- > lib/librte_vhost/rte_vhost_version.map | 7 +++++++ > 7 files changed, 63 insertions(+), 32 deletions(-) > I just wonder whether tagging the new API as experimental is needed, but apart from that it looks good to me: Reviewed-by: Maxime Coquelin Thanks! Maxime