From mboxrd@z Thu Jan 1 00:00:00 1970 From: Ferruh Yigit Subject: Re: [PATCH v3 0/7] ethdev: add flow API object converter Date: Thu, 4 Oct 2018 15:25:58 +0100 Message-ID: References: <20180803132032.29038-1-adrien.mazarguil@6wind.com> <20180831085337.21419-1-adrien.mazarguil@6wind.com> <20180831113259.u5rceja7zpx5i27w@laranjeiro-vm.dev.6wind.com> <2339995.YGgu5CYcxV@xps> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit Cc: dev@dpdk.org, =?UTF-8?Q?N=c3=a9lio_Laranjeiro?= , Adrien Mazarguil To: Thomas Monjalon Return-path: Received: from mga07.intel.com (mga07.intel.com [134.134.136.100]) by dpdk.org (Postfix) with ESMTP id 16E551B496 for ; Thu, 4 Oct 2018 16:26:00 +0200 (CEST) In-Reply-To: <2339995.YGgu5CYcxV@xps> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 10/3/2018 9:31 PM, Thomas Monjalon wrote: > 31/08/2018 13:32, Nélio Laranjeiro: >> On Fri, Aug 31, 2018 at 11:00:57AM +0200, Adrien Mazarguil wrote: >>> This is a follow up to the "Flow API helpers enhancements" series submitted >>> almost a year ago [1]. The new title is due to the reduced scope of this >>> version. >>> >>> rte_flow_conv() is a flexible replacement to rte_flow_copy(), itself a >>> temporary solution pending something better [2]. It replaces a lot of >>> duplicated code found in testpmd and removes some of the maintenance burden >>> that developers tend to forget (me included) when modifying pattern >>> items or actions (updating app/test-pmd/config.c to be clear). >>> >>> This series was unearthed in order to complete the implementation of >>> RTE_FLOW_ACTION_TYPE_ENCAP_(VXLAN|NVGRE) in testpmd [3] without having to >>> duplicate existing code once again. >> >> Acked-by: Nelio Laranjeiro > > No more comment after one month. > Ferruh, I think it should go into next-net. Series applied to dpdk-next-net/master, thanks.