From mboxrd@z Thu Jan 1 00:00:00 1970 From: Shreyansh Jain Subject: Re: [PATCH v2 2/4] drivers: prefix global variables with module name Date: Mon, 8 Oct 2018 17:48:52 +0530 Message-ID: References: <20181004034047.26824-1-ferruh.yigit@intel.com> <20181005162612.31906-1-ferruh.yigit@intel.com> <20181005162612.31906-2-ferruh.yigit@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Cc: Reshma Pattan , Hemant Agrawal , Ashish Gupta , Fiona Trahe , Pablo de Lara , Akhil Goyal , Declan Doherty , Fan Zhang , Rahul Lakkireddy , Gaetan Rivet , Qi Zhang , Xiao Wang , Beilei Xing , Wenzhuo Lu , Konstantin Ananyev , Rasesh Mody , Harish Patil , Shahed Shaikh , Andrew Rybchenko , Jasvinder Singh , Cristian Dumitrescu , Keith Wiles Return-path: Received: from EUR04-VI1-obe.outbound.protection.outlook.com (mail-eopbgr80050.outbound.protection.outlook.com [40.107.8.50]) by dpdk.org (Postfix) with ESMTP id B55C258F6 for ; Mon, 8 Oct 2018 14:19:25 +0200 (CEST) In-Reply-To: <20181005162612.31906-2-ferruh.yigit@intel.com> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Friday 05 October 2018 09:56 PM, Ferruh Yigit wrote: > Some global variables are defined with generic names, add component name > as prefix to variables to prevent collusion with application variables. > > Signed-off-by: Ferruh Yigit > --- > drivers/bus/dpaa/include/fsl_fman_crc64.h | 8 ++-- [...] > > diff --git a/drivers/bus/dpaa/include/fsl_fman_crc64.h b/drivers/bus/dpaa/include/fsl_fman_crc64.h > index bf162f3ac..08ad63042 100644 > --- a/drivers/bus/dpaa/include/fsl_fman_crc64.h > +++ b/drivers/bus/dpaa/include/fsl_fman_crc64.h > @@ -42,9 +42,9 @@ struct fman_crc64_t { > uint64_t initial; > uint64_t table[1 << 8]; > }; > -extern struct fman_crc64_t FMAN_CRC64_ECMA_182; > +extern struct fman_crc64_t fman_crc64_ecma_182; > #define DECLARE_FMAN_CRC64_TABLE() \ > -struct fman_crc64_t FMAN_CRC64_ECMA_182 = { \ > +struct fman_crc64_t fman_crc64_ecma_182 = { \ > 0xFFFFFFFFFFFFFFFFULL, \ > { \ > 0x0000000000000000ULL, 0xb32e4cbe03a75f6fULL, \ > @@ -183,7 +183,7 @@ struct fman_crc64_t FMAN_CRC64_ECMA_182 = { \ > */ > static inline uint64_t fman_crc64_init(void) > { > - return FMAN_CRC64_ECMA_182.initial; > + return fman_crc64_ecma_182.initial; > } > > /* Updates the CRC with arbitrary data */ > @@ -192,7 +192,7 @@ static inline uint64_t fman_crc64_update(uint64_t crc, > { > uint8_t *p = data; > while (len--) > - crc = FMAN_CRC64_ECMA_182.table[(crc ^ *(p++)) & 0xff] ^ > + crc = fman_crc64_ecma_182.table[(crc ^ *(p++)) & 0xff] ^ > (crc >> 8); > return crc; > } [...] For the change above: Acked-by: Shreyansh Jain