Distributed Replicated Block Device (DRBD) development
 help / color / mirror / Atom feed
 messages from 2023-05-26 07:35:58 to 2024-06-11 06:28:33 UTC [more...]

move features flags into queue_limits
 2024-06-11  6:00 UTC  (29+ messages)
` [PATCH 01/26] sd: fix sd_is_zoned
` [PATCH 02/26] sd: move zone limits setup out of sd_read_block_characteristics
` [PATCH 03/26] loop: stop using loop_reconfigure_limits in __loop_clr_fd
` [PATCH 04/26] loop: always update discard settings in loop_reconfigure_limits
` [PATCH 05/26] loop: regularize upgrading the lock size for direct I/O
` [PATCH 06/26] loop: also use the default block size from an underlying block device
` [PATCH 07/26] loop: fold loop_update_rotational into loop_reconfigure_limits
` [PATCH 09/26] nbd: move setting the cache control flags to __nbd_set_size
` [PATCH 11/26] block: freeze the queue in queue_attr_store
` [PATCH 13/26] block: move cache control settings out of queue->flags
` [PATCH 14/26] block: move the nonrot flag to queue_limits
` [PATCH 15/26] block: move the add_random "
` [PATCH 17/26] block: move the stable_write "
` [PATCH 23/26] block: move the zone_resetall "
` [PATCH 24/26] block: move the pci_p2pdma "
` [PATCH 26/26] block: move the bounce flag into the feature field

[PATCH 1/2] crm-fence-peer.9.sh: fix parsing in_ccm crmd fields of node_state with Pacemaker 2.1.7
 2024-04-17 10:47 UTC  (6+ messages)
` [PATCH 2/2] crm-fence-peer.9.sh: use join of node_state to judge whether node is banned

[PATCH] lru_cache: Initialize hlist_head in lc_create
 2024-04-16 13:42 UTC  (2+ messages)

[PATCH] lru_cache: Initialize hlist_head in lc_create
 2024-03-11  3:44 UTC 

drbd atomic queue limits conversion
 2024-03-06 15:35 UTC  (17+ messages)
` [PATCH 1/7] drbd: pass the max_hw_sectors limit to blk_alloc_disk
` [PATCH 2/7] drbd: refactor drbd_reconsider_queue_parameters
` [PATCH 3/7] drbd: refactor the backing dev max_segments calculation
` [PATCH 4/7] drbd: merge drbd_setup_queue_param into drbd_reconsider_queue_parameters
` [PATCH 5/7] drbd: don't set max_write_zeroes_sectors in decide_on_discard_support
` [PATCH 6/7] drbd: split out a drbd_discard_supported helper
` [PATCH 7/7] drbd: atomically update queue limits in drbd_reconsider_queue_parameters
` [PATCH 0/7] drbd atomic queue limits conversion

atomic queue limit updates for stackable devices v2
 2024-03-05 13:38 UTC  (28+ messages)
` [PATCH 01/16] block: add a queue_limits_set helper
` [PATCH 02/16] block: add a queue_limits_stack_bdev helper
` [PATCH 03/16] dm: use queue_limits_set
` [PATCH 04/16] md: add queue limit helpers
` [PATCH 05/16] md/raid0: use the atomic queue limit update APIs
` [PATCH 06/16] md/raid1: "
` [PATCH 07/16] md/raid10: "
` [PATCH 08/16] md/raid5: "
` [PATCH 09/16] block: remove disk_stack_limits
` [PATCH 10/16] drbd: pass the max_hw_sectors limit to blk_alloc_disk
  ` drbd queue limits conversion ping
` [PATCH 11/16] drbd: refactor drbd_reconsider_queue_parameters
` [PATCH 12/16] drbd: refactor the backing dev max_segments calculation
` [PATCH 13/16] drbd: merge drbd_setup_queue_param into drbd_reconsider_queue_parameters
` [PATCH 14/16] drbd: don't set max_write_zeroes_sectors in decide_on_discard_support
` [PATCH 15/16] drbd: split out a drbd_discard_supported helper
` [PATCH 16/16] drbd: atomically update queue limits in drbd_reconsider_queue_parameters

[PATCH] configure.ac: Add an option to disable host udev version checks
 2024-03-05 10:00 UTC  (3+ messages)

[PATCH] drbd: fix function cast warnings in state machine
 2024-02-13 15:55 UTC  (2+ messages)

subscribe
 2024-01-31  9:56 UTC 

[Drbd-dev] [PATCH 0/3] lru_cache: Adjustments for lc_create()
 2024-01-10 11:40 UTC  (2+ messages)

[Drbd-dev] [PATCH] drbd: actlog: fix kernel-doc warnings and spelling
 2023-12-22 14:18 UTC  (2+ messages)

[Drbd-dev] [PATCH] drbd: when change susp_uuid[NEW] to true, make sure susp_uuid[OLD] is false
 2023-12-08  9:27 UTC  (8+ messages)

[Drbd-dev] [PATCH] drbd: Spelling fix in comment
 2023-10-23  6:31 UTC 

[Drbd-dev] BUG: looking up invalid subclass: 8
 2023-10-18 18:52 UTC 

[Drbd-dev] [PATCH] drbd: Clean up errors in drbd.h
 2023-10-13  3:37 UTC 

[Drbd-dev] [PATCH] kallsyms: Clean up errors in module.h
 2023-10-13  3:36 UTC 

[Drbd-dev] [PATCH v3 0/29] block: Make blkdev_get_by_*() return handle
 2023-10-02  7:57 UTC  (10+ messages)
` [Drbd-dev] [PATCH 04/29] drdb: Convert to use bdev_open_by_path()
` [Drbd-dev] [PATCH v4 0/29] block: Make blkdev_get_by_*() return handle

[Drbd-dev] [PATCH] drbd: Annotate struct fifo_buffer with __counted_by
 2023-09-29 19:21 UTC  (3+ messages)

[Drbd-dev] [PATCH 0/5] drbd: rename worker to sender
 2023-09-29 12:04 UTC  (7+ messages)
` [Drbd-dev] [PATCH 1/5] drbd: Rename per-connection "worker" thread to "sender"
` [Drbd-dev] [PATCH 2/5] drbd: Add new per-resource "worker" thread
` [Drbd-dev] [PATCH 3/5] drbd: Move connection independent work from "sender" to "worker"
` [Drbd-dev] [PATCH 4/5] drbd: Keep connection threads running while connection is up only
` [Drbd-dev] [PATCH 5/5] drbd: Get rid of conn_reconfig_start() and conn_reconfig_done()

[Drbd-dev] [PATCH v3 0/4] block: simplify with PAGE_SECTORS_SHIFT
 2023-09-18  5:55 UTC  (8+ messages)
` [Drbd-dev] [PATCH v3 1/4] drbd: use PAGE_SECTORS_SHIFT and PAGE_SECTORS
` [Drbd-dev] [PATCH v3 2/4] iomap: simplify iomap_init() with PAGE_SECTORS
` [Drbd-dev] [PATCH v3 3/4] dm bufio: simplify by using PAGE_SECTORS_SHIFT
` [Drbd-dev] [PATCH v3 4/4] zram: use generic PAGE_SECTORS and PAGE_SECTORS_SHIFT

[Drbd-dev] [PATCH] drbd: swap bvec_set_page len and offset
 2023-09-06 13:33 UTC  (2+ messages)

[Drbd-dev] DRBD broken in kernel 6.5 and 6.5.1
 2023-09-05 17:24 UTC  (3+ messages)

[Drbd-dev] DRBD broken in kernel 6.5 and 6.5.1
 2023-09-05 15:23 UTC  (2+ messages)

[Drbd-dev] [PATCH v2 0/29] block: Make blkdev_get_by_*() return handle
 2023-08-28 14:27 UTC  (9+ messages)
` [Drbd-dev] [PATCH 04/29] drdb: Convert to use bdev_open_by_path()

[Drbd-dev] [PATCH net-next v3 03/10] genetlink: remove userhdr from struct genl_info
 2023-08-15 12:49 UTC  (2+ messages)
  ` [Drbd-dev] [ovs-dev] "

[Drbd-dev] [PATCH net-next v2 03/10] genetlink: remove userhdr from struct genl_info
 2023-08-10 23:38 UTC 

[Drbd-dev] [PATCH net-next 03/10] genetlink: remove userhdr from struct genl_info
 2023-08-10  8:26 UTC  (4+ messages)

[Drbd-dev] [PATCH -next] drbd: Use helper put_drbd_dev() and get_drbd_dev()
 2023-08-09  1:32 UTC  (3+ messages)

[Drbd-dev] Improvement of output log
 2023-08-08 11:24 UTC 

[Drbd-dev] [PATCH -next] drbd: Remove unused function declarations
 2023-08-02 14:38 UTC 

[Drbd-dev] [PATCH -next] drbd: Annotate RCU pointers as __rcu to fix sparse errors
 2023-08-01  9:42 UTC 

[Drbd-dev] [bug report] drbd: destroy workqueue when drbd device was freed
 2023-07-31  8:15 UTC 

[Drbd-dev] [PATCH RFC 0/32] block: Make blkdev_get_by_*() return handle
 2023-07-31 11:13 UTC  (20+ messages)
` [Drbd-dev] [PATCH 01/32] block: Provide blkdev_get_handle_* functions
` [Drbd-dev] [PATCH 05/32] drdb: Convert to use blkdev_get_handle_by_path()
` [Drbd-dev] [PATCH 32/32] block: Rename blkdev_get_handle_by_*() and blkdev_handle_put()

[Drbd-dev] [PATCH -next] drbd: Remove unsued extern declarations
 2023-07-25 14:09 UTC 

[Drbd-dev] [PATCH net-next v5 10/16] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage()
 2023-06-23 22:55 UTC 

[Drbd-dev] [PATCH net-next v4 10/15] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage()
 2023-06-23 11:44 UTC 

[Drbd-dev] [PATCH net-next v3 14/18] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage()
 2023-06-20 14:53 UTC  (2+ messages)
` [Drbd-dev] [PATCH net-next v3 15/18] drdb: Send an entire bio in a single sendmsg

[Drbd-dev] [PATCH net-next v2 13/17] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage()
 2023-06-17 12:11 UTC  (2+ messages)
` [Drbd-dev] [PATCH net-next v2 14/17] drdb: Send an entire bio in a single sendmsg

[Drbd-dev] [PATCH][next] drbd: remove redundant assignment to variable owords
 2023-06-16 16:45 UTC 

[Drbd-dev] [PATCH net-next 13/17] drbd: Use sendmsg(MSG_SPLICE_PAGES) rather than sendpage()
 2023-06-16 16:12 UTC  (2+ messages)
` [Drbd-dev] [PATCH net-next 14/17] drdb: Send an entire bio in a single sendmsg

[Drbd-dev] [PATCH] drbd: stop defining __KERNEL_SYSCALLS__
 2023-06-05 17:21 UTC  (3+ messages)

[Drbd-dev] [PATCH v2 0/5] block: simplify with PAGE_SECTORS_SHIFT
 2023-05-26  9:26 UTC  (14+ messages)
` [Drbd-dev] [PATCH v2 1/5] block: annotate bdev_disk_changed() deprecation with a symbol namespace
` [Drbd-dev] [PATCH v2 2/5] drbd: use PAGE_SECTORS_SHIFT and PAGE_SECTORS
` [Drbd-dev] [PATCH v2 3/5] iomap: simplify iomap_init() with PAGE_SECTORS
` [Drbd-dev] [PATCH v2 4/5] dm bufio: simplify by using PAGE_SECTORS_SHIFT
` [Drbd-dev] [PATCH v2 5/5] zram: use generic PAGE_SECTORS and PAGE_SECTORS_SHIFT


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox