From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jingoo Han Subject: Re: [PATCH 1/7] drm: Renaming DP training vswing pre emph defines Date: Thu, 28 Aug 2014 09:34:35 +0900 Message-ID: <00bc01cfc257$d7adf940$8709ebc0$%han@samsung.com> References: <1407495226-12620-1-git-send-email-sonika.jindal@intel.com> <1407495226-12620-2-git-send-email-sonika.jindal@intel.com> <20140826112818.GA31534@ulmo> <53FD5F08.4090406@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-reply-to: <53FD5F08.4090406@intel.com> Content-language: ko List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: "'Jindal, Sonika'" , 'Thierry Reding' Cc: intel-gfx@lists.freedesktop.org, 'Jingoo Han' , dri-devel@lists.freedesktop.org List-Id: dri-devel@lists.freedesktop.org On Wednesday, August 27, 2014 1:31 PM, Jindal, Sonika wrote: > On 8/26/2014 4:58 PM, Thierry Reding wrote: > > On Fri, Aug 08, 2014 at 04:23:40PM +0530, sonika.jindal@intel.com wrote: > >> From: Sonika Jindal > >> > >> Adding new defines, older one will be removed in the last patch in the series. > >> This is to rename the defines to have levels instead of values for vswing and > >> pre-emph levels as the values may differ in other scenarios like low vswing of > >> eDP1.4 where the values are different. > >> > >> Done using following cocci patch for each define: > >> @@ > >> @@ > >> > >> # define DP_TRAIN_VOLTAGE_SWING_400 (0 << 0) > >> + # define DP_TRAIN_VOLTAGE_SWING_LEVEL_0 (0 << 0) > > > > Could this perhaps be simply: > > > > #define DP_TRAIN_VOLTAGE_SWING(x) ((x) << 0) > > > > As it is, there's no information about the value within the symbolic > > name anyway, so _LEVEL_* really isn't that useful and keeping several > > macros for each value seems isn't either. > > > I feel _LEVEL_* makes it more readable and since there are only 4 values > possible, it is ok to have 4 different macros for readability purpose. > What do you think? (+cc Damien Lespiau) Personally, I also think that LEVEL_* looks more readable. Best regards, Jingoo Han > > An alternative would be to provide a second set of defines for eDP 1.4 > > where the name implies the meaning and then use them as appropriate. > > > > Thierry > > > _______________________________________________ > dri-devel mailing list > dri-devel@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/dri-devel