dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Dmitry Osipenko <digetx@gmail.com>
To: Thierry Reding <thierry.reding@gmail.com>
Cc: linux-tegra@vger.kernel.org, dri-devel@lists.freedesktop.org,
	"Michał Mirosław" <mirq-linux@rere.qmqm.pl>
Subject: Re: [PATCH libdrm v2 05/25] tegra: Add flink helpers
Date: Thu, 24 Feb 2022 20:18:00 +0300	[thread overview]
Message-ID: <0a550dde-7c06-c61d-2cbf-e63ad1a7dcc5@gmail.com> (raw)
In-Reply-To: <20220217191625.2534521-6-thierry.reding@gmail.com>

17.02.2022 22:16, Thierry Reding пишет:
> +int drm_tegra_bo_get_name(struct drm_tegra_bo *bo, uint32_t *name);
> +int drm_tegra_bo_open(struct drm_tegra *drm, uint32_t name, uint32_t flags,
> +                      struct drm_tegra_bo **bop);

drm_tegra_bo_open() isn't a very good name for a function. How will you
name dmabuf and handle variants?

In grate-drive we're using these names:

drm_tegra_bo_from_name
drm_tegra_bo_from_dmabuf
drm_tegra_bo_from_handle

I suggest to use more meaningful function names before will be too late,
especially given that this is the upstream libdrm.

  reply	other threads:[~2022-02-24 17:18 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-02-17 19:16 [PATCH libdrm v2 00/25] Update Tegra support Thierry Reding
2022-02-17 19:16 ` [PATCH libdrm v2 01/25] tegra: Indent according to .editorconfig Thierry Reding
2022-02-17 19:16 ` [PATCH libdrm v2 02/25] tegra: Remove unused IOCTL implementations Thierry Reding
2022-02-24 16:52   ` Dmitry Osipenko
2022-02-17 19:16 ` [PATCH libdrm v2 03/25] tegra: Extract common buffer object allocation code Thierry Reding
2022-02-17 19:16 ` [PATCH libdrm v2 04/25] tegra: Fix mmap() of GEM buffer objects Thierry Reding
2022-02-17 19:16 ` [PATCH libdrm v2 05/25] tegra: Add flink helpers Thierry Reding
2022-02-24 17:18   ` Dmitry Osipenko [this message]
2022-02-17 20:02 ` [PATCH libdrm v2 00/25] Update Tegra support Dmitry Osipenko
2022-02-17 21:37   ` Thierry Reding
2022-02-18 14:16     ` Dmitry Osipenko
2022-02-18 19:49       ` Dmitry Osipenko
2022-02-18  9:31 ` Mikko Perttunen
2022-02-21 20:29   ` Dmitry Osipenko
2022-02-22  8:41     ` Mikko Perttunen
2022-02-23 15:01       ` Thierry Reding

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0a550dde-7c06-c61d-2cbf-e63ad1a7dcc5@gmail.com \
    --to=digetx@gmail.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=mirq-linux@rere.qmqm.pl \
    --cc=thierry.reding@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox