From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Tomi Valkeinen <tomi.valkeinen@ti.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v2 03/22] drm/omap: dss: hdmi: Rename hdmi_display_(set|check)_timing() functions
Date: Sun, 19 Aug 2018 13:59:00 +0300 [thread overview]
Message-ID: <11900322.0Th8LOgzXJ@avalon> (raw)
In-Reply-To: <22d1de8a-5b55-9e1a-3dfe-20b634009060@ti.com>
Hi Tomi,
On Monday, 13 August 2018 13:50:18 EEST Tomi Valkeinen wrote:
> On 06/08/18 23:36, Laurent Pinchart wrote:
> > The two functions implement the .set_timings() and .check_timings()
> > operations. Rename them to hdmi_disply_set_timings() and
> > hdmi_display_check_timings() respectively to match the operations names
> > and make searching the source code easier.
> >
> > Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> > Reviewed-by: Sebastian Reichel <sebastian.reichel@collabora.co.uk>
> > ---
> >
> > drivers/gpu/drm/omapdrm/displays/encoder-tfp410.c | 2 --
> > drivers/gpu/drm/omapdrm/dss/hdmi4.c | 12 ++++++------
> > drivers/gpu/drm/omapdrm/dss/hdmi5.c | 12 ++++++------
> > 3 files changed, 12 insertions(+), 14 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/omapdrm/displays/encoder-tfp410.c
> > b/drivers/gpu/drm/omapdrm/displays/encoder-tfp410.c index
> > 29bda16afbdc..54f133d7da07 100644
> > --- a/drivers/gpu/drm/omapdrm/displays/encoder-tfp410.c
> > +++ b/drivers/gpu/drm/omapdrm/displays/encoder-tfp410.c
> > @@ -92,8 +92,6 @@ static void tfp410_set_timings(struct omap_dss_device
> > *dssdev,>
> > struct panel_drv_data *ddata = to_panel_data(dssdev);
> > struct omap_dss_device *src = dssdev->src;
> >
> > - tfp410_fix_timings(vm);
>
> ?
Oops :-/ I don't know how this ended up here, it should be in 04/22. I'll fix
that.
--
Regards,
Laurent Pinchart
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2018-08-19 10:58 UTC|newest]
Thread overview: 53+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-08-06 20:22 [PATCH v2 00/21] omapdrm: Rework the HPD-related operations Laurent Pinchart
2018-08-06 20:22 ` [PATCH v2 01/21] drm/omap: dss: Remove unused omap_dss_driver operations Laurent Pinchart
2018-08-06 20:22 ` [PATCH v2 02/21] drm/omap: dss: Remove omap_dss_driver .[gs]et_mirror operations Laurent Pinchart
2018-08-06 20:22 ` [PATCH v2 03/21] drm/omap: Remove unnecessary display output sanity checks Laurent Pinchart
2018-08-06 20:22 ` [PATCH v2 04/21] drm/omap: Check omap_dss_device type based on the output_type field Laurent Pinchart
2018-08-06 20:28 ` [PATCH v2.1 " Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 00/22] omapdrm: Rework the timing-related operations Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 01/22] drm/omap: Pass both output and display omap_dss_device to connector init Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 02/22] drm/omap: Determine connector type directly in omap_connector.c Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 03/22] drm/omap: dss: hdmi: Rename hdmi_display_(set|check)_timing() functions Laurent Pinchart
2018-08-13 10:50 ` Tomi Valkeinen
2018-08-19 10:59 ` Laurent Pinchart [this message]
2018-08-06 20:36 ` [PATCH v2 04/22] drm/omap: Make the video_mode pointer to .set_timings() const Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 05/22] drm/omap: Remove duplicate calls to .set_timings() operation Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 06/22] drm/omap: Remove unneeded fallback for missing .check_timings() Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 07/22] drm/omap: Don't store video mode internally for external encoders Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 08/22] drm/omap: Store bus flags in the omap_dss_device structure Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 09/22] drm/omap: Don't call .check_timings() operation recursively Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 10/22] drm/omap: Query timing information from analog TV encoder Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 11/22] drm/omap: Remove .get_timings() operation from display connectors Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 12/22] drm/omap: panels: Don't modify fixed timings Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 13/22] drm/omap: Move bus flag hack to encoder implementation Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 14/22] drm/omap: Split mode fixup and mode set from encoder enable Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 15/22] drm/omap: Call dispc timings check operation directly Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 16/22] drm/omap: dpi: Don't fixup video mode in dpi_set_mode() Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 17/22] drm/omap: dsi: Fixup video mode in .set_config() operation Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 18/22] drm/omap: hdmi: Constify video mode and related pointers Laurent Pinchart
2018-08-06 20:36 ` [PATCH v2 19/22] drm/omap: sdi: Fixup video mode in .check_timings() operation Laurent Pinchart
2018-08-06 20:37 ` [PATCH v2 20/22] drm/omap: venc: " Laurent Pinchart
2018-08-06 20:37 ` [PATCH v2 21/22] drm/omap: Store CRTC timings in .set_timings() operation Laurent Pinchart
2018-08-06 20:37 ` [PATCH v2 22/22] drm/omap: Don't call .set_timings() operation recursively Laurent Pinchart
2018-08-13 11:12 ` [PATCH v2 00/22] omapdrm: Rework the timing-related operations Tomi Valkeinen
2018-08-13 19:24 ` Sebastian Reichel
2018-08-19 10:53 ` Laurent Pinchart
2018-08-20 11:24 ` Tomi Valkeinen
2018-08-20 11:33 ` Laurent Pinchart
2018-08-06 20:22 ` [PATCH v2 05/21] drm/omap: connector-hdmi: Convert to the GPIO descriptors API Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 06/21] drm/omap: encoder-tfp410: " Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 07/21] drm/omap: panel-nec-nl8048hl11: " Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 08/21] drm/omap: panel-sony-acx565akm: " Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 09/21] drm/omap: panel-tpo-td028ttec1: Drop unneeded linux/gpio.h header Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 10/21] drm/omap: panel-tpo-td043mtea1: Convert to the GPIO descriptors API Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 11/21] drm/omap: Move most omap_dss_driver operations to omap_dss_device_ops Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 12/21] drm/omap: dss: Add device operations flags Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 13/21] drm/omap: Don't call .detect() operation recursively Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 14/21] drm/omap: Don't call HPD registration operations recursively Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 15/21] drm/omap: Remove unneeded safety checks in the HPD operations Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 16/21] drm/omap: Merge HPD enable operation with HPD callback registration Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 17/21] drm/omap: Move HPD disconnection handling to omap_connector Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 18/21] drm/omap: Don't call EDID read operation recursively Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 19/21] drm/omap: Get from CRTC to display device directly Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 20/21] drm/omap: Pass both output and display omap_dss_device to encoder init Laurent Pinchart
2018-08-06 20:23 ` [PATCH v2 21/21] drm/omap: Don't call HDMI mode and infoframe operations recursively Laurent Pinchart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=11900322.0Th8LOgzXJ@avalon \
--to=laurent.pinchart@ideasonboard.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=tomi.valkeinen@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox