dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Michel Dänzer" <michel@daenzer.net>
To: Steven Fuerst <svfuerst@gmail.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v3 1/3] Rename i2f() to int2float(), and make it global so one copy can be removed.
Date: Thu, 16 Aug 2012 10:00:13 +0200	[thread overview]
Message-ID: <1345104013.17900.641.camel@thor.local> (raw)
In-Reply-To: <1345068436-19885-1-git-send-email-svfuerst@gmail.com>

On Mit, 2012-08-15 at 15:07 -0700, Steven Fuerst wrote: 
> Remove the copy of i2f() in r600_blit_kms.c
> We rename the function to something longer now that it is a global
> symbol.  This reduces the likelyhood of unintended clashes later.
> 
> This might be a candidate for inclusion inside general drm infrastructure.
> However, at the moment only the radeon driver uses it.
> 
> Signed-off-by: Steven Fuerst <svfuerst@gmail.com>

For the series:

Reviewed-by: Michel Dänzer <michel.daenzer@amd.com>


-- 
Earthling Michel Dänzer           |                   http://www.amd.com
Libre software enthusiast         |          Debian, X and DRI developer

      parent reply	other threads:[~2012-08-16  8:00 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-08-15 22:07 [PATCH v3 1/3] Rename i2f() to int2float(), and make it global so one copy can be removed Steven Fuerst
2012-08-15 22:07 ` [PATCH v3 2/3] Replace int2float() with an optimized version Steven Fuerst
2012-08-15 22:07 ` [PATCH v3 3/3] Annotate int2float() as being a pure function Steven Fuerst
2012-08-16  8:00 ` Michel Dänzer [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1345104013.17900.641.camel@thor.local \
    --to=michel@daenzer.net \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=svfuerst@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox