From: "Michel Dänzer" <michel@daenzer.net>
To: Alex Deucher <alexdeucher@gmail.com>
Cc: dri-devel@lists.freedesktop.org,
Dan Carpenter <dan.carpenter@oracle.com>
Subject: Re: [PATCH] drm/radeon: fix endian bugs in radeon_atom_get_clock_dividers()
Date: Mon, 22 Apr 2013 18:25:45 +0200 [thread overview]
Message-ID: <1366647945.4530.191.camel@thor.local> (raw)
In-Reply-To: <CADnq5_Of5GJDFagzZ77geB8VmfDcUqy+mvEMvSf-ziOjt9KFmQ@mail.gmail.com>
On Mon, 2013-04-22 at 12:15 -0400, Alex Deucher wrote:
> On Mon, Apr 22, 2013 at 11:29 AM, Michel Dänzer <michel@daenzer.net> wrote:
> > On Mon, 2013-04-22 at 10:18 -0400, Alex Deucher wrote:
> >> On Mon, Apr 22, 2013 at 10:08 AM, Dan Carpenter
> >> <dan.carpenter@oracle.com> wrote:
> >> > On Mon, Apr 22, 2013 at 10:03:13AM -0400, alexdeucher@gmail.com wrote:
> >> >> From: Alex Deucher <alexander.deucher@amd.com>
> >> >>
> >> >> Reported-by: Dan Carpenter <dan.carpenter@oracle.com>
> >> >> Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
> >> >> ---
> >> >> drivers/gpu/drm/radeon/atombios.h | 2 ++
> >> >> drivers/gpu/drm/radeon/radeon_atombios.c | 6 ++----
> >> >> 2 files changed, 4 insertions(+), 4 deletions(-)
> >> >>
> >> >> diff --git a/drivers/gpu/drm/radeon/atombios.h b/drivers/gpu/drm/radeon/atombios.h
> >> >> index 4b04ba3..de678dd 100644
> >> >> --- a/drivers/gpu/drm/radeon/atombios.h
> >> >> +++ b/drivers/gpu/drm/radeon/atombios.h
> > [...]
> >> >> @@ -491,6 +492,7 @@ typedef struct _COMPUTE_MEMORY_ENGINE_PLL_PARAMETERS_V5
> >> >> {
> >> >> ATOM_COMPUTE_CLOCK_FREQ ulClock; //Input Parameter
> >> >> ATOM_S_MPLL_FB_DIVIDER ulFbDiv; //Output Parameter
> >> >> + ULONG ulClockFbDiv;
> >> >> };
> >> >> UCHAR ucRefDiv; //Output Parameter
> >> >> UCHAR ucPostDiv; //Output Parameter
> >
> > This may just be a nitpick, but the location and name of the new union
> > member is slightly confusing: It suggests that it's some kind of
> > combination of the ulClock and ulFbDiv members, when it's just an
> > alternative representation of ulClock. I'd suggest moving up the new
> > member, clarifying its name and/or adding a comment explaining what it
> > is for.
> > Looks good to me other than that.
>
> Sounds good. v3 attached.
Thanks.
Reviewed-by: Michel Dänzer <michel.daenzer@amd.com>
--
Earthling Michel Dänzer | http://www.amd.com
Libre software enthusiast | Debian, X and DRI developer
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
prev parent reply other threads:[~2013-04-22 16:25 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-18 18:47 drm/radeon: add radeon_atom_get_clock_dividers helper Dan Carpenter
2013-04-19 15:45 ` Christian König
2013-04-22 14:03 ` [PATCH] drm/radeon: fix endian bugs in radeon_atom_get_clock_dividers() alexdeucher
2013-04-22 14:08 ` Dan Carpenter
2013-04-22 14:18 ` Alex Deucher
2013-04-22 14:31 ` Dan Carpenter
2013-04-22 14:34 ` Alex Deucher
2013-04-22 15:29 ` Michel Dänzer
2013-04-22 16:15 ` Alex Deucher
2013-04-22 16:25 ` Michel Dänzer [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1366647945.4530.191.camel@thor.local \
--to=michel@daenzer.net \
--cc=alexdeucher@gmail.com \
--cc=dan.carpenter@oracle.com \
--cc=dri-devel@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox