From: David Herrmann <dh.herrmann@gmail.com>
To: dri-devel@lists.freedesktop.org
Subject: [PULL 2/3] drm-minor
Date: Sun, 16 Mar 2014 14:31:05 +0100 [thread overview]
Message-ID: <1394976666-4055-3-git-send-email-dh.herrmann@gmail.com> (raw)
In-Reply-To: <1394976666-4055-1-git-send-email-dh.herrmann@gmail.com>
Hi Dave
This series contains several cleanups for the DRM-minor handling. All but the
last one reviewed by Daniel and tested by Thierry. Initially, the series
included patches to convert minor-handling to a common base-ID, but have
been NACKed by Daniel so I dropped them and only included the main part in the
last patch. With this in place, drm_global_mutex is no longer needed for
minor-handling (but still for device unregistration..).
There are some pending patches that try to remove the global mutex entirely, but
they need some more reviews and thus are not included.
Thanks
David
The following changes since commit 786a7828bc74b9b1466e83abb200b75f80f94121:
Merge branch 'drm-next-3.15' of git://people.freedesktop.org/~deathsimple/linux into drm-next (2014-03-05 14:52:19 +1000)
are available in the git repository at:
git://people.freedesktop.org/~dvdhrm/linux drm-minor
for you to fetch changes up to 0d639883ee26359e1bf38195df1dbca0f879e239:
drm: make minors independent of global lock (2014-03-16 12:54:21 +0100)
----------------------------------------------------------------
David Herrmann (14):
drm: group dev-lifetime related members
drm: skip redundant minor-lookup in open path
drm: remove unused DRM_MINOR_UNASSIGNED
drm: turn DRM_MINOR_* into enum
drm: provide device-refcount
drm: add minor-lookup/release helpers
drm: allocate minors early
drm: move drm_put_minor() to drm_minor_free()
drm: rename drm_unplug/get_minor() to drm_minor_register/unregister()
drm: remove unneeded #ifdef CONFIG_DEBUGFS
drm: remove redundant minor->device field
drm: coding-style fixes in minor handling
drm: inline drm_minor_get_id()
drm: make minors independent of global lock
drivers/gpu/drm/drm_drv.c | 4 +-
drivers/gpu/drm/drm_fops.c | 70 ++++-----
drivers/gpu/drm/drm_pci.c | 2 +-
drivers/gpu/drm/drm_platform.c | 2 +-
drivers/gpu/drm/drm_stub.c | 348 +++++++++++++++++++++++++----------------
drivers/gpu/drm/drm_usb.c | 2 +-
drivers/gpu/drm/tegra/bus.c | 2 +-
include/drm/drmP.h | 41 +++--
8 files changed, 278 insertions(+), 193 deletions(-)
next prev parent reply other threads:[~2014-03-16 13:31 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-03-16 13:31 [PULL 0/3] Pending patches for 3.15 David Herrmann
2014-03-16 13:31 ` [PULL 1/3] drm-fixes David Herrmann
2014-03-16 13:31 ` David Herrmann [this message]
2014-03-16 13:31 ` [PULL 3/3] drm-anon David Herrmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1394976666-4055-3-git-send-email-dh.herrmann@gmail.com \
--to=dh.herrmann@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox