dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
To: dri-devel@lists.freedesktop.org
Cc: intel-gfx@lists.freedesktop.org
Subject: [PATCH 00/12] drm/atomic: Rename async to nonblocking.
Date: Tue, 26 Apr 2016 16:11:33 +0200	[thread overview]
Message-ID: <1461679905-30177-1-git-send-email-maarten.lankhorst@linux.intel.com> (raw)

Userspace calls the atomic ioctl with DRM_MODE_ATOMIC_NONBLOCK
when it doesn't want the ioctl to block for completion.

In the kernel it's called async commit, which is confusing. The legacy
pageflip and atomic ioctl also have a flag DRM_MODE_PAGE_FLIP_ASYNC
which means that the flip should happen as soon as possible,
even if it causes tearing.

Because of this we should rename async commit to nonblocking commit,
which should reduce a lot of the confusion.

This is done partially with a cocci script, and inspection by hand
because cocci doesn't patch comments.

Maarten Lankhorst (12):
  drm/atomic: Rename async parameter to nonblocking.
  drm/atomic: Rename drm_atomic_async_commit to nonblocking.
  drm/arm/hdlcd: Rename async to nonblock.
  drm/exynos: Rename async to nonblock.
  drm/msm: Rename async to nonblock.
  drm/omapdrm: Rename async to nonblock.
  drm/rcar-du: Rename async to nonblock.
  drm/sti: Rename async to nonblock.
  drm/tegra: Rename async to nonblock.
  drm/rockchip: Rename async to nonblock.
  drm/vc4: Rename async to nonblock.
  drm/i915: Rename async to nonblock.

 drivers/gpu/drm/arm/hdlcd_drv.c            |  2 +-
 drivers/gpu/drm/drm_atomic.c               | 12 +++++------
 drivers/gpu/drm/drm_atomic_helper.c        | 34 +++++++++++++++---------------
 drivers/gpu/drm/exynos/exynos_drm_drv.c    |  4 ++--
 drivers/gpu/drm/exynos/exynos_drm_drv.h    |  2 +-
 drivers/gpu/drm/i915/intel_display.c       | 16 +++++++-------
 drivers/gpu/drm/msm/msm_atomic.c           |  9 ++++----
 drivers/gpu/drm/msm/msm_drv.h              |  2 +-
 drivers/gpu/drm/omapdrm/omap_drv.c         |  4 ++--
 drivers/gpu/drm/rcar-du/rcar_du_kms.c      |  5 +++--
 drivers/gpu/drm/rockchip/rockchip_drm_fb.c |  6 +++---
 drivers/gpu/drm/sti/sti_drv.c              |  6 +++---
 drivers/gpu/drm/tegra/drm.c                |  6 +++---
 drivers/gpu/drm/vc4/vc4_kms.c              |  6 +++---
 include/drm/drm_atomic.h                   |  2 +-
 include/drm/drm_atomic_helper.h            |  2 +-
 include/drm/drm_crtc.h                     |  8 +++----
 17 files changed, 63 insertions(+), 63 deletions(-)

-- 
2.5.5

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

             reply	other threads:[~2016-04-26 14:11 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-26 14:11 Maarten Lankhorst [this message]
2016-04-26 14:11 ` [PATCH 01/12] drm/atomic: Rename async parameter to nonblocking Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 02/12] drm/atomic: Rename drm_atomic_async_commit " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 03/12] drm/arm/hdlcd: Rename async to nonblock Maarten Lankhorst
2016-04-26 15:03   ` Liviu Dudau
2016-04-26 14:11 ` [PATCH 04/12] drm/exynos: " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 05/12] drm/msm: " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 06/12] drm/omapdrm: " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 07/12] drm/rcar-du: " Maarten Lankhorst
2016-04-27 15:31   ` Laurent Pinchart
2016-04-26 14:11 ` [PATCH 08/12] drm/sti: " Maarten Lankhorst
2016-04-27  7:17   ` Vincent ABRIOU
2016-04-26 14:11 ` [PATCH 09/12] drm/tegra: " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 10/12] drm/rockchip: " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 11/12] drm/vc4: " Maarten Lankhorst
2016-04-26 14:11 ` [PATCH 12/12] drm/i915: " Maarten Lankhorst
2016-04-26 14:34 ` [PATCH 00/12] drm/atomic: Rename async to nonblocking Daniel Vetter
2016-05-02 14:39   ` Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1461679905-30177-1-git-send-email-maarten.lankhorst@linux.intel.com \
    --to=maarten.lankhorst@linux.intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox