From mboxrd@z Thu Jan 1 00:00:00 1970 From: =?UTF-8?Q?Noralf_Tr=c3=b8nnes?= Subject: Re: [PATCH v3 20/23] drm/qxl: add mode/framebuffer check functions Date: Fri, 25 Jan 2019 18:30:30 +0100 Message-ID: <1df6fc76-1805-c434-4a4e-e6483d1bde7b@tronnes.org> References: <20190118122020.27596-1-kraxel@redhat.com> <20190118122020.27596-21-kraxel@redhat.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit Return-path: In-Reply-To: <20190118122020.27596-21-kraxel@redhat.com> Sender: linux-kernel-owner@vger.kernel.org To: Gerd Hoffmann , dri-devel@lists.freedesktop.org Cc: David Airlie , open list , "open list:DRM DRIVER FOR QXL VIRTUAL GPU" , "open list:DRM DRIVER FOR QXL VIRTUAL GPU" , Dave Airlie List-Id: dri-devel@lists.freedesktop.org Den 18.01.2019 13.20, skrev Gerd Hoffmann: > Add a helper functions to check video modes. Also add a helper to check > framebuffer buffer objects, using the former for consistency. That way > we should not fail in qxl_primary_atomic_check() because video modes > which are too big will not be added to the mode list in the first place. > > Signed-off-by: Gerd Hoffmann > --- Acked-by: Noralf Trønnes