From: Daniel Vetter <daniel@ffwll.ch>
To: Sumit Semwal <sumit.semwal@linaro.org>
Cc: Dave Airlie <airlied@gmail.com>, Rob Clark <rob.clark@linaro.org>,
patches@linaro.org, dri-devel@lists.freedesktop.org,
linaro-mm-sig@lists.linaro.org, daniel@ffwll.ch,
airlied@redhat.com, linux-media@vger.kernel.org
Subject: Re: [Linaro-mm-sig] [PATCH] dma-buf: add get_dma_buf()
Date: Sun, 18 Mar 2012 20:04:53 +0100 [thread overview]
Message-ID: <20120318190453.GJ4286@phenom.ffwll.local> (raw)
In-Reply-To: <CAO_48GH_zkgQQgvbiD8MQ5dHb3pD5mTSxtA_z4+KhGQJWQhC1g@mail.gmail.com>
On Sun, Mar 18, 2012 at 01:12:22PM +0530, Sumit Semwal wrote:
> On 16 March 2012 23:23, Dave Airlie <airlied@gmail.com> wrote:
> > On Fri, Mar 16, 2012 at 4:04 PM, Rob Clark <rob.clark@linaro.org> wrote:
> >> From: Rob Clark <rob@ti.com>
> >>
> >> Works in a similar way to get_file(), and is needed in cases such as
> >> when the exporter needs to also keep a reference to the dmabuf (that
> >> is later released with a dma_buf_put()), and possibly other similar
> >> cases.
> >>
> >> Signed-off-by: Rob Clark <rob@ti.com>
> >
> > Reviewed-by: Dave Airlie <airlied@redhat.com>
> >
> Thanks; pulled into for-next.
I'm back from vacation and already grumpily complaining about dma-buf
patches ;-) For consistency with dma_buf_put we should call this
dma_buf_get instead of get_dma_buf ... I'll write a bikeshed patch on top
of your tree.
-Daniel
--
Daniel Vetter
Mail: daniel@ffwll.ch
Mobile: +41 (0)79 365 57 48
next prev parent reply other threads:[~2012-03-18 19:04 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-03-16 16:04 [PATCH] dma-buf: add get_dma_buf() Rob Clark
2012-03-16 17:53 ` [Linaro-mm-sig] " Dave Airlie
2012-03-18 7:42 ` Sumit Semwal
2012-03-18 19:04 ` Daniel Vetter [this message]
2012-03-18 19:15 ` Daniel Vetter
2012-05-22 13:47 ` Tomasz Stanislawski
2012-05-22 14:32 ` Daniel Vetter
2012-05-22 15:00 ` Tomasz Stanislawski
2012-05-22 15:05 ` Daniel Vetter
2012-05-22 15:13 ` Dave Airlie
2012-05-22 17:37 ` Rob Clark
-- strict thread matches above, loose matches on Subject: below --
2012-03-16 20:02 Rob Clark
2012-03-17 4:11 ` [Linaro-mm-sig] " Kyungmin Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20120318190453.GJ4286@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=airlied@gmail.com \
--cc=airlied@redhat.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=linaro-mm-sig@lists.linaro.org \
--cc=linux-media@vger.kernel.org \
--cc=patches@linaro.org \
--cc=rob.clark@linaro.org \
--cc=sumit.semwal@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox