From mboxrd@z Thu Jan 1 00:00:00 1970 From: Chris Wilson Subject: Re: [PATCH v3] drm/i915: bounds check execbuffer relocation count Date: Tue, 12 Mar 2013 09:07:46 +0000 Message-ID: <20130312090746.GD31324@cantiga.alporthouse.com> References: <20130312003145.GA28993@www.outflux.net> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: <20130312003145.GA28993@www.outflux.net> Sender: linux-kernel-owner@vger.kernel.org To: Kees Cook Cc: linux-kernel@vger.kernel.org, Daniel Vetter , David Airlie , dri-devel@lists.freedesktop.org, intel-gfx@lists.freedesktop.org, Julien Tinnes , marcheu@chromium.org List-Id: dri-devel@lists.freedesktop.org On Mon, Mar 11, 2013 at 05:31:45PM -0700, Kees Cook wrote: > It is possible to wrap the counter used to allocate the buffer for > relocation copies. This could lead to heap writing overflows. > > CVE-2013-0913 > > v3: collapse test, improve comment > v2: move check into validate_exec_list > > Signed-off-by: Kees Cook > Reported-by: Pinkie Pie > Cc: stable@vger.kernel.org Looks good to me. The only bikeshed that remains is whether we should just collapse the two variables into one, but the current 'max - count' is more idiomatic and so preferrable. Reviewed-by: Chris Wilson -Chris -- Chris Wilson, Intel Open Source Technology Centre