From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 2/4] drm: Add plane type property Date: Tue, 4 Mar 2014 13:38:52 +0100 Message-ID: <20140304123614.GY17001@phenom.ffwll.local> References: <1393539283-5901-1-git-send-email-matthew.d.roper@intel.com> <1393539283-5901-3-git-send-email-matthew.d.roper@intel.com> <20140227232408.GU27672@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ee0-f49.google.com (mail-ee0-f49.google.com [74.125.83.49]) by gabe.freedesktop.org (Postfix) with ESMTP id 35189FB5E5 for ; Tue, 4 Mar 2014 04:39:02 -0800 (PST) Received: by mail-ee0-f49.google.com with SMTP id c41so795890eek.22 for ; Tue, 04 Mar 2014 04:39:01 -0800 (PST) Content-Disposition: inline In-Reply-To: <20140227232408.GU27672@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dri-devel-bounces@lists.freedesktop.org Errors-To: dri-devel-bounces@lists.freedesktop.org To: Matt Roper Cc: "dri-devel@lists.freedesktop.org" List-Id: dri-devel@lists.freedesktop.org On Thu, Feb 27, 2014 at 03:24:08PM -0800, Matt Roper wrote: > On Thu, Feb 27, 2014 at 05:39:00PM -0500, Rob Clark wrote: > > On Thu, Feb 27, 2014 at 5:14 PM, Matt Roper wrote: > > > Add a plane type property to allow userspace to distinguish > > > sprite/overlay planes from primary planes. In the future we may extend > > > this to cover cursor planes as well. > > > > > > Signed-off-by: Matt Roper > > > --- > > > drivers/gpu/drm/drm_crtc.c | 32 ++++++++++++++++++++++++++++++++ > > > include/drm/drm_crtc.h | 1 + > > > include/uapi/drm/drm_mode.h | 3 +++ > > > 3 files changed, 36 insertions(+) > > > > > > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c > > > index 21c6d4b..1032eaf 100644 > > > --- a/drivers/gpu/drm/drm_crtc.c > > > +++ b/drivers/gpu/drm/drm_crtc.c > > > @@ -114,6 +114,14 @@ static const struct drm_prop_enum_list drm_dpms_enum_list[] = > > > > > > DRM_ENUM_NAME_FN(drm_get_dpms_name, drm_dpms_enum_list) > > > > > > +static const struct drm_prop_enum_list drm_plane_type_enum_list[] = > > > +{ > > > + { DRM_MODE_PLANE_TYPE_SPRITE, "Sprite" }, > > > > I'm not the *hugest* fan of using the name "sprite".. at least that > > too me implies sort of a subset of possible functionality of a plane.. > > Any suggestions on a better name? Maybe call them "traditional" planes > and then just give new names to the other types (primary, cursor) that > we wind up exposing when appropriate client caps are set? What about "secondary" for any plane exposed which doesn't match one of the special-purpose planes for backwards compat? We'd then have "primary" (fixed to a crtc and used for legacy setCrtc/pageflips), "cursor" (again fixed to a crtc for use by the legacy setcurso ioctl) and a pile of secondary planes without special meaning attached to them. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch