From: Thierry Reding <thierry.reding@gmail.com>
To: Rob Clark <robdclark@gmail.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [RFC] drm: add plane iterator macros
Date: Fri, 21 Nov 2014 17:29:32 +0100 [thread overview]
Message-ID: <20141121162930.GA16290@ulmo.nvidia.com> (raw)
In-Reply-To: <1416573551-1890-1-git-send-email-robdclark@gmail.com>
[-- Attachment #1.1: Type: text/plain, Size: 2492 bytes --]
On Fri, Nov 21, 2014 at 07:39:11AM -0500, Rob Clark wrote:
> Inspired in part by some cute iterator macros I noticed in i915. I
> currently have these in drm/msm, but seems like they should be useful
> for others. Quite possibly other iterators would be useful to add for
> other drivers.
>
> Signed-off-by: Rob Clark <robdclark@gmail.com>
> ---
> NOTE: to actually merge this, depending on the order this is merged
> vs drm/msm/mdp5 atomic support, these would have to be removed from
> msm_kms.h.
>
> include/drm/drm_crtc.h | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)
>
> diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> index bc1cc3c..5ea46ec 100644
> --- a/include/drm/drm_crtc.h
> +++ b/include/drm/drm_crtc.h
> @@ -773,6 +773,34 @@ struct drm_plane {
> struct drm_plane_state *state;
> };
>
> +/* iterate over the planes *currently* attached to a crtc, useful
> + * to apply current state to hw:
> + */
> +#define for_each_plane_on_crtc(_crtc, _plane) \
> + list_for_each_entry((_plane), &(_crtc)->dev->mode_config.plane_list, head) \
> + if ((_plane)->state->crtc == (_crtc))
Perhaps throw in a drm_ prefix (for this and the below iterator). Or
maybe rename to something like:
drm_crtc_for_each_plane()
to make the argument list more intuitive?
> +static inline bool
> +__plane_will_be_attached_to_crtc(struct drm_atomic_state *state,
> + struct drm_plane *plane, struct drm_crtc *crtc)
> +{
> + int idx = drm_plane_index(plane);
> +
> + /* if plane is modified in incoming state, use the new state: */
> + if (state->plane_states[idx])
> + return state->plane_states[idx]->crtc == crtc;
> +
> + /* otherwise, current state: */
> + return plane->state->crtc == crtc;
> +}
Maybe drm_crtc_plane_pending(crtc, state, plane) for somewhat more
cohesive naming?
> +
> +/* iterate over the planes that *will be* attached to a crtc,
> + * useful for ->atomic_check() operations:
> + */
> +#define for_each_pending_plane_on_crtc(_state, _crtc, _plane) \
> + list_for_each_entry((_plane), &(_crtc)->dev->mode_config.plane_list, head) \
> + if (__plane_will_be_attached_to_crtc((_state), (_plane), (_crtc)))
Similarily as for the above, perhaps:
drm_crtc_for_each_pending_plane(_crtc, _state, _plane)
might be more intuitive.
Irrespective of the bike-shedding and with Daniel's comments addressed,
this is:
Reviewed-by: Thierry Reding <treding@nvidia.com>
[-- Attachment #1.2: Type: application/pgp-signature, Size: 819 bytes --]
[-- Attachment #2: Type: text/plain, Size: 159 bytes --]
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
prev parent reply other threads:[~2014-11-21 16:29 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-21 12:39 [RFC] drm: add plane iterator macros Rob Clark
2014-11-21 15:24 ` Daniel Vetter
2014-11-21 16:29 ` Thierry Reding [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20141121162930.GA16290@ulmo.nvidia.com \
--to=thierry.reding@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=robdclark@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox