From: Daniel Vetter <daniel@ffwll.ch>
To: Thierry Reding <thierry.reding@gmail.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 2/2] drm/atomic: add plane iterator macros
Date: Tue, 25 Nov 2014 13:31:01 +0100 [thread overview]
Message-ID: <20141125123100.GD25711@phenom.ffwll.local> (raw)
In-Reply-To: <20141121204223.GB10379@mithrandir>
On Fri, Nov 21, 2014 at 09:42:25PM +0100, Thierry Reding wrote:
> On Fri, Nov 21, 2014 at 09:38:40PM +0100, Daniel Vetter wrote:
> > On Fri, Nov 21, 2014 at 03:28:32PM -0500, Rob Clark wrote:
> > > +#define drm_crtc_for_each_plane(plane, crtc) \
> > > + list_for_each_entry((plane), &(crtc)->dev->mode_config.plane_list, head) \
> > > + if ((crtc)->state->plane_mask & (1 << drm_plane_index(plane)))
> >
> > Implement this as drm_crtc_for_each_pending_plane(plane, (crtc)->state)?
> > Which means _pending is a strange name ...
>
> Yeah, I think the drm_crtc_for_each_pending_plane() could be
> drm_crtc_state_for_each_plane(), then your suggestion makes perfect
> sense.
I like Thierry's naming here. Rob can you apply that please?
Thanks, Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2014-11-25 12:30 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-21 20:28 [PATCH 1/2] drm/atomic: track bitmask of planes attached to crtc Rob Clark
2014-11-21 20:28 ` [PATCH 2/2] drm/atomic: add plane iterator macros Rob Clark
2014-11-21 20:38 ` Daniel Vetter
2014-11-21 20:42 ` Thierry Reding
2014-11-25 12:31 ` Daniel Vetter [this message]
2014-11-21 20:46 ` Thierry Reding
2014-11-25 14:15 ` [PATCH 1/2] drm/atomic: track bitmask of planes attached to crtc Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20141125123100.GD25711@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=thierry.reding@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox