dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
To: Emil Velikov <emil.l.velikov@gmail.com>
Cc: ML dri-devel <dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH 1/6] drm: Fix DRM_IOCTL_DEF_DRV()
Date: Mon, 30 Mar 2015 14:23:51 +0300	[thread overview]
Message-ID: <20150330112351.GK17410@intel.com> (raw)
In-Reply-To: <CACvgo51tjmBK_tDqb9JE1Bic-c1eBVd9rrM5Gm1ruOHP+qJNJg@mail.gmail.com>

On Fri, Mar 27, 2015 at 03:14:10PM +0000, Emil Velikov wrote:
> Hi Ville,
> 
> On 27 March 2015 at 13:51,  <ville.syrjala@linux.intel.com> wrote:
> > From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> >
> > Currently DRM_IOCTL_DEF_DRV does '[DRM_IOCTL_NR(DRM_##ioctl)]' which
> > doesn't make much sense since DRM_##ioctl is already a the raw ioctl
> > number. So change it to 'DRM_IOCTL_NR(DRM_IOCTL_##ioctl) - DRM_COMMAND_BASE'
> > which means the DRM_IOCTL_NR() now makes sense, and also this also means
> > if there's a mistake in the DRM_IOCTL_##ioctl macros we might get a
> > warning about it (eg. we would have gotten a sparse warning about the
> > i915 colorkey get/set ioctl being defined to be the same thing).
> >
> > Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > ---
> >  include/drm/drmP.h | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/include/drm/drmP.h b/include/drm/drmP.h
> > index 63c0b01..6195ee9b 100644
> > --- a/include/drm/drmP.h
> > +++ b/include/drm/drmP.h
> > @@ -263,7 +263,7 @@ struct drm_ioctl_desc {
> >   */
> >
> >  #define DRM_IOCTL_DEF_DRV(ioctl, _func, _flags)                        \
> > -       [DRM_IOCTL_NR(DRM_##ioctl)] = {.cmd = DRM_##ioctl, .func = _func, .flags = _flags, .cmd_drv = DRM_IOCTL_##ioctl, .name = #ioctl}
> > +       [DRM_IOCTL_NR(DRM_IOCTL_##ioctl) - DRM_COMMAND_BASE] = {.cmd = DRM_##ioctl, .func = _func, .flags = _flags, .cmd_drv = DRM_IOCTL_##ioctl, .name = #ioctl}
> >
> Humble request: Can you split this long line to something line the
> following. It should improve the overall readability.
> Plus is will make your follow up changes clearer.
> 
> +       [DRM_IOCTL_NR(DRM_IOCTL_##ioctl) - DRM_COMMAND_BASE] = { \
> +             .cmd = DRM_##ioctl, \
> +             .func = _func, \
> +             .flags = _flags, \
> +             .cmd_drv = DRM_IOCTL_##ioctl, \
> +             .name = #ioctl \
> +       }

Daniel already picked these up, so my work is done ;) But feel free to
toss in a followup.

-- 
Ville Syrjälä
Intel OTC
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2015-03-30 11:23 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-27 13:51 [PATCH 0/6] drm: Ioctl code cleanups ville.syrjala
2015-03-27 13:51 ` [PATCH 1/6] drm: Fix DRM_IOCTL_DEF_DRV() ville.syrjala
2015-03-27 15:14   ` Emil Velikov
2015-03-30 11:23     ` Ville Syrjälä [this message]
2015-03-30 12:58       ` [PATCH] drm: line wrap DRM_IOCTL_DEF* macros Emil Velikov
2015-03-30 14:51         ` Daniel Vetter
2015-03-30 17:10         ` [PATCH v2] " Emil Velikov
2015-03-31  7:18           ` Daniel Vetter
2015-03-27 13:51 ` [PATCH 2/6] drm: Drop ioctl->cmd_drv ville.syrjala
2015-03-27 13:51 ` [PATCH 3/6] drm/vmwgfx: Replace VMW_IOCTL_DEF with DRM_IOCTL_DEF_DRV ville.syrjala
2015-03-27 13:51 ` [PATCH 4/6] drm: Simplify core vs. drv ioctl handling ville.syrjala
2015-03-27 13:51 ` [PATCH 5/6] drm: Use max() to make the ioctl alloc size code cleaner ville.syrjala
2015-03-27 13:52 ` [PATCH 6/6] drm: Rewrite drm_ioctl_flags() to resemble the new drm_ioctl() code ville.syrjala
2015-03-27 15:09 ` [PATCH 0/6] drm: Ioctl code cleanups Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150330112351.GK17410@intel.com \
    --to=ville.syrjala@linux.intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=emil.l.velikov@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox