From: Lukas Wunner <lukas@wunner.de>
To: Thierry Reding <thierry.reding@gmail.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 4/7] vga_switcheroo: Cleanup header comment
Date: Fri, 8 May 2015 15:18:26 +0200 [thread overview]
Message-ID: <20150508131826.GA6344@wunner.de> (raw)
In-Reply-To: <1431082249-18681-5-git-send-email-thierry.reding@gmail.com>
Hi Thierry,
On Fri, May 08, 2015 at 12:50:46PM +0200, Thierry Reding wrote:
> + *
> + * Switcher interface - methods require for ATPX and DCM
> + * - switchto - this throws the output MUX switch
> + * - discrete_set_power - sets the power state for the discrete card
> + *
> + * GPU driver interface
> + * - set_gpu_state - this should do the equiv of s/r for the card
> + * - this should *not* set the discrete power state
> + * - switch_check - check if the device is in a position to switch now
That documentation is actually wrong, I fixed it in my MacBook Pro
gpu switching patchset but that is still under development and thus
not merged. Might as well fix it with this patch (if you want):
s/discrete_set_power - sets the power state for the discrete card/power_state - sets the power state for either GPU/
s/switch_check/can_switch/
Best regards,
Lukas
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2015-05-08 13:18 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-05-08 10:50 [PATCH 0/7] vga: Miscellaneous cleanups Thierry Reding
2015-05-08 10:50 ` [PATCH 1/7] vgaarb: Use vgaarb: prefix consistently in messages Thierry Reding
2015-05-08 10:50 ` [PATCH 2/7] vgaarb: Fix a few checkpatch errors and warnings Thierry Reding
2015-05-08 10:50 ` [PATCH 3/7] vga_switcheroo: Use pr_*() instead of printk() Thierry Reding
2015-05-08 10:50 ` [PATCH 4/7] vga_switcheroo: Cleanup header comment Thierry Reding
2015-05-08 13:18 ` Lukas Wunner [this message]
2015-05-08 10:50 ` [PATCH 5/7] vga_switcheroo: Use pr_fmt() Thierry Reding
2015-05-08 10:50 ` [PATCH 6/7] vga_switcheroo: Wrap overly long lines Thierry Reding
2015-05-08 10:50 ` [PATCH 7/7] vga_switcheroo: Remove unnecessary checks Thierry Reding
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150508131826.GA6344@wunner.de \
--to=lukas@wunner.de \
--cc=dri-devel@lists.freedesktop.org \
--cc=thierry.reding@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox