From: Russell King - ARM Linux <linux@arm.linux.org.uk>
To: gregkh@linux-foundation.org
Cc: dri-devel@lists.freedesktop.org, linux-arm-kernel@lists.infradead.org
Subject: [PATCH 0/4] Component helper updates
Date: Mon, 23 Nov 2015 16:02:11 +0000 [thread overview]
Message-ID: <20151123160210.GR8644@n2100.arm.linux.org.uk> (raw)
Greg,
These four patches update the component helper by:
* Removing the legacy matching code with the .add_components method
in the master's operation structure. Nothing in -rc1 appears to be
using the legacy functions or method, according to my git greps.
* A slight code reorganisation which results in slightly easier to read
code.
* Switch to tracking components via an array rather than a list, which
allows us to keep the matching and matched components together, and
more importantly allows us to reduce the amount of matching - with
this structure, we can incrementally add the component devices as
they become available, rather than re-running the list of matches
each time something changes.
* Fix the lack of match release functionality, which Liviu Dudau
reminded me was missing. This allows people who want to pass
device_node structures in to (correctly) retain the reference to the
node, and drop the node when the need to do matches is no longer
required.
The first three patches have been well tested over the last year as I've
had them in my tree that long. I hadn't considered them important enough
to send as they're only removing and cleaning up functionality. However,
with the need to fix something, it now makes sense to get them merged.
The last patch has been tested with etnaviv DRM to prove that the match
release works by unloading the module. On unload, the release function
is correctly called.
This is intended for the next merge window. Please apply.
drivers/base/component.c | 281 ++++++++++++++++++++++++----------------------
include/linux/component.h | 33 ++++--
2 files changed, 167 insertions(+), 147 deletions(-)
--
FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up
according to speedtest.net.
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next reply other threads:[~2015-11-23 16:02 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-11-23 16:02 Russell King - ARM Linux [this message]
2015-11-23 16:02 ` [PATCH 1/4] component: remove old add_components method Russell King
2015-11-23 23:26 ` Andrew Lunn
2015-12-07 17:06 ` Andrew Lunn
2015-11-23 16:02 ` [PATCH 2/4] component: move check for unbound master into try_to_bring_up_masters() Russell King
2015-11-23 16:02 ` [PATCH 3/4] component: track components via array rather than list Russell King
2015-11-23 16:02 ` [PATCH 4/4] component: add support for releasing match data Russell King
2015-11-23 23:38 ` [PATCH 0/4] Component helper updates Andrew Lunn
2015-12-07 15:01 ` Russell King - ARM Linux
2016-01-04 17:25 ` Russell King - ARM Linux
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20151123160210.GR8644@n2100.arm.linux.org.uk \
--to=linux@arm.linux.org.uk \
--cc=dri-devel@lists.freedesktop.org \
--cc=gregkh@linux-foundation.org \
--cc=linux-arm-kernel@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox