dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Eric Engestrom <eric.engestrom@intel.com>
To: dri-devel@lists.freedesktop.org
Subject: [PATCH libdrm 2/2] xf86drm: rename "real_path" to "pci_path"
Date: Wed,  5 Sep 2018 13:31:49 +0100	[thread overview]
Message-ID: <20180905123149.18117-2-eric.engestrom@intel.com> (raw)
In-Reply-To: <20180905123149.18117-1-eric.engestrom@intel.com>

"real_path" was getting confusing when there are other *paths in the
same functions.

Signed-off-by: Eric Engestrom <eric.engestrom@intel.com>
---
 xf86drm.c | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/xf86drm.c b/xf86drm.c
index 649d400bcbc494ac04e6..b2388194932754dadc99 100644
--- a/xf86drm.c
+++ b/xf86drm.c
@@ -2999,17 +2999,17 @@ static int drmParseSubsystemType(int maj, int min)
 }
 
 static void
-get_real_pci_path(int maj, int min, char *real_path)
+get_pci_path(int maj, int min, char *pci_path)
 {
     char path[PATH_MAX + 1], *term;
 
     snprintf(path, sizeof(path), "/sys/dev/char/%d:%d/device", maj, min);
-    if (!realpath(path, real_path)) {
-        strcpy(real_path, path);
+    if (!realpath(path, pci_path)) {
+        strcpy(pci_path, path);
         return;
     }
 
-    term = strrchr(real_path, '/');
+    term = strrchr(pci_path, '/');
     if (term && strncmp(term, "/virtio", 7) == 0)
         *term = 0;
 }
@@ -3018,12 +3018,12 @@ static int drmParsePciBusInfo(int maj, int min, drmPciBusInfoPtr info)
 {
 #ifdef __linux__
     unsigned int domain, bus, dev, func;
-    char real_path[PATH_MAX + 1], *value;
+    char pci_path[PATH_MAX + 1], *value;
     int num;
 
-    get_real_pci_path(maj, min, real_path);
+    get_pci_path(maj, min, pci_path);
 
-    value = sysfs_uevent_get(real_path, "PCI_SLOT_NAME");
+    value = sysfs_uevent_get(pci_path, "PCI_SLOT_NAME");
     if (!value)
         return -ENOENT;
 
@@ -3136,15 +3136,15 @@ static int parse_separate_sysfs_files(int maj, int min,
       "subsystem_vendor",
       "subsystem_device",
     };
-    char path[PATH_MAX + 1], real_path[PATH_MAX + 1];
+    char path[PATH_MAX + 1], pci_path[PATH_MAX + 1];
     unsigned int data[ARRAY_SIZE(attrs)];
     FILE *fp;
     int ret;
 
-    get_real_pci_path(maj, min, real_path);
+    get_pci_path(maj, min, pci_path);
 
     for (unsigned i = ignore_revision ? 1 : 0; i < ARRAY_SIZE(attrs); i++) {
-        snprintf(path, PATH_MAX, "%s/%s", real_path, attrs[i]);
+        snprintf(path, PATH_MAX, "%s/%s", pci_path, attrs[i]);
         fp = fopen(path, "r");
         if (!fp)
             return -errno;
@@ -3168,13 +3168,13 @@ static int parse_separate_sysfs_files(int maj, int min,
 static int parse_config_sysfs_file(int maj, int min,
                                    drmPciDeviceInfoPtr device)
 {
-    char path[PATH_MAX + 1], real_path[PATH_MAX + 1];
+    char path[PATH_MAX + 1], pci_path[PATH_MAX + 1];
     unsigned char config[64];
     int fd, ret;
 
-    get_real_pci_path(maj, min, real_path);
+    get_pci_path(maj, min, pci_path);
 
-    snprintf(path, PATH_MAX, "%s/config", real_path);
+    snprintf(path, PATH_MAX, "%s/config", pci_path);
     fd = open(path, O_RDONLY);
     if (fd < 0)
         return -errno;
-- 
Cheers,
  Eric

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2018-09-05 12:31 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-05 12:31 [PATCH libdrm 1/2] xf86drm: merge get_normal_pci_path() into get_real_pci_path() Eric Engestrom
2018-09-05 12:31 ` Eric Engestrom [this message]
2018-09-05 12:58 ` Emil Velikov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180905123149.18117-2-eric.engestrom@intel.com \
    --to=eric.engestrom@intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox