From: Daniel Vetter <daniel@ffwll.ch>
To: Shayenne da Luz Moura <shayenneluzmoura@gmail.com>
Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <maxime.ripard@bootlin.com>,
Sean Paul <sean@poorly.run>, David Airlie <airlied@linux.ie>,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
outreachy-kernel@googlegroups.com
Subject: Re: [Outreachy kernel] [PATCH] drm: Remove complete task from TODO documentation
Date: Fri, 14 Dec 2018 09:35:54 +0100 [thread overview]
Message-ID: <20181214083554.GJ21184@phenom.ffwll.local> (raw)
In-Reply-To: <20181213225537.nq4dwidn6tma33iv@smtp.gmail.com>
On Thu, Dec 13, 2018 at 08:55:37PM -0200, Shayenne da Luz Moura wrote:
> This patch remove the follow complete task from TODO documentation:
>
> drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
> Should be renamed to drm_mode_config.object_idr.
>
> Signed-off-by: Shayenne da Luz Moura <shayenneluzmoura@gmail.com>
Applied, thanks for your patch.
-Daniel
> ---
> Documentation/gpu/todo.rst | 3 ---
> 1 file changed, 3 deletions(-)
>
> diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> index 14191b64446d..41da7b06195c 100644
> --- a/Documentation/gpu/todo.rst
> +++ b/Documentation/gpu/todo.rst
> @@ -354,9 +354,6 @@ KMS cleanups
>
> Some of these date from the very introduction of KMS in 2008 ...
>
> -- drm_mode_config.crtc_idr is misnamed, since it contains all KMS object. Should
> - be renamed to drm_mode_config.object_idr.
> -
> - drm_display_mode doesn't need to be derived from drm_mode_object. That's
> leftovers from older (never merged into upstream) KMS designs where modes
> where set using their ID, including support to add/remove modes.
> --
> 2.19.2
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20181213225537.nq4dwidn6tma33iv%40smtp.gmail.com.
> For more options, visit https://groups.google.com/d/optout.
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
prev parent reply other threads:[~2018-12-14 8:35 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-12-13 22:55 [PATCH] drm: Remove complete task from TODO documentation Shayenne da Luz Moura
2018-12-14 8:35 ` Daniel Vetter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181214083554.GJ21184@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=airlied@linux.ie \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=maxime.ripard@bootlin.com \
--cc=outreachy-kernel@googlegroups.com \
--cc=sean@poorly.run \
--cc=shayenneluzmoura@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox