dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Sam Ravnborg <sam@ravnborg.org>
To: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Cc: Maxime Ripard <maxime.ripard@bootlin.com>,
	Tomi Valkeinen <tomi.valkeinen@ti.com>,
	Sean Paul <sean@poorly.run>,
	Sebastian Reichel <sebastian.reichel@collabora.com>,
	dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 10/60] drm/bridge: Add bridge driver for display connectors
Date: Tue, 16 Jul 2019 11:28:57 +0200	[thread overview]
Message-ID: <20190716092857.GA23287@ravnborg.org> (raw)
In-Reply-To: <20190707181937.6250-7-laurent.pinchart@ideasonboard.com>

Hi Laurent.

Two small details, see below.

	Sam

On Sun, Jul 07, 2019 at 09:18:47PM +0300, Laurent Pinchart wrote:
> Display connectors are modelled in DT as a device node, but have so far
> been handled manually in several bridge drivers. This resulted in
> duplicate code in several bridge drivers, with slightly different (and
> thus confusing) logics.
> 
> In order to fix this, implement a bridge driver for display connectors.
> The driver centralises logic for the DVI, HDMI, VGAn composite and
> S-video connectors and exposes corresponding bridge operations.
> 
> This driver in itself doesn't solve the issue completely, changes in
> bridge and display controller drivers are needed to make use of the new
> connector driver.
> 
> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> ---
>  drivers/gpu/drm/bridge/Kconfig             |  11 +
>  drivers/gpu/drm/bridge/Makefile            |   1 +
>  drivers/gpu/drm/bridge/display-connector.c | 327 +++++++++++++++++++++
>  3 files changed, 339 insertions(+)
>  create mode 100644 drivers/gpu/drm/bridge/display-connector.c
> 
> diff --git a/drivers/gpu/drm/bridge/Kconfig b/drivers/gpu/drm/bridge/Kconfig
> index a78392e2dbb9..295a62f65ef9 100644
> --- a/drivers/gpu/drm/bridge/Kconfig
> +++ b/drivers/gpu/drm/bridge/Kconfig
> @@ -37,6 +37,17 @@ config DRM_CDNS_DSI
>  	  Support Cadence DPI to DSI bridge. This is an internal
>  	  bridge and is meant to be directly embedded in a SoC.
>  
> +config DRM_DISPLAY_CONNECTOR
> +	tristate "Display connector support"
> +	depends on OF
> +	help
> +	  Driver for display connectors with support for DDC and hot-plug
> +	  detection. Most display controller handle display connectors
> +	  internally and don't need this driver, but the DRM subsystem is
> +	  moving towards separating connector handling from display controllers
> +	  on ARM-based platforms. Saying Y here when this driver is not needed
> +	  will not cause any issue.
> +
>  config DRM_LVDS_ENCODER
>  	tristate "Transparent parallel to LVDS encoder support"
>  	depends on OF
> diff --git a/drivers/gpu/drm/bridge/Makefile b/drivers/gpu/drm/bridge/Makefile
> index 6ff7f2adbb0e..e5987b3aaf62 100644
> --- a/drivers/gpu/drm/bridge/Makefile
> +++ b/drivers/gpu/drm/bridge/Makefile
> @@ -1,6 +1,7 @@
>  # SPDX-License-Identifier: GPL-2.0
>  obj-$(CONFIG_DRM_ANALOGIX_ANX78XX) += analogix-anx78xx.o
>  obj-$(CONFIG_DRM_CDNS_DSI) += cdns-dsi.o
> +obj-$(CONFIG_DRM_DISPLAY_CONNECTOR) += display-connector.o
>  obj-$(CONFIG_DRM_LVDS_ENCODER) += lvds-encoder.o
>  obj-$(CONFIG_DRM_MEGACHIPS_STDPXXXX_GE_B850V3_FW) += megachips-stdpxxxx-ge-b850v3-fw.o
>  obj-$(CONFIG_DRM_NXP_PTN3460) += nxp-ptn3460.o
> diff --git a/drivers/gpu/drm/bridge/display-connector.c b/drivers/gpu/drm/bridge/display-connector.c
> new file mode 100644
> index 000000000000..2e1e7ee89275
> --- /dev/null
> +++ b/drivers/gpu/drm/bridge/display-connector.c
> @@ -0,0 +1,327 @@
> +// SPDX-License-Identifier: GPL-2.0
> +/*
> + * Copyright (C) 2019 Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> + */
> +
...
> +
> +static void display_connector_hpd_enable(struct drm_bridge *bridge)
> +{
> +}
> +
> +static void display_connector_hpd_disable(struct drm_bridge *bridge)
> +{
> +}

It seems wrong that a new driver needs empty implementation of
hpd_enable() and hpd_disable().
I noticed the same in a later patch too.

Can we do without these empty functions?

> +
> +static const struct drm_bridge_funcs display_connector_bridge_funcs = {
> +	.attach = display_connector_attach,
> +	.detect = display_connector_detect,
> +	.get_edid = display_connector_get_edid,
> +	.hpd_enable = display_connector_hpd_enable,
> +	.hpd_disable = display_connector_hpd_disable,
> +};
> +
> +	struct display_connector *conn = arg;
> +	struct drm_bridge *bridge = &conn->bridge;
> +
> +	drm_bridge_hpd_notify(bridge, display_connector_detect(bridge));
> +
> +	return IRQ_HANDLED;
> +}
> +
> +static const char *display_connector_type_name(struct display_connector *conn)
> +{
> +	switch (conn->bridge.type) {
> +	case DRM_MODE_CONNECTOR_Composite:
> +		return "Composite";
> +	case DRM_MODE_CONNECTOR_DVIA:
> +		return "DVI-A";
> +	case DRM_MODE_CONNECTOR_DVID:
> +		return "DVI-D";
> +	case DRM_MODE_CONNECTOR_DVII:
> +		return "DVI-I";
> +	case DRM_MODE_CONNECTOR_HDMIA:
> +		return "HDMI-A";
> +	case DRM_MODE_CONNECTOR_HDMIB:
> +		return "HDMI-B";
> +	case DRM_MODE_CONNECTOR_SVIDEO:
> +		return "S-Video";
> +	case DRM_MODE_CONNECTOR_VGA:
> +		return "VGA";
> +	default:
> +		return "unknown";
> +	}
> +}
We already have the relation DRM_MODE_CONNECTOR <=> name in drm_connector -
see drm_connector_enum_list.

Add a small function in drm_connector.c get the name, so we do not hardcode the
name twice?

	Sam
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2019-07-16  9:29 UTC|newest]

Thread overview: 166+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-07 18:07 [PATCH 00/60] drm/omap: Replace custom display drivers with drm_bridge and drm_panel Laurent Pinchart
2019-07-07 18:07 ` [PATCH 01/60] drm/edid: Add flag to drm_display_info to identify HDMI sinks Laurent Pinchart
2019-07-09 13:20   ` Andrzej Hajda
2019-07-10 15:41     ` Daniel Vetter
2019-07-10 15:59   ` Ville Syrjälä
2019-07-07 18:07 ` [PATCH 02/60] video: hdmi: Change return type of hdmi_avi_infoframe_init() to void Laurent Pinchart
2019-07-07 18:14   ` Laurent Pinchart
2019-07-07 18:21     ` Ilia Mirkin
2019-07-09 13:22   ` Andrzej Hajda
2019-07-07 18:07 ` [PATCH 03/60] drm/bridge: dumb-vga-dac: Rename internal symbols to simple-bridge Laurent Pinchart
2019-07-09 13:34   ` Andrzej Hajda
2019-07-07 18:18 ` [PATCH 04/60] drm/bridge: dumb-vga-dac: Rename driver " Laurent Pinchart
2019-07-07 18:18   ` [PATCH 05/60] drm/bridge: simple-bridge: Add support for non-VGA bridges Laurent Pinchart
2019-07-09 14:08     ` Andrzej Hajda
2019-07-26 13:24     ` Stefan Agner
2019-07-07 18:18   ` [PATCH 06/60] drm/bridge: simple-bridge: Add support for enable GPIO Laurent Pinchart
2019-07-09 14:32     ` Andrzej Hajda
2019-07-26 13:19     ` Stefan Agner
2019-07-07 18:18   ` [PATCH 07/60] drm/bridge: simple-bridge: Add support for the TI OP362 Laurent Pinchart
2019-07-09 14:32     ` Andrzej Hajda
2019-08-27  6:16     ` Tomi Valkeinen
2019-07-07 18:18   ` [PATCH 08/60] drm/bridge: Extend bridge API to disable connector creation Laurent Pinchart
2019-07-17  6:39     ` Andrzej Hajda
2019-08-08 14:25       ` Laurent Pinchart
2019-08-08 17:36         ` Andrzej Hajda
2019-08-08 18:50           ` Laurent Pinchart
2019-08-14  8:18           ` Daniel Vetter
2019-08-14  9:55             ` Laurent Pinchart
2019-08-14 12:24               ` Daniel Vetter
2019-07-07 18:18   ` [PATCH 09/60] drm/bridge: Add connector-related bridge operations and data Laurent Pinchart
2019-07-10 12:12     ` Andrzej Hajda
2019-07-11  7:35       ` Daniel Vetter
2019-07-11 12:41         ` Andrzej Hajda
2019-07-11 13:18           ` Daniel Vetter
2019-07-11 15:12             ` Andrzej Hajda
2019-07-11 15:50               ` Daniel Vetter
2019-07-12  9:01                 ` Andrzej Hajda
2019-07-16  9:00                   ` Daniel Vetter
2019-07-16 13:57                     ` Andrzej Hajda
2019-08-08 19:32                       ` Laurent Pinchart
2019-08-09 11:55                         ` Andrzej Hajda
2019-08-10 22:43                           ` Laurent Pinchart
2019-08-14  6:23                             ` Andrzej Hajda
2019-08-14 10:04                               ` Laurent Pinchart
2019-08-14 12:40                                 ` Daniel Vetter
2019-08-19  8:38                                   ` Andrzej Hajda
2019-08-19 22:45                                     ` Laurent Pinchart
2019-08-22 12:17                                       ` Andrzej Hajda
2019-08-26 16:27                                         ` Laurent Pinchart
2019-08-29 16:48                                           ` Andrzej Hajda
2019-12-02 15:40                                             ` Laurent Pinchart
2019-08-14 12:35                         ` Daniel Vetter
2019-08-19 22:32                           ` Laurent Pinchart
2019-08-20  8:30                             ` Daniel Vetter
2019-08-26 15:57                               ` Laurent Pinchart
2019-08-08 18:19         ` Laurent Pinchart
2019-08-08 18:36           ` Laurent Pinchart
2019-08-14 13:03             ` Daniel Vetter
2019-08-14 13:30               ` Laurent Pinchart
2019-08-14 17:02                 ` Daniel Vetter
2019-08-16 23:30                   ` Laurent Pinchart
2019-08-17  0:14                     ` Laurent Pinchart
2019-08-19  2:37                       ` Laurent Pinchart
2019-08-20  8:41                         ` Daniel Vetter
2019-08-14 12:43           ` Daniel Vetter
2019-08-14 12:56             ` Laurent Pinchart
2019-07-07 18:18   ` [PATCH 10/60] drm/bridge: Add bridge driver for display connectors Laurent Pinchart
2019-07-16  9:28     ` Sam Ravnborg [this message]
2019-08-08 16:41       ` Laurent Pinchart
2019-09-30 11:15     ` Tomi Valkeinen
2019-10-01 20:08       ` Laurent Pinchart
2019-10-02 12:38         ` Tomi Valkeinen
2019-07-07 18:18   ` [PATCH 11/60] drm/bridge: Add driver for the TI TPD12S015 HDMI level shifter Laurent Pinchart
     [not found]     ` <3347b6c8-6f2d-17d6-3dc8-e62a3bac634b@ti.com>
2019-08-27  7:30       ` Laurent Pinchart
2019-07-07 18:18   ` [PATCH 12/60] drm/bridge: panel: Implement bridge connector operations Laurent Pinchart
2019-07-16 11:08     ` drm_panel_get_modes() should take the connector as an argument [Was: drm/bridge: panel: Implement bridge ...] Sam Ravnborg
2019-08-08 16:07       ` Laurent Pinchart
2019-08-08 16:52         ` Sam Ravnborg
2019-08-08 18:37           ` Laurent Pinchart
2019-07-07 18:18   ` [PATCH 13/60] drm/bridge: tfp410: Don't include drmP.h Laurent Pinchart
     [not found]     ` <3bb82dc4-434a-aaac-8ea1-3aff0991e790@ti.com>
2019-08-27  7:47       ` Laurent Pinchart
2019-07-07 18:18   ` [PATCH 14/60] drm/bridge: tfp410: Replace manual connector handling with bridge Laurent Pinchart
2019-07-07 18:18   ` [PATCH 15/60] drm/bridge: tfp410: Allow operation without drm_connector Laurent Pinchart
2019-07-07 18:18   ` [PATCH 16/60] dt-bindings: Add vendor prefix for LG Display Laurent Pinchart
2019-07-24 16:22     ` Rob Herring
2019-07-07 18:18   ` [PATCH 17/60] dt-bindings: Add legacy 'toppoly' vendor prefix Laurent Pinchart
2019-07-08 19:00     ` Rob Herring
2019-07-09  1:00       ` Laurent Pinchart
2019-07-09  1:35         ` Rob Herring
2019-07-07 18:18   ` [PATCH 18/60] dt-bindings: display: panel: Add bindings for NEC NL8048HL11 panel Laurent Pinchart
2019-07-07 18:18   ` [PATCH 19/60] drm/panel: Add driver for the LG Philips LB035Q02 panel Laurent Pinchart
2019-07-08 18:51     ` Sam Ravnborg
2019-07-09  0:56       ` Laurent Pinchart
2019-07-09  5:47         ` Sam Ravnborg
2019-07-07 18:18   ` [PATCH 20/60] drm/panel: Add driver for the NEC NL8048HL11 panel Laurent Pinchart
2019-07-08 19:10     ` Sam Ravnborg
2019-07-08 19:26       ` Sam Ravnborg
2019-08-08 15:17       ` Laurent Pinchart
2019-07-07 18:18   ` [PATCH 21/60] drm/panel: Add driver for the Sharp LS037V7DW01 panel Laurent Pinchart
2019-07-08 19:44     ` Sam Ravnborg
2019-07-08 19:47       ` Sam Ravnborg
2019-08-08 15:31       ` Laurent Pinchart
2019-07-07 18:18   ` [PATCH 22/60] drm/panel: Add driver for the Sony ACX565AKM panel Laurent Pinchart
2019-07-07 18:19   ` [PATCH 23/60] drm/panel: Add driver for the Toppology TD028TTEC1 panel Laurent Pinchart
2019-07-10  7:48     ` Sam Ravnborg
2019-08-08 15:43       ` Laurent Pinchart
2019-07-07 18:19   ` [PATCH 24/60] drm/panel: Add driver for the Toppology TD043MTEA1 panel Laurent Pinchart
2019-07-10 13:09     ` Sam Ravnborg
2019-08-08 15:54       ` Laurent Pinchart
2019-08-09 13:33         ` Sam Ravnborg
2019-08-09 17:51           ` Laurent Pinchart
2019-07-07 18:19   ` [PATCH 25/60] drm: Add helper to create a connector for a chain of bridges Laurent Pinchart
2019-07-18 17:01     ` Daniel Vetter
2019-08-08 19:48       ` Laurent Pinchart
2019-08-14 15:01         ` Daniel Vetter
2019-08-19 22:16           ` Laurent Pinchart
2019-07-07 18:19   ` [PATCH 26/60] drm/omap: Detach from panels at remove time Laurent Pinchart
2019-08-13  7:28     ` Tomi Valkeinen
2019-08-13 13:50       ` Laurent Pinchart
2019-07-07 18:19   ` [PATCH 27/60] drm/omap: Simplify HDMI mode and infoframe configuration Laurent Pinchart
2019-08-13  7:29     ` Tomi Valkeinen
2019-07-07 18:19   ` [PATCH 28/60] drm/omap: Factor out display type to connector type conversion Laurent Pinchart
2019-08-13  7:32     ` Tomi Valkeinen
2019-08-13 15:18       ` Laurent Pinchart
2019-07-07 18:19   ` [PATCH 29/60] drm/omap: Use the drm_panel_bridge API Laurent Pinchart
2019-08-13  7:36     ` Tomi Valkeinen
2019-07-07 18:19   ` [PATCH 30/60] drm/omap: dss: Fix output next device lookup in DT Laurent Pinchart
2019-08-13  7:38     ` Tomi Valkeinen
2019-07-07 18:19   ` [PATCH 31/60] drm/omap: Add infrastructure to support drm_bridge local to DSS outputs Laurent Pinchart
2019-07-07 18:19   ` [PATCH 32/60] drm/omap: dss: Make omap_dss_device_ops optional Laurent Pinchart
2019-08-13  7:48     ` Tomi Valkeinen
2019-08-13 13:55       ` Laurent Pinchart
2019-07-07 18:19   ` [PATCH 33/60] drm/omap: hdmi: Allocate EDID in the .read_edid() operation Laurent Pinchart
2019-08-13  7:52     ` Tomi Valkeinen
2019-07-07 18:19   ` [PATCH 34/60] drm/omap: hdmi4: Rework EDID read to isolate data read Laurent Pinchart
2019-07-07 18:19   ` [PATCH 35/60] drm/omap: hdmi5: " Laurent Pinchart
2019-07-07 18:19   ` [PATCH 36/60] drm/omap: hdmi4: Register a drm_bridge for EDID read Laurent Pinchart
2019-07-07 18:19   ` [PATCH 37/60] drm/omap: hdmi5: " Laurent Pinchart
2019-07-07 18:19   ` [PATCH 38/60] drm/omap: hdmi4: Move mode set, enable and disable operations to bridge Laurent Pinchart
2019-07-07 18:19   ` [PATCH 39/60] drm/omap: hdmi5: " Laurent Pinchart
2019-07-07 18:19   ` [PATCH 40/60] drm/omap: hdmi4: Implement drm_bridge .lost_hotplug() operation Laurent Pinchart
2019-07-07 18:19   ` [PATCH 41/60] drm/omap: dss: Remove .set_hdmi_mode() and .set_infoframe() operations Laurent Pinchart
2019-07-07 18:19   ` [PATCH 42/60] drm/omap: venc: Register a drm_bridge Laurent Pinchart
2019-07-07 18:19   ` [PATCH 43/60] drm/omap: Create connector for bridges Laurent Pinchart
2019-07-07 18:19   ` [PATCH 44/60] drm/omap: Switch the HDMI and VENC outputs to drm_bridge Laurent Pinchart
2019-07-07 18:19   ` [PATCH 45/60] drm/omap: Remove HPD, detect and EDID omapdss operations Laurent Pinchart
2019-07-07 18:19   ` [PATCH 46/60] drm/omap: hdmi: Remove omap_dss_device operations Laurent Pinchart
2019-07-07 18:19   ` [PATCH 47/60] drm/omap: venc: " Laurent Pinchart
2019-07-07 18:19   ` [PATCH 48/60] drm/omap: hdmi4: Simplify EDID read Laurent Pinchart
2019-07-07 18:19   ` [PATCH 49/60] drm/omap: hdmi5: " Laurent Pinchart
2019-07-07 18:19   ` [PATCH 50/60] drm/omap: displays: Remove unused panel drivers Laurent Pinchart
2019-07-07 18:19   ` [PATCH 51/60] drm/omap: dpi: Sort includes alphabetically Laurent Pinchart
2019-07-07 18:19   ` [PATCH 52/60] drm/omap: dpi: Reorder functions in sections Laurent Pinchart
2019-07-07 18:19   ` [PATCH 53/60] drm/omap: dpi: Simplify clock setting API Laurent Pinchart
2019-07-07 18:19   ` [PATCH 54/60] drm/omap: dpi: Register a drm_bridge Laurent Pinchart
2019-07-07 18:19   ` [PATCH 55/60] drm/omap: sdi: Sort includes alphabetically Laurent Pinchart
2019-07-07 18:19   ` [PATCH 56/60] drm/omap: sdi: Register a drm_bridge Laurent Pinchart
2019-07-07 18:19   ` [PATCH 57/60] drm/omap: Simplify connector implementation Laurent Pinchart
2019-07-07 18:19   ` [PATCH 58/60] drm/omap: dss: Remove unused omap_dss_device operations Laurent Pinchart
2019-07-07 18:19   ` [PATCH 59/60] drm/omap: dss: Inline the omapdss_display_get() function Laurent Pinchart
2019-07-07 18:19   ` [PATCH 60/60] drm/omap: dss: Remove unused omapdss_of_find_connected_device() function Laurent Pinchart
2019-07-09 13:35   ` [PATCH 04/60] drm/bridge: dumb-vga-dac: Rename driver to simple-bridge Andrzej Hajda
2019-07-11  7:37 ` [PATCH 00/60] drm/omap: Replace custom display drivers with drm_bridge and drm_panel Daniel Vetter
2019-07-11 11:59   ` Sebastian Reichel
2019-08-08 14:26     ` Laurent Pinchart
2019-08-08 14:31   ` Laurent Pinchart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190716092857.GA23287@ravnborg.org \
    --to=sam@ravnborg.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=maxime.ripard@bootlin.com \
    --cc=sean@poorly.run \
    --cc=sebastian.reichel@collabora.com \
    --cc=tomi.valkeinen@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox