dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: "Noralf Trønnes" <noralf@tronnes.org>
Cc: daniel.vetter@ffwll.ch, sam@ravnborg.org,
	dri-devel@lists.freedesktop.org, hdegoede@redhat.com
Subject: Re: [PATCH 0/3] drm/tinydrm: Rename to drm/tiny
Date: Thu, 25 Jul 2019 14:06:32 +0200	[thread overview]
Message-ID: <20190725120632.GC15868@phenom.ffwll.local> (raw)
In-Reply-To: <20190725105132.22545-1-noralf@tronnes.org>

On Thu, Jul 25, 2019 at 12:51:29PM +0200, Noralf Trønnes wrote:
> This is the final polish on tinydrm turning it into _the_ place for tiny
> DRM drivers.
> 
> Noralf.
> 
> Noralf Trønnes (3):
>   drm/tinydrm/Kconfig: Remove menuconfig DRM_TINYDRM
>   drm/tinydrm: Rename folder to tiny
>   drm/gm12u320: Move driver to drm/tiny

I wonder whether we could place a documentation hint somewhere to put
tiny drm drivers (i.e. one file only, and that one pretty small) into
drm/tiny. But I couldn't come up with a good place. Maybe re-add tiny.rst
with a short overview paragraph that points at the most useful helpers for
tiny drivers, plus how to integrate them? Kinda as a FAQ to the "I want to
port an fbdev driver, halp pls?" question.

Anyway that's just an idea aside, on the series:

Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>

> 
>  MAINTAINERS                                   | 14 +++----
>  drivers/gpu/drm/Kconfig                       |  4 +-
>  drivers/gpu/drm/Makefile                      |  3 +-
>  drivers/gpu/drm/gm12u320/Kconfig              |  9 ----
>  drivers/gpu/drm/gm12u320/Makefile             |  2 -
>  drivers/gpu/drm/{tinydrm => tiny}/Kconfig     | 41 +++++++++++++------
>  drivers/gpu/drm/{tinydrm => tiny}/Makefile    |  1 +
>  drivers/gpu/drm/{gm12u320 => tiny}/gm12u320.c |  0
>  drivers/gpu/drm/{tinydrm => tiny}/hx8357d.c   |  0
>  drivers/gpu/drm/{tinydrm => tiny}/ili9225.c   |  0
>  drivers/gpu/drm/{tinydrm => tiny}/ili9341.c   |  0
>  drivers/gpu/drm/{tinydrm => tiny}/mi0283qt.c  |  0
>  drivers/gpu/drm/{tinydrm => tiny}/repaper.c   |  0
>  drivers/gpu/drm/{tinydrm => tiny}/st7586.c    |  0
>  drivers/gpu/drm/{tinydrm => tiny}/st7735r.c   |  0
>  15 files changed, 38 insertions(+), 36 deletions(-)
>  delete mode 100644 drivers/gpu/drm/gm12u320/Kconfig
>  delete mode 100644 drivers/gpu/drm/gm12u320/Makefile
>  rename drivers/gpu/drm/{tinydrm => tiny}/Kconfig (73%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/Makefile (89%)
>  rename drivers/gpu/drm/{gm12u320 => tiny}/gm12u320.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/hx8357d.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/ili9225.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/ili9341.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/mi0283qt.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/repaper.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/st7586.c (100%)
>  rename drivers/gpu/drm/{tinydrm => tiny}/st7735r.c (100%)
> 
> -- 
> 2.20.1
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  parent reply	other threads:[~2019-07-25 12:06 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-25 10:51 [PATCH 0/3] drm/tinydrm: Rename to drm/tiny Noralf Trønnes
2019-07-25 10:51 ` [PATCH 1/3] drm/tinydrm/Kconfig: Remove menuconfig DRM_TINYDRM Noralf Trønnes
2019-07-30 13:19   ` Hans de Goede
2019-07-30 13:34     ` Noralf Trønnes
2019-07-30 13:35       ` Hans de Goede
2019-07-30 13:53   ` Emil Velikov
2019-07-30 14:03     ` Noralf Trønnes
2019-07-30 14:16       ` Emil Velikov
2019-10-01 12:36   ` [1/3] " Jason Gunthorpe
2019-10-01 13:28     ` Noralf Trønnes
2019-10-01 13:45       ` Jason Gunthorpe
2019-10-01 14:07         ` Noralf Trønnes
2019-10-09 10:45           ` Daniel Vetter
2019-10-09 12:48             ` Noralf Trønnes
2019-10-09 13:31               ` Maxime Ripard
2019-10-10 13:30                 ` Noralf Trønnes
2019-07-25 10:51 ` [PATCH 2/3] drm/tinydrm: Rename folder to tiny Noralf Trønnes
2019-07-25 10:51 ` [PATCH 3/3] drm/gm12u320: Move driver to drm/tiny Noralf Trønnes
2019-07-25 12:06 ` Daniel Vetter [this message]
2019-07-25 12:46   ` [PATCH 0/3] drm/tinydrm: Rename " Noralf Trønnes
2019-07-25 15:10     ` Sam Ravnborg
2019-07-31 13:32 ` Noralf Trønnes

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190725120632.GC15868@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=hdegoede@redhat.com \
    --cc=noralf@tronnes.org \
    --cc=sam@ravnborg.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox