From: Boris Brezillon <boris.brezillon@collabora.com>
To: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Cc: Jernej Skrabec <jernej.skrabec@siol.net>,
Neil Armstrong <narmstrong@baylibre.com>,
Jonas Karlman <jonas@kwiboo.se>,
Seung-Woo Kim <sw0312.kim@samsung.com>,
dri-devel@lists.freedesktop.org,
Kyungmin Park <kyungmin.park@samsung.com>,
Thierry Reding <thierry.reding@gmail.com>,
Chris Healy <Chris.Healy@zii.aero>,
kernel@collabora.com, Sam Ravnborg <sam@ravnborg.org>
Subject: Re: [PATCH RFC 06/19] drm/bridge: Create drm_bridge_chain_xx() wrappers
Date: Wed, 21 Aug 2019 17:53:45 +0200 [thread overview]
Message-ID: <20190821175345.6d29a34f@collabora.com> (raw)
In-Reply-To: <20190821144504.GF5433@pendragon.ideasonboard.com>
On Wed, 21 Aug 2019 17:45:04 +0300
Laurent Pinchart <laurent.pinchart@ideasonboard.com> wrote:
> Hi Boris,
>
> Thank you for the patch.
>
> On Thu, Aug 08, 2019 at 05:11:37PM +0200, Boris Brezillon wrote:
> > DRM bridges should not be operated independently. Let's rename the
> > drm_bridge_xxx() helpers that take the first bridge of the chain and
> > iterate over the whole chain into drm_bridge_chain_xx(). We also pass
> > it the encoder containing the bridge chain instead of the dereferencing
> > encoder->bridge.
>
> I'm not sure about this. I do agree that the helpers operate on a chain,
> but I think they're use for calling them on any bridge, especially in
> conjunction with your work. The way I see it is that when a bridge in
> the chain needs a custom enable/disable sequence (flagged by some kind
> of flag in the bridge structure), the helpers will not automatically
> propagate the calls down the chain, and let the bridge call the pre/post
> enable/disable operations on the downstream bridge. This means that
> those bridges with special needs will have to call the helpers on the
> next bridge down the chain, and thus require keeping the ability to do
> so.
Also changed my mind on this one after the discussion we had. I
kept the rename part but dropper the s/bridge/encoder/ change. This way,
bridges that need to control the enable/disable sequence can use those
helpers on a sub-chain (the chain starting at the bridge element just
after them).
>
> We could of course propose two sets of helpers, one taking a bridge
> pointer, and another one taking an encoder pointer, but I think it's a
> bit overkill. Especially if you consider my comments earlier in this
> series where I propose moving the custom sequence feature to bridges
> instead of encoders, I don't think this patch will be needed.
Agreed. As said above, I kept the rename part of this patch because I
think it better reflects the fact that those helpers are acting on a
bridge chain, and not a single bridge element.
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2019-08-21 15:53 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-08-08 15:11 [PATCH RFC 00/19] drm: Add support for bus-format negotiation Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 01/19] drm: Stop including drm_bridge.h from drm_crtc.h Boris Brezillon
2019-08-08 18:05 ` Sam Ravnborg
2019-08-20 18:53 ` Laurent Pinchart
2019-08-21 15:44 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 02/19] drm: Support custom encoder/bridge enable/disable sequences officially Boris Brezillon
2019-08-20 19:05 ` Laurent Pinchart
2019-08-21 8:21 ` Daniel Vetter
2019-08-21 13:57 ` Laurent Pinchart
2019-08-21 15:39 ` Boris Brezillon
2019-08-21 15:30 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 03/19] drm/vc4: Get rid of the dsi->bridge field Boris Brezillon
2019-08-08 20:31 ` Eric Anholt
2019-08-08 15:11 ` [PATCH RFC 04/19] drm/exynos: Get rid of exynos_dsi->out_bridge Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 05/19] drm/exynos: Don't reset bridge->next Boris Brezillon
2019-08-08 21:04 ` Boris Brezillon
2019-08-21 14:01 ` Laurent Pinchart
2019-08-08 15:11 ` [PATCH RFC 06/19] drm/bridge: Create drm_bridge_chain_xx() wrappers Boris Brezillon
2019-08-21 14:45 ` Laurent Pinchart
2019-08-21 15:53 ` Boris Brezillon [this message]
2019-08-08 15:11 ` [PATCH RFC 07/19] drm/msm: Use drm_attach_bridge() to attach a bridge to an encoder Boris Brezillon
2019-08-19 17:19 ` Sam Ravnborg
2019-08-21 14:46 ` Laurent Pinchart
2019-08-08 15:11 ` [PATCH RFC 08/19] drm/bridge: Introduce drm_bridge_chain_get_{first, last, next}_bridge() Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 09/19] drm/bridge: Make the bridge chain a double-linked list Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 10/19] drm/bridge: Add a drm_bridge_state object Boris Brezillon
2019-08-21 20:14 ` Laurent Pinchart
2019-08-22 9:00 ` Boris Brezillon
2019-12-02 15:52 ` Laurent Pinchart
2019-08-08 15:11 ` [PATCH RFC 11/19] drm/bridge: Patch atomic hooks to take a drm_bridge_state Boris Brezillon
2019-08-22 0:02 ` Laurent Pinchart
2019-08-22 8:25 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 12/19] drm/bridge: Add an ->atomic_check() hook Boris Brezillon
2019-08-22 0:12 ` Laurent Pinchart
2019-08-22 7:58 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 13/19] drm/bridge: Add the drm_bridge_chain_get_prev_bridge() helper Boris Brezillon
2019-08-22 0:17 ` Laurent Pinchart
2019-08-22 8:04 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 14/19] drm/bridge: Add the necessary bits to support bus format negotiation Boris Brezillon
2019-08-14 7:51 ` Neil Armstrong
2019-08-21 18:31 ` Boris Brezillon
2019-08-22 0:55 ` Laurent Pinchart
2019-08-22 7:48 ` Boris Brezillon
2019-08-22 9:29 ` Neil Armstrong
2019-08-22 10:09 ` Boris Brezillon
2019-08-22 10:22 ` Neil Armstrong
2019-08-22 10:34 ` Boris Brezillon
2019-08-22 11:30 ` Neil Armstrong
2019-08-08 15:11 ` [PATCH RFC 15/19] drm/imx: pd: Use bus format/flags provided by the bridge when available Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 16/19] drm/bridge: lvds-encoder: Add a way to support custom ->atomic_check() implem Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 17/19] drm/bridge: lvds-encoder: Implement bus format negotiation for sn75lvds83 Boris Brezillon
2019-08-22 0:32 ` Laurent Pinchart
2019-08-22 8:12 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 18/19] drm/panel: simple: Add support for Toshiba LTA089AC29000 panel Boris Brezillon
2019-08-22 0:36 ` Laurent Pinchart
2019-08-22 8:15 ` Boris Brezillon
2019-08-08 15:11 ` [PATCH RFC 19/19] ARM: dts: imx: imx51-zii-rdu1: Fix the display pipeline definition Boris Brezillon
2019-08-09 6:58 ` [PATCH RFC 00/19] drm: Add support for bus-format negotiation Neil Armstrong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190821175345.6d29a34f@collabora.com \
--to=boris.brezillon@collabora.com \
--cc=Chris.Healy@zii.aero \
--cc=dri-devel@lists.freedesktop.org \
--cc=jernej.skrabec@siol.net \
--cc=jonas@kwiboo.se \
--cc=kernel@collabora.com \
--cc=kyungmin.park@samsung.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=narmstrong@baylibre.com \
--cc=sam@ravnborg.org \
--cc=sw0312.kim@samsung.com \
--cc=thierry.reding@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox