From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-2.1 required=3.0 tests=DKIM_INVALID,DKIM_SIGNED, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS, USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id E68D1C43603 for ; Wed, 18 Dec 2019 01:48:46 +0000 (UTC) Received: from gabe.freedesktop.org (gabe.freedesktop.org [131.252.210.177]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id B9442206EC for ; Wed, 18 Dec 2019 01:48:46 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=fail reason="signature verification failed" (1024-bit key) header.d=ideasonboard.com header.i=@ideasonboard.com header.b="Ut9gX4On" DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org B9442206EC Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=ideasonboard.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=dri-devel-bounces@lists.freedesktop.org Received: from gabe.freedesktop.org (localhost [127.0.0.1]) by gabe.freedesktop.org (Postfix) with ESMTP id ABDEA6E21C; Wed, 18 Dec 2019 01:48:45 +0000 (UTC) Received: from perceval.ideasonboard.com (perceval.ideasonboard.com [213.167.242.64]) by gabe.freedesktop.org (Postfix) with ESMTPS id A94A46E21C for ; Wed, 18 Dec 2019 01:48:43 +0000 (UTC) Received: from pendragon.ideasonboard.com (81-175-216-236.bb.dnainternet.fi [81.175.216.236]) by perceval.ideasonboard.com (Postfix) with ESMTPSA id A003A33B; Wed, 18 Dec 2019 02:48:41 +0100 (CET) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1576633721; bh=Hlg5xVk73E+8TxdDy+ZKRYmuTUFx0BbsKdd7t6egTIY=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=Ut9gX4OnVj6sfIK+en8wZX0P1f5gYFpwMdSAcPSJ2YH6cu47tTGj4in5qT3wq0vkL Fd2Mj6SCBCJr0UV3Rr4gXj9CbyWW3a69DBNl/H/fGB6WVHBRBAIdEt4VFEk9eJ2Kab lUJNvlRYj7PKCu7m2YBAw5cdRG113N1IlFzgmxFw= Date: Wed, 18 Dec 2019 03:48:30 +0200 From: Laurent Pinchart To: Sam Ravnborg Subject: Re: [PATCH v3 11/50] drm/bridge: Add bridge driver for display connectors Message-ID: <20191218014830.GL4874@pendragon.ideasonboard.com> References: <20191210225750.15709-1-laurent.pinchart@ideasonboard.com> <20191210225750.15709-12-laurent.pinchart@ideasonboard.com> <20191215120331.GD27552@ravnborg.org> MIME-Version: 1.0 Content-Disposition: inline In-Reply-To: <20191215120331.GD27552@ravnborg.org> User-Agent: Mutt/1.10.1 (2018-07-13) X-BeenThere: dri-devel@lists.freedesktop.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Direct Rendering Infrastructure - Development List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Tomi Valkeinen , Sean Paul , Sebastian Reichel , dri-devel@lists.freedesktop.org, Boris Brezillon Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Errors-To: dri-devel-bounces@lists.freedesktop.org Sender: "dri-devel" Hi Sam, Thank you for the review. On Sun, Dec 15, 2019 at 01:03:31PM +0100, Sam Ravnborg wrote: > Hi Laurent. > > One nit below. > > > + > > +struct display_connector { > > + struct drm_bridge bridge; > > + > > + const char *label; > > label is defined here. > > > + struct gpio_desc *hpd_gpio; > > + int hpd_irq; > > +}; > > + > ... > > + > > + /* Get the optional connector label. */ > > + of_property_read_string(pdev->dev.of_node, "label", &conn->label); > > Assinged here. > > > + > > + /* > > + * Get the HPD GPIO for DVI and HDMI connectors. If the GPIO can provide > > + * edge interrupts, register an interrupt handler. > > + */ > ... > > + > > + dev_info(&pdev->dev, > > + "Found %s display connector '%s' %s DDC bus and %s HPD GPIO (ops 0x%x)\n", > > + drm_get_connector_type_name(conn->bridge.type), > > + conn->label ? conn->label : "", > > + conn->bridge.ddc ? "with" : "without", > > + conn->hpd_gpio ? "with" : "without", > > + conn->bridge.ops); > > And this is the only user - within the same function where label is > assigned. > We could use a loacal variable, no need to have it in struct display_connector > unless futher use is planned. Agreed, I'll move the field to a local variable. We can always move it back to the display_connector structure later if needed. -- Regards, Laurent Pinchart _______________________________________________ dri-devel mailing list dri-devel@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/dri-devel