dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Sam Ravnborg <sam@ravnborg.org>
To: dri-devel@lists.freedesktop.org,
	Jani Nikula <jani.nikula@intel.com>,
	Daniel Vetter <daniel@ffwll.ch>
Cc: Joe Perches <joe@perches.com>, Sam Ravnborg <sam@ravnborg.org>,
	Sean Paul <sean@poorly.run>
Subject: [RFC PATCH 0/9] drm: add more new-style logging functions
Date: Sat, 21 Dec 2019 10:55:45 +0100	[thread overview]
Message-ID: <20191221095553.13332-1-sam@ravnborg.org> (raw)

Jani Nikula introduced the new nice drm_* logging functions.
I looked at updating drm/panel/* to use these,
but was quickly faced with the fact that in
many cases there was a device * but no drm_device *.
And in some cases not even a device *.

So we would end up with a mixture of different type
of logging making it confusing when to use what.
Somethign that alos IMO hurts the readability of the code.

Likewise for review feedback where we cannot simply tell
people to use new style logging but have to explain when
to use what. This will be confusing.

This patchset starts by introducing brief documentation
of the new style logging functions - something I have missed.
And then it introduces new style logging for the remaining
types of logging.

    drm_dev_*	- when a device * is avialable
    drm_pr_*	- when no identification is available

The last patch change the now legacy logging functions to
use the new style logging functions and in the process
delete a few now unused functions.
No conversion of actual users included - that will come
later when we have agreed on namign etc.

The patchset is not yet tested - but it builds.
This is an early drop of the patches to trigger
feedback on naming, get early feedback on documentation,
and any other good comments.

	Sam

Sam Ravnborg (8):
      drm/print: document logging functions
      drm/print: move new style logging functions
      drm/print: add new logging helper for drm logging
      drm/print: add kernel-doc for drm_debug_enabled
      drm/print: rename drm_dev_dbg
      drm/print: add drm_dev_* logging functions
      drm/print: add drm_pr_ logging
      drm/print: let legacy logging use new style functions

 Documentation/gpu/drm-internals.rst |   6 +
 drivers/gpu/drm/drm_print.c         |  80 ------
 include/drm/drm_print.h             | 538 +++++++++++++++++++++++-------------
 3 files changed, 351 insertions(+), 273 deletions(-)


_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

             reply	other threads:[~2019-12-21  9:56 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-21  9:55 Sam Ravnborg [this message]
2019-12-21  9:55 ` [PATCH v1 1/8] drm/print: document logging functions Sam Ravnborg
2019-12-23 11:23   ` Jani Nikula
2019-12-23 12:07     ` Sam Ravnborg
2019-12-21  9:55 ` [PATCH v1 2/8] drm/print: move new style " Sam Ravnborg
2019-12-21  9:55 ` [PATCH v1 3/8] drm/print: add new logging helper for drm logging Sam Ravnborg
2019-12-23 11:16   ` Jani Nikula
2019-12-23 11:18     ` Joe Perches
2019-12-23 12:10     ` Sam Ravnborg
2019-12-21  9:55 ` [PATCH v1 4/8] drm/print: add kernel-doc for drm_debug_enabled Sam Ravnborg
2019-12-23 11:18   ` Jani Nikula
2019-12-21  9:55 ` [PATCH v1 5/8] drm/print: rename drm_dev_dbg Sam Ravnborg
2019-12-21  9:55 ` [PATCH v1 6/8] drm/print: add drm_dev_* logging functions Sam Ravnborg
2019-12-21 13:56   ` Joe Perches
2019-12-21 14:48     ` Sam Ravnborg
2019-12-23 11:21       ` Jani Nikula
2019-12-23 11:29   ` Jani Nikula
2019-12-23 12:35     ` Sam Ravnborg
2019-12-31 14:35       ` Jani Nikula
2019-12-21  9:55 ` [PATCH v1 7/8] drm/print: add drm_pr_ logging Sam Ravnborg
2019-12-21  9:55 ` [PATCH v1 8/8] drm/print: let legacy logging use new style functions Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191221095553.13332-1-sam@ravnborg.org \
    --to=sam@ravnborg.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jani.nikula@intel.com \
    --cc=joe@perches.com \
    --cc=sean@poorly.run \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox