From: Sam Ravnborg <sam@ravnborg.org>
To: Thomas Zimmermann <tzimmermann@suse.de>
Cc: alexandre.belloni@bootlin.com, linux-aspeed@lists.ozlabs.org,
narmstrong@baylibre.com, airlied@linux.ie, liviu.dudau@arm.com,
philippe.cornu@st.com, paul@crapouillou.net,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
mihail.atanassov@arm.com, alexandre.torgue@st.com, marex@denx.de,
khilman@baylibre.com, abrodkin@synopsys.com,
ludovic.desroches@microchip.com, xinliang.liu@linaro.org,
kong.kongxinwei@hisilicon.com, tomi.valkeinen@ti.com,
james.qian.wang@arm.com, joel@jms.id.au, linux-imx@nxp.com,
puck.chen@hisilicon.com, s.hauer@pengutronix.de,
alison.wang@nxp.com, jsarha@ti.com, wens@csie.org,
vincent.abriou@st.com, kernel@pengutronix.de,
linux-arm-kernel@lists.infradead.org, mcoquelin.stm32@gmail.com,
bbrezillon@kernel.org, andrew@aj.id.au,
dri-devel@lists.freedesktop.org, nicolas.ferre@microchip.com,
yannick.fertre@st.com, kieran.bingham+renesas@ideasonboard.com,
zourongrong@gmail.com, shawnguo@kernel.org
Subject: Re: [PATCH v3 01/43] drm/cma-helper: Rename symbols from drm_cma_gem_ to drm_gem_cma_
Date: Fri, 5 Jun 2020 16:23:51 +0200 [thread overview]
Message-ID: <20200605142351.GA204352@ravnborg.org> (raw)
In-Reply-To: <8e2e8394-4110-9fb6-e99e-0495cf9f7218@suse.de>
On Fri, Jun 05, 2020 at 04:15:46PM +0200, Thomas Zimmermann wrote:
> Hi
>
> Am 05.06.20 um 10:40 schrieb Laurent Pinchart:
> > Hi Thomas,
> >
> > Thank you for the patch.
> >
> > On Fri, Jun 05, 2020 at 09:32:05AM +0200, Thomas Zimmermann wrote:
> >> This fixes the naming of several symbols within CMA helpers. No functional
> >> changes are made.
> >>
> >> Signed-off-by: Thomas Zimmermann <tzimmermann@suse.de>
> >
> > Thank you for the patch.
> >
> > Speaking of naming, I wish we could rename drm_gem_cma_* to something
> > else, as those helpers don't use CMA directly (and may not use it at
> > all), but I think that would be too much intrusive changes for too
> > little gain :-(
>
> I agree. Calling them GEM DMA helpers would be more precise. But I don't
> really see an easy solution without either a big patch that touches
> everything, or a lot of small patches with ugly intermediate states.
>
> IMHO the best option would probably be an additional header file
> drm_gem_dma_helper.h that defines a dma name for each cma name. Drivers
> could then be converted individually with a single per-driver patch.
From todo.rst:
"
Rename CMA helpers to DMA helpers
---------------------------------
CMA (standing for contiguous memory allocator) is really a bit an accident of
what these were used for first, a much better name would be DMA helpers. In the
text these should even be called coherent DMA memory helpers (so maybe CDM, but
no one knows what that means) since underneath they just use dma_alloc_coherent.
Contact: Laurent Pinchart, Daniel Vetter
Level: Intermediate (mostly because it is a huge tasks without good partial
milestones, not technically itself that challenging)
"
The same?
Sam
>
> Best regards
> Thomas
>
> >
> >> ---
> >> drivers/gpu/drm/aspeed/aspeed_gfx_drv.c | 2 +-
> >> drivers/gpu/drm/drm_gem_cma_helper.c | 10 +++++-----
> >> include/drm/drm_gem_cma_helper.h | 4 ++--
> >> 3 files changed, 8 insertions(+), 8 deletions(-)
> >>
> >> diff --git a/drivers/gpu/drm/aspeed/aspeed_gfx_drv.c b/drivers/gpu/drm/aspeed/aspeed_gfx_drv.c
> >> index 6b27242b9ee3c..5e7ea0459d018 100644
> >> --- a/drivers/gpu/drm/aspeed/aspeed_gfx_drv.c
> >> +++ b/drivers/gpu/drm/aspeed/aspeed_gfx_drv.c
> >> @@ -188,7 +188,7 @@ DEFINE_DRM_GEM_CMA_FOPS(fops);
> >>
> >> static struct drm_driver aspeed_gfx_driver = {
> >> .driver_features = DRIVER_GEM | DRIVER_MODESET | DRIVER_ATOMIC,
> >> - .gem_create_object = drm_cma_gem_create_object_default_funcs,
> >> + .gem_create_object = drm_gem_cma_create_object_default_funcs,
> >> .dumb_create = drm_gem_cma_dumb_create,
> >> .prime_handle_to_fd = drm_gem_prime_handle_to_fd,
> >> .prime_fd_to_handle = drm_gem_prime_fd_to_handle,
> >> diff --git a/drivers/gpu/drm/drm_gem_cma_helper.c b/drivers/gpu/drm/drm_gem_cma_helper.c
> >> index b3db3ca7bd7a7..842e2fa332354 100644
> >> --- a/drivers/gpu/drm/drm_gem_cma_helper.c
> >> +++ b/drivers/gpu/drm/drm_gem_cma_helper.c
> >> @@ -572,7 +572,7 @@ void drm_gem_cma_prime_vunmap(struct drm_gem_object *obj, void *vaddr)
> >> }
> >> EXPORT_SYMBOL_GPL(drm_gem_cma_prime_vunmap);
> >>
> >> -static const struct drm_gem_object_funcs drm_cma_gem_default_funcs = {
> >> +static const struct drm_gem_object_funcs drm_gem_cma_default_funcs = {
> >> .free = drm_gem_cma_free_object,
> >> .print_info = drm_gem_cma_print_info,
> >> .get_sg_table = drm_gem_cma_prime_get_sg_table,
> >> @@ -581,7 +581,7 @@ static const struct drm_gem_object_funcs drm_cma_gem_default_funcs = {
> >> };
> >>
> >> /**
> >> - * drm_cma_gem_create_object_default_funcs - Create a CMA GEM object with a
> >> + * drm_gem_cma_create_object_default_funcs - Create a CMA GEM object with a
> >> * default function table
> >> * @dev: DRM device
> >> * @size: Size of the object to allocate
> >> @@ -593,7 +593,7 @@ static const struct drm_gem_object_funcs drm_cma_gem_default_funcs = {
> >> * A pointer to a allocated GEM object or an error pointer on failure.
> >> */
> >> struct drm_gem_object *
> >> -drm_cma_gem_create_object_default_funcs(struct drm_device *dev, size_t size)
> >> +drm_gem_cma_create_object_default_funcs(struct drm_device *dev, size_t size)
> >> {
> >> struct drm_gem_cma_object *cma_obj;
> >>
> >> @@ -601,11 +601,11 @@ drm_cma_gem_create_object_default_funcs(struct drm_device *dev, size_t size)
> >> if (!cma_obj)
> >> return NULL;
> >>
> >> - cma_obj->base.funcs = &drm_cma_gem_default_funcs;
> >> + cma_obj->base.funcs = &drm_gem_cma_default_funcs;
> >>
> >> return &cma_obj->base;
> >> }
> >> -EXPORT_SYMBOL(drm_cma_gem_create_object_default_funcs);
> >> +EXPORT_SYMBOL(drm_gem_cma_create_object_default_funcs);
> >>
> >> /**
> >> * drm_gem_cma_prime_import_sg_table_vmap - PRIME import another driver's
> >> diff --git a/include/drm/drm_gem_cma_helper.h b/include/drm/drm_gem_cma_helper.h
> >> index 947ac95eb24a9..64b7e9d42129a 100644
> >> --- a/include/drm/drm_gem_cma_helper.h
> >> +++ b/include/drm/drm_gem_cma_helper.h
> >> @@ -107,7 +107,7 @@ void *drm_gem_cma_prime_vmap(struct drm_gem_object *obj);
> >> void drm_gem_cma_prime_vunmap(struct drm_gem_object *obj, void *vaddr);
> >>
> >> struct drm_gem_object *
> >> -drm_cma_gem_create_object_default_funcs(struct drm_device *dev, size_t size);
> >> +drm_gem_cma_create_object_default_funcs(struct drm_device *dev, size_t size);
> >>
> >> /**
> >> * DRM_GEM_CMA_VMAP_DRIVER_OPS - CMA GEM driver operations ensuring a virtual
> >> @@ -118,7 +118,7 @@ drm_cma_gem_create_object_default_funcs(struct drm_device *dev, size_t size);
> >> * imported buffers.
> >> */
> >> #define DRM_GEM_CMA_VMAP_DRIVER_OPS \
> >> - .gem_create_object = drm_cma_gem_create_object_default_funcs, \
> >> + .gem_create_object = drm_gem_cma_create_object_default_funcs, \
> >> .dumb_create = drm_gem_cma_dumb_create, \
> >> .prime_handle_to_fd = drm_gem_prime_handle_to_fd, \
> >> .prime_fd_to_handle = drm_gem_prime_fd_to_handle, \
> >
>
> --
> Thomas Zimmermann
> Graphics Driver Developer
> SUSE Software Solutions Germany GmbH
> Maxfeldstr. 5, 90409 Nürnberg, Germany
> (HRB 36809, AG Nürnberg)
> Geschäftsführer: Felix Imendörffer
>
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2020-06-05 14:24 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-06-05 7:32 [PATCH v3 00/43] Convert most CMA-based drivers to GEM object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 01/43] drm/cma-helper: Rename symbols from drm_cma_gem_ to drm_gem_cma_ Thomas Zimmermann
2020-06-05 8:40 ` Laurent Pinchart
2020-06-05 14:15 ` Thomas Zimmermann
2020-06-05 14:23 ` Sam Ravnborg [this message]
2020-06-05 14:40 ` Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 02/43] drm/cma-helper: Rework DRM_GEM_CMA_VMAP_DRIVER_OPS macro Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 03/43] drm/cma-helper: Add DRM_GEM_CMA_DRIVER_OPS to set default GEM CMA functions Thomas Zimmermann
2020-06-05 8:16 ` Laurent Pinchart
2020-06-09 9:45 ` Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 04/43] drm/arc: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 05/43] drm/arc: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 06/43] drm/arm: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 07/43] drm/arm: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 08/43] drm/atmel-hlcdc: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 09/43] drm/atmel-hlcdc: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 10/43] drm/fsl-dcu: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 11/43] drm/fsl-dcu: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 12/43] drm/hisilicon/kirin: Set .dumb_create to drm_gem_cma_dumb_create() Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 13/43] drm/hisilicon/kirin: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 14/43] drm/hisilicon/kirin: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 15/43] drm/imx: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 16/43] drm/imx: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 17/43] drm/ingenic: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 18/43] drm/ingenic: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 19/43] drm/komeda: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 20/43] drm/komeda: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS_WITH_DUMB_CREATE Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 21/43] drm/malidp: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 22/43] drm/malidp: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS_WITH_DUMB_CREATE Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 23/43] drm/mcde: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 24/43] drm/mcde: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 25/43] drm/meson: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 26/43] drm/meson: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS_WITH_DUMB_CREATE Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 27/43] drm/mxsfb: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 28/43] drm/mxsfb: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 29/43] drm/rcar-du: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 8:23 ` Laurent Pinchart
2020-06-05 7:32 ` [PATCH v3 30/43] drm/rcar-du: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS_WITH_DUMB_CREATE Thomas Zimmermann
2020-06-05 8:14 ` Laurent Pinchart
2020-06-05 7:32 ` [PATCH v3 31/43] drm/shmobile: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 8:20 ` Laurent Pinchart
2020-06-05 7:32 ` [PATCH v3 32/43] drm/shmobile: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 8:13 ` Laurent Pinchart
2020-06-05 7:32 ` [PATCH v3 33/43] drm/stm: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 34/43] drm/stm: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS_WITH_DUMB_CREATE Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 35/43] drm/sti: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 36/43] drm/sti: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 37/43] drm/tilcdc: Use GEM CMA object functions Thomas Zimmermann
2020-06-24 9:03 ` Jyri Sarha
2020-06-05 7:32 ` [PATCH v3 38/43] drm/tilcdc: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-24 9:03 ` Jyri Sarha
2020-06-05 7:32 ` [PATCH v3 39/43] drm/tve200: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 40/43] drm/tve200: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 41/43] drm/zte: Use GEM CMA object functions Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 42/43] drm/zte: Set GEM CMA functions with DRM_GEM_CMA_DRIVER_OPS Thomas Zimmermann
2020-06-05 7:32 ` [PATCH v3 43/43] drm: Remove struct drm_driver.gem_print_info Thomas Zimmermann
2020-06-05 8:37 ` Laurent Pinchart
2020-06-05 15:40 ` [PATCH v3 00/43] Convert most CMA-based drivers to GEM object functions Emil Velikov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200605142351.GA204352@ravnborg.org \
--to=sam@ravnborg.org \
--cc=abrodkin@synopsys.com \
--cc=airlied@linux.ie \
--cc=alexandre.belloni@bootlin.com \
--cc=alexandre.torgue@st.com \
--cc=alison.wang@nxp.com \
--cc=andrew@aj.id.au \
--cc=bbrezillon@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=james.qian.wang@arm.com \
--cc=joel@jms.id.au \
--cc=jsarha@ti.com \
--cc=kernel@pengutronix.de \
--cc=khilman@baylibre.com \
--cc=kieran.bingham+renesas@ideasonboard.com \
--cc=kong.kongxinwei@hisilicon.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-aspeed@lists.ozlabs.org \
--cc=linux-imx@nxp.com \
--cc=liviu.dudau@arm.com \
--cc=ludovic.desroches@microchip.com \
--cc=marex@denx.de \
--cc=mcoquelin.stm32@gmail.com \
--cc=mihail.atanassov@arm.com \
--cc=narmstrong@baylibre.com \
--cc=nicolas.ferre@microchip.com \
--cc=paul@crapouillou.net \
--cc=philippe.cornu@st.com \
--cc=puck.chen@hisilicon.com \
--cc=s.hauer@pengutronix.de \
--cc=shawnguo@kernel.org \
--cc=tomi.valkeinen@ti.com \
--cc=tzimmermann@suse.de \
--cc=vincent.abriou@st.com \
--cc=wens@csie.org \
--cc=xinliang.liu@linaro.org \
--cc=yannick.fertre@st.com \
--cc=zourongrong@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox