From: Jagan Teki <jagan@amarulasolutions.com>
To: Andrzej Hajda <andrzej.hajda@intel.com>,
Inki Dae <inki.dae@samsung.com>,
Marek Szyprowski <m.szyprowski@samsung.com>,
Joonyoung Shim <jy0922.shim@samsung.com>,
Seung-Woo Kim <sw0312.kim@samsung.com>,
Kyungmin Park <kyungmin.park@samsung.com>,
Frieder Schrempf <frieder.schrempf@kontron.de>,
Fancy Fang <chen.fang@nxp.com>,
Tim Harvey <tharvey@gateworks.com>,
Michael Nazzareno Trimarchi <michael@amarulasolutions.com>,
Adam Ford <aford173@gmail.com>,
Neil Armstrong <narmstrong@linaro.org>,
Robert Foss <robert.foss@linaro.org>,
Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
Tommaso Merciai <tommaso.merciai@amarulasolutions.com>,
Marek Vasut <marex@denx.de>
Cc: linux-samsung-soc@vger.kernel.org,
Matteo Lisi <matteo.lisi@engicam.com>,
dri-devel@lists.freedesktop.org,
NXP Linux Team <linux-imx@nxp.com>,
linux-amarula <linux-amarula@amarulasolutions.com>,
linux-arm-kernel@lists.infradead.org,
Jagan Teki <jagan@amarulasolutions.com>
Subject: [PATCH v8 02/14] drm: exynos: dsi: Properly name HSA/HBP/HFP/HSE bits
Date: Fri, 11 Nov 2022 00:08:41 +0530 [thread overview]
Message-ID: <20221110183853.3678209-3-jagan@amarulasolutions.com> (raw)
In-Reply-To: <20221110183853.3678209-1-jagan@amarulasolutions.com>
HSA/HBP/HFP/HSE mode bits in Exynos DSI host specify a naming
conversion as 'disable mode bit' due to its bit definition,
0 = Enable and 1 = Disable.
Fix the naming convention of the mode bits.
Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
---
drivers/gpu/drm/exynos/exynos_drm_dsi.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c b/drivers/gpu/drm/exynos/exynos_drm_dsi.c
index b5305b145ddb..fce7f0a7e4ee 100644
--- a/drivers/gpu/drm/exynos/exynos_drm_dsi.c
+++ b/drivers/gpu/drm/exynos/exynos_drm_dsi.c
@@ -75,10 +75,10 @@
#define DSIM_MAIN_PIX_FORMAT_RGB565 (0x4 << 12)
#define DSIM_SUB_VC (((x) & 0x3) << 16)
#define DSIM_MAIN_VC (((x) & 0x3) << 18)
-#define DSIM_HSA_MODE (1 << 20)
-#define DSIM_HBP_MODE (1 << 21)
-#define DSIM_HFP_MODE (1 << 22)
-#define DSIM_HSE_MODE (1 << 23)
+#define DSIM_HSA_DISABLE (1 << 20)
+#define DSIM_HBP_DISABLE (1 << 21)
+#define DSIM_HFP_DISABLE (1 << 22)
+#define DSIM_HSE_DISABLE (1 << 23)
#define DSIM_AUTO_MODE (1 << 24)
#define DSIM_VIDEO_MODE (1 << 25)
#define DSIM_BURST_MODE (1 << 26)
@@ -804,13 +804,13 @@ static int exynos_dsi_init_link(struct exynos_dsi *dsi)
if (dsi->mode_flags & MIPI_DSI_MODE_VIDEO_AUTO_VERT)
reg |= DSIM_AUTO_MODE;
if (dsi->mode_flags & MIPI_DSI_MODE_VIDEO_HSE)
- reg |= DSIM_HSE_MODE;
+ reg |= DSIM_HSE_DISABLE;
if (dsi->mode_flags & MIPI_DSI_MODE_VIDEO_NO_HFP)
- reg |= DSIM_HFP_MODE;
+ reg |= DSIM_HFP_DISABLE;
if (dsi->mode_flags & MIPI_DSI_MODE_VIDEO_NO_HBP)
- reg |= DSIM_HBP_MODE;
+ reg |= DSIM_HBP_DISABLE;
if (dsi->mode_flags & MIPI_DSI_MODE_VIDEO_NO_HSA)
- reg |= DSIM_HSA_MODE;
+ reg |= DSIM_HSA_DISABLE;
}
if (dsi->mode_flags & MIPI_DSI_MODE_NO_EOT_PACKET)
--
2.25.1
next prev parent reply other threads:[~2022-11-10 18:40 UTC|newest]
Thread overview: 61+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-11-10 18:38 [PATCH v8 00/14] drm: bridge: Add Samsung MIPI DSIM bridge Jagan Teki
2022-11-10 18:38 ` [PATCH v8 01/14] drm: exynos: dsi: Fix MIPI_DSI*_NO_* mode flags Jagan Teki
2022-11-11 0:49 ` Nicolas Boichat
2022-11-11 8:49 ` Jagan Teki
2022-11-11 12:12 ` Nicolas Boichat
2022-11-11 12:45 ` Jagan Teki
2022-11-13 0:29 ` Marek Vasut
2022-11-14 1:11 ` Nicolas Boichat
2022-11-14 3:16 ` Marek Vasut
2022-12-05 11:55 ` Frieder Schrempf
2022-11-10 18:38 ` Jagan Teki [this message]
2022-11-13 0:25 ` [PATCH v8 02/14] drm: exynos: dsi: Properly name HSA/HBP/HFP/HSE bits Marek Vasut
2022-11-14 8:27 ` Jagan Teki
2022-12-05 11:59 ` Frieder Schrempf
2022-12-05 12:06 ` Jagan Teki
2022-11-10 18:38 ` [PATCH v8 03/14] drm: bridge: Generalize Exynos-DSI driver into a Samsung DSIM bridge Jagan Teki
2022-11-17 5:01 ` Marek Vasut
2022-11-18 6:40 ` Jagan Teki
2022-11-10 18:38 ` [PATCH v8 04/14] drm: bridge: samsung-dsim: Lookup OF-graph or Child node devices Jagan Teki
2022-11-10 18:38 ` [PATCH v8 05/14] drm: bridge: samsung-dsim: Mark PHY as optional Jagan Teki
2022-11-10 18:38 ` [PATCH v8 06/14] drm: bridge: samsung-dsim: Handle proper DSI host initialization Jagan Teki
2022-11-17 4:58 ` Marek Vasut
2022-11-17 13:04 ` Marek Szyprowski
2022-11-19 13:36 ` Marek Vasut
2022-11-23 20:09 ` Jagan Teki
2022-11-25 22:14 ` Marek Vasut
2022-11-28 14:43 ` Jagan Teki
2022-12-02 10:52 ` Marek Szyprowski
2022-12-02 12:21 ` Marek Vasut
2022-12-02 14:55 ` Dave Stevenson
2022-12-05 7:30 ` Frieder Schrempf
2022-12-05 15:20 ` Dave Stevenson
2022-12-05 15:37 ` Frieder Schrempf
2022-12-06 9:02 ` Frieder Schrempf
2022-12-08 11:32 ` Jagan Teki
2022-12-08 12:21 ` Marek Szyprowski
2022-11-10 18:38 ` [PATCH v8 07/14] drm: bridge: samsung-dsim: Add atomic_check Jagan Teki
2022-11-10 18:38 ` [PATCH v8 08/14] drm: bridge: samsung-dsim: Add platform PLL_P (PMS_P) offset Jagan Teki
2022-11-10 18:38 ` [PATCH v8 09/14] drm: bridge: samsung-dsim: Add atomic_get_input_bus_fmts Jagan Teki
2022-11-13 0:21 ` Marek Vasut
2022-11-14 7:49 ` Jagan Teki
2022-11-15 12:00 ` Marek Vasut
2022-11-16 8:07 ` Marek Szyprowski
2022-11-16 10:49 ` Marek Vasut
2022-11-16 11:07 ` Marek Szyprowski
2022-11-16 11:30 ` Jagan Teki
2022-11-14 10:57 ` Marek Szyprowski
2022-11-14 14:40 ` Marek Szyprowski
2022-11-14 17:07 ` Jagan Teki
2022-11-15 8:09 ` Marek Szyprowski
2022-11-15 8:48 ` Frieder Schrempf
2022-11-15 9:20 ` Jagan Teki
2022-11-15 21:38 ` Marek Szyprowski
2022-11-10 18:38 ` [PATCH v8 10/14] drm: bridge: samsung-dsim: Add input_bus_flags Jagan Teki
2022-11-10 18:38 ` [PATCH v8 11/14] dt-bindings: display: exynos: dsim: Add NXP i.MX8M Mini/Nano support Jagan Teki
2022-11-10 18:38 ` [PATCH v8 12/14] drm: bridge: samsung-dsim: Add " Jagan Teki
2022-11-10 18:38 ` [PATCH v8 13/14] dt-bindings: display: exynos: dsim: Add NXP i.MX8M Plus support Jagan Teki
2022-11-10 18:38 ` [PATCH v8 14/14] drm: bridge: samsung-dsim: Add " Jagan Teki
2022-11-14 8:41 ` [PATCH v8 00/14] drm: bridge: Add Samsung MIPI DSIM bridge Frieder Schrempf
2022-11-14 8:47 ` Jagan Teki
2022-12-05 13:22 ` Frieder Schrempf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20221110183853.3678209-3-jagan@amarulasolutions.com \
--to=jagan@amarulasolutions.com \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=aford173@gmail.com \
--cc=andrzej.hajda@intel.com \
--cc=chen.fang@nxp.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=frieder.schrempf@kontron.de \
--cc=inki.dae@samsung.com \
--cc=jy0922.shim@samsung.com \
--cc=kyungmin.park@samsung.com \
--cc=linux-amarula@amarulasolutions.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-imx@nxp.com \
--cc=linux-samsung-soc@vger.kernel.org \
--cc=m.szyprowski@samsung.com \
--cc=marex@denx.de \
--cc=matteo.lisi@engicam.com \
--cc=michael@amarulasolutions.com \
--cc=narmstrong@linaro.org \
--cc=robert.foss@linaro.org \
--cc=sw0312.kim@samsung.com \
--cc=tharvey@gateworks.com \
--cc=tommaso.merciai@amarulasolutions.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox