dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Michel Dänzer" <michel@daenzer.net>
To: Dave Airlie <airlied@gmail.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH] drm: use kvfree instead of opencoding
Date: Thu, 29 Jan 2015 12:10:24 +0900	[thread overview]
Message-ID: <54C9A4A0.4050604@daenzer.net> (raw)
In-Reply-To: <1422499001-12678-1-git-send-email-airlied@gmail.com>

On 29.01.2015 11:36, Dave Airlie wrote:
> From: Dave Airlie <airlied@redhat.com>
> 
> Al Viro added this to the mm finally, so instead
> of opencoding it use kvfree instead.
> 
> Signed-off-by: Dave Airlie <airlied@redhat.com>
> ---
>  drivers/gpu/drm/nouveau/nouveau_gem.c | 5 +----
>  include/drm/drm_mem_util.h            | 5 +----
>  2 files changed, 2 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/gpu/drm/nouveau/nouveau_gem.c b/drivers/gpu/drm/nouveau/nouveau_gem.c
> index 7c077fc..7270649 100644
> --- a/drivers/gpu/drm/nouveau/nouveau_gem.c
> +++ b/drivers/gpu/drm/nouveau/nouveau_gem.c
> @@ -552,10 +552,7 @@ nouveau_gem_pushbuf_validate(struct nouveau_channel *chan,
>  static inline void
>  u_free(void *addr)
>  {
> -	if (!is_vmalloc_addr(addr))
> -		kfree(addr);
> -	else
> -		vfree(addr);
> +	kvfree(addr);
>  }
>  
>  static inline void *
> diff --git a/include/drm/drm_mem_util.h b/include/drm/drm_mem_util.h
> index 19a2404..e42495a 100644
> --- a/include/drm/drm_mem_util.h
> +++ b/include/drm/drm_mem_util.h
> @@ -56,10 +56,7 @@ static __inline__ void *drm_malloc_ab(size_t nmemb, size_t size)
>  
>  static __inline void drm_free_large(void *ptr)
>  {
> -	if (!is_vmalloc_addr(ptr))
> -		return kfree(ptr);
> -
> -	vfree(ptr);
> +	kvfree(ptr);
>  }
>  
>  #endif
> 

Any reason for keeping the u_free and drm_free_large wrappers?


-- 
Earthling Michel Dänzer               |               http://www.amd.com
Libre software enthusiast             |             Mesa and X developer
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

      reply	other threads:[~2015-01-29  3:10 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-01-29  2:36 [PATCH] drm: use kvfree instead of opencoding Dave Airlie
2015-01-29  3:10 ` Michel Dänzer [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=54C9A4A0.4050604@daenzer.net \
    --to=michel@daenzer.net \
    --cc=airlied@gmail.com \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox