From: Archit Taneja <architt@codeaurora.org>
To: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH RESEND v2 06/25] drm/fb_helper: Create a wrapper for remove_conflicting_framebuffers
Date: Wed, 29 Jul 2015 09:50:56 +0530 [thread overview]
Message-ID: <55B854A8.7050102@codeaurora.org> (raw)
In-Reply-To: <20150728184954.GL16722@phenom.ffwll.local>
On 07/29/2015 12:19 AM, Daniel Vetter wrote:
> On Tue, Jul 28, 2015 at 08:46:24PM +0200, Daniel Vetter wrote:
>> On Wed, Jul 22, 2015 at 02:58:01PM +0530, Archit Taneja wrote:
>>> Some drm drivers call remove_conflicting_framebuffers. Create a
>>> drm_fb_helper function that wraps around these calls.
>>>
>>> This is part of an effort to prevent drm drivers from calling fbdev
>>> functions directly, in order to make fbdev emulation a top level drm
>>> option.
>>>
>>> v2:
>>> - Added kerneldocs
>>> - Follow the drm way of aligning of arguments in func definitions
>>>
>>> Signed-off-by: Archit Taneja <architt@codeaurora.org>
>>> ---
>>> drivers/gpu/drm/drm_fb_helper.c | 15 +++++++++++++++
>>> include/drm/drm_fb_helper.h | 4 ++++
>>> 2 files changed, 19 insertions(+)
>>>
>>> diff --git a/drivers/gpu/drm/drm_fb_helper.c b/drivers/gpu/drm/drm_fb_helper.c
>>> index 9620aa5..86e4e2c 100644
>>> --- a/drivers/gpu/drm/drm_fb_helper.c
>>> +++ b/drivers/gpu/drm/drm_fb_helper.c
>>> @@ -894,6 +894,21 @@ void drm_fb_helper_set_suspend(struct drm_fb_helper *fb_helper, int state)
>>> }
>>> EXPORT_SYMBOL(drm_fb_helper_set_suspend);
>>>
>>> +/**
>>> + * drm_fb_helper_remove_conflicting_framebuffers - wrapper around
>>> + * remove_conflicting_framebuffers
>>> + * @fb_helper: driver-allocated fbdev helper
>>> + *
>>> + * A wrapper around remove_conflicting_framebuffers implemented by fbdev core
>>> + */
>>> +int drm_fb_helper_remove_conflicting_framebuffers(struct apertures_struct *a,
>>> + const char *name,
>>> + bool primary)
>>> +{
>>> + return remove_conflicting_framebuffers(a, name, primary);
>>> +}
>>> +EXPORT_SYMBOL(drm_fb_helper_remove_conflicting_framebuffers);
>>
>> Chris Wilson reported on irc that if he builds with I915_FBDEV=n then
>> there's a missing symbol problem here because i915 wants to kick out other
>> framebuffers (well we have to for correctness) even when fbdev emulation
>> is disabled. If you look at i915_dma.c you'll see that the call to
>> remove_conflicting_framebuffers is conditional upon CONFIG_FB and not
>> CONFIG_I915_FBDEV.
>>
>> I think the proper solution here would be to provide a static inline
>> helper for remove_conflicting_framebuffer itself when CONFIG_FB=n, since a
>> all drivers who call this still want to call this even when fbdev
>> emulation is disabled.
>>
>> Plan B would be to move this into core drm and make the static inline one
>> selected for CONFIG_FB=n. If you do that then maybe also rename it to
>> drm_remove_conflicting_framebuffer since this really is only tangetial to
>> fbdev emulation.
>>
>> Anyway current patch unfortunately won't work since we really must remove
>> other framebuffers even in the FB=y, I915_FBDEV=n case. So I dropped it
>> from drm-misc for now. Unfortunately that means all the driver conversions
>> won't apply anymore either :(
>
> Ok I didn't have to drop all of the driver specific patches since all the
> arm ones don't have calls to remove_conflicting_framebuffers.
I can re-spin the x86 ones and make them stick to the original
remove_conflicting_framebuffers call. This way we can at least use the
other helpers.
Archit
--
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2015-07-29 4:21 UTC|newest]
Thread overview: 61+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1437548401-10125-1-git-send-email-architt@codeaurora.or>
2015-07-22 9:27 ` [PATCH RESEND v2 00/25] drm: fb emulation: Step 1: Create new drm_fb_helper wrapper funcs Archit Taneja
2015-07-22 9:27 ` [PATCH RESEND v2 01/25] drm/fb_helper: Add drm_fb_helper functions to manage fb_info creation Archit Taneja
2015-07-22 9:27 ` [PATCH RESEND v2 02/25] drm/fb_helper: Create a wrapper for unlink_framebuffer Archit Taneja
2015-07-22 9:27 ` [PATCH RESEND v2 03/25] drm/fb_helper: Create wrappers for fb_sys_read/write funcs Archit Taneja
2015-07-22 9:27 ` [PATCH RESEND v2 04/25] drm/fb_helper: Create wrappers for blit, copyarea and fillrect funcs Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 05/25] drm/fb_helper: Create a wrapper for fb_set_suspend Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 06/25] drm/fb_helper: Create a wrapper for remove_conflicting_framebuffers Archit Taneja
2015-07-28 18:46 ` Daniel Vetter
2015-07-28 18:49 ` Daniel Vetter
2015-07-29 4:20 ` Archit Taneja [this message]
2015-07-29 6:30 ` Daniel Vetter
2015-07-29 4:19 ` Archit Taneja
2015-07-29 6:30 ` Daniel Vetter
2015-07-22 9:28 ` [PATCH RESEND v2 07/25] drm/cirrus: Use new drm_fb_helper functions Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 08/25] drm/rockchip: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 09/25] drm/armada: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 10/25] drm/ast: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 11/25] drm/omap: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 12/25] drm/tegra: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 13/25] drm/msm: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 14/25] drm/exynos: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 15/25] drm/gma500: " Archit Taneja
2015-07-22 20:59 ` Patrik Jakobsson
2015-07-22 9:28 ` [PATCH RESEND v2 16/25] drm/mgag200: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 17/25] drm/radeon: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 18/25] drm/qxl: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 19/25] drm/i915: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 20/25] drm/nouveau: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 21/25] drm/udl: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 22/25] drm/bochs: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 23/25] drm/amdgpu: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 24/25] drm/virtio: " Archit Taneja
2015-07-22 9:28 ` [PATCH RESEND v2 25/25] drm/fb_cma_helper: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 00/24] drm: fb emulation: Step 1: Create new drm_fb_helper wrapper funcs Archit Taneja
2015-07-31 10:51 ` [PATCH v3 00/24] rm: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 01/24] drm/fb_helper: Add drm_fb_helper functions to manage fb_info creation Archit Taneja
2015-07-31 10:51 ` [PATCH v3 02/24] drm/fb_helper: Create a wrapper for unlink_framebuffer Archit Taneja
2015-07-31 10:51 ` [PATCH v3 03/24] drm/fb_helper: Create wrappers for fb_sys_read/write funcs Archit Taneja
2015-07-31 10:51 ` [PATCH v3 04/24] drm/fb_helper: Create wrappers for blit, copyarea and fillrect funcs Archit Taneja
2015-07-31 10:51 ` [PATCH v3 05/24] drm/fb_helper: Create a wrapper for fb_set_suspend Archit Taneja
2015-07-31 10:51 ` [PATCH v3 06/24] drm/cirrus: Use new drm_fb_helper functions Archit Taneja
2015-07-31 10:51 ` [PATCH v3 07/24] drm/rockchip: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 08/24] drm/armada: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 09/24] drm/ast: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 10/24] drm/omap: " Archit Taneja
2015-08-01 9:55 ` Laurent Pinchart
2015-08-20 10:38 ` Tomi Valkeinen
2015-07-31 10:51 ` [PATCH v3 11/24] drm/tegra: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 12/24] drm/msm: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 13/24] drm/exynos: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 14/24] drm/gma500: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 15/24] drm/mgag200: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 16/24] drm/radeon: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 17/24] drm/qxl: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 18/24] drm/i915: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 19/24] drm/nouveau: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 20/24] drm/udl: " Archit Taneja
2015-07-31 10:51 ` [PATCH v3 21/24] drm/bochs: " Archit Taneja
2015-07-31 10:52 ` [PATCH v3 22/24] drm/amdgpu: " Archit Taneja
2015-07-31 10:52 ` [PATCH v3 23/24] drm/virtio: " Archit Taneja
2015-07-31 10:52 ` [PATCH v3 24/24] drm/fb_cma_helper: " Archit Taneja
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=55B854A8.7050102@codeaurora.org \
--to=architt@codeaurora.org \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox