dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Christian König" <deathsimple@vodafone.de>
To: "Marek Olšák" <maraeo@gmail.com>
Cc: Maling list - DRI developers <dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH 00/10] libdrm amdgpu patches
Date: Wed, 13 Jan 2016 12:34:10 +0100	[thread overview]
Message-ID: <56963632.4020708@vodafone.de> (raw)
In-Reply-To: <CAAxE2A49JB-NQq7s9kq1Dkf6q2L48WQDyyq1HyS-jHnORV_Z-w@mail.gmail.com>

Am 13.01.2016 um 12:15 schrieb Marek Olšák:
> On Wed, Jan 13, 2016 at 11:43 AM, Christian König
> <deathsimple@vodafone.de> wrote:
>> Am 12.01.2016 um 22:30 schrieb Alex Deucher:
>>> On Tue, Jan 12, 2016 at 4:23 PM, Marek Olšák <maraeo@gmail.com> wrote:
>>>> Hi,
>>>>
>>>> These are libdrm_amdgpu patches harvested from an internal branch.
>>>>
>>>> The first patch is a revert I had to make to fix the build. Yeah,
>>>> sequence_mutex should be renamed to a more appropriate name. That can be
>>>> done as a follow-up.
>>>>
>>>> One notable change is the addition of DRM_IOCTL_AMDGPU_WAIT_FENCES. I
>>>> hope the kernel contains (or will contain) the changes too, so that I don't
>>>> push something that doesn't exist in the kernel.
>>> We haven't pushed DRM_IOCTL_AMDGPU_WAIT_FENCES upstream yet so I would
>>> hold off on any changes that depend on that.
>>
>> Yeah, and do we really have patch #9 in our internal branch without an
>> Review? Cause that one breaks the API.
> It doesn't break the API, because the API is added by this series in
> an earlier patch. The API would be broken if it was changed between
> two libdrm versions.

Ah, in this case please squash the two patches together for upstreaming.

Regards,
Christian.

>
> Marek

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

      reply	other threads:[~2016-01-13 11:34 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-01-12 21:23 [PATCH 00/10] libdrm amdgpu patches Marek Olšák
2016-01-12 21:23 ` [PATCH 01/10] Revert "amdgpu: remove sequence mutex" Marek Olšák
2016-01-12 21:23 ` [PATCH 02/10] amdgpu: add the interface of waiting multiple fences Marek Olšák
2016-01-12 21:23 ` [PATCH 03/10] amdgpu: drop address patching logics Marek Olšák
2016-01-12 21:23 ` [PATCH 04/10] amdgpu/tests: add multi-fence test in base test Marek Olšák
2016-01-12 21:23 ` [PATCH 05/10] amdgpu: Cast pointer to uintptr_t for assignment to unsigned integer Marek Olšák
2016-01-13  3:31   ` Michel Dänzer
2016-01-12 21:23 ` [PATCH 06/10] amdgpu: add semaphore support Marek Olšák
2016-01-12 21:23 ` [PATCH 07/10] tests/amdgpu: add semaphore test Marek Olšák
2016-01-12 21:23 ` [PATCH 08/10] amdgpu: validate user memory for userptr Marek Olšák
2016-01-12 21:23 ` [PATCH 09/10] amdgpu: cs_wait_fences now can return the first signaled fence index Marek Olšák
2016-01-12 21:23 ` [PATCH 10/10] amdgpu: list each entry safely for sw semaphore when submit ib Marek Olšák
2016-01-12 21:30 ` [PATCH 00/10] libdrm amdgpu patches Alex Deucher
2016-01-13 10:43   ` Christian König
2016-01-13 11:15     ` Marek Olšák
2016-01-13 11:34       ` Christian König [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=56963632.4020708@vodafone.de \
    --to=deathsimple@vodafone.de \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=maraeo@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox