From mboxrd@z Thu Jan 1 00:00:00 1970 From: Kevin Hilman Subject: Re: [PATCH 4/9] drm: meson: vpp: use proper macros instead of magic constants Date: Mon, 24 Jun 2019 16:15:28 -0700 Message-ID: <7h36jyy3qn.fsf@baylibre.com> References: <86zhm782g5.fsf@baylibre.com> <86tvcf82eu.fsf@baylibre.com> Mime-Version: 1.0 Content-Type: text/plain Return-path: In-Reply-To: <86tvcf82eu.fsf@baylibre.com> Sender: linux-kernel-owner@vger.kernel.org To: 86zhm782g5.fsf@baylibre.com, Neil Armstrong Cc: linux-arm-kernel@lists.infradead.org, linux-amlogic@lists.infradead.org, dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, Julien Masson List-Id: dri-devel@lists.freedesktop.org Julien Masson writes: > This patch add new macros which are used to set the following > registers: > - VPP_OSD_SCALE_COEF_IDX > - VPP_DOLBY_CTRL > - VPP_OFIFO_SIZE > - VPP_HOLD_LINES > - VPP_SC_MISC > - VPP_VADJ_CTRL > > Signed-off-by: Julien Masson [...] > @@ -97,20 +97,22 @@ void meson_vpp_init(struct meson_drm *priv) > else if (meson_vpu_is_compatible(priv, "amlogic,meson-gxm-vpu")) { > writel_bits_relaxed(0xff << 16, 0xff << 16, > priv->io_base + _REG(VIU_MISC_CTRL1)); > - writel_relaxed(0x20000, priv->io_base + _REG(VPP_DOLBY_CTRL)); > - writel_relaxed(0x1020080, > + writel_relaxed(VPP_PPS_DUMMY_DATA_MODE, > + priv->io_base + _REG(VPP_DOLBY_CTRL)); > + writel_relaxed(0x108080, nit: still a magic constant here, and it's not obvious why it's different from the current one. Kevin