From: John Ogness <john.ogness@linutronix.de>
To: Petr Mladek <pmladek@suse.com>
Cc: Jocelyn Falempe <jfalempe@redhat.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Daniel Vetter <daniel@ffwll.ch>,
Javier Martinez Canillas <javierm@redhat.com>,
"Guilherme G . Piccoli" <gpiccoli@igalia.com>,
bluescreen_avenger@verizon.net,
Caleb Connolly <caleb.connolly@linaro.org>,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 5/6] drm/log: Implement suspend/resume
Date: Tue, 05 Nov 2024 15:25:31 +0106 [thread overview]
Message-ID: <844j4lepak.fsf@jogness.linutronix.de> (raw)
In-Reply-To: <ZyoNZfLT6tlVAWjO@pathway.suse.cz>
On 2024-11-05, Petr Mladek <pmladek@suse.com> wrote:
> Observation:
>
> + CON_ENABLED is not needed for the original purpose. Only enabled
> consoles are added into @console_list.
>
> + CON_ENABLED is still used to explicitely block the console driver
> during suspend by console_stop()/console_start() in serial_core.c.
>
> It is not bad. But it is a bit confusing because we have
> CON_SUSPENDED flag now and this is about suspend/resume.
Also note that CON_ENABLED is used to gate ->unblank(). It should
probably consider CON_SUSPENDED as well.
> + CON_SUSPENDED is per-console flag but it is set synchronously
> for all consoles.
>
> IMHO, a global variable would make more sense for the big hammer
> purpose.
>
>
> Big question:
>
> Does the driver really needs to call console_stop()/console_start()
> when there is the big hammer?
>
> I would preserve it because it makes the design more robust.
Agreed. They serve different purposes.
console_stop()/console_start() is a method for _drivers_ to communicate
that they must not be called because their hardware is not
available/functioning.
console_suspend()/console_resume() is a method for the _system_ to
communicate that consoles should be silent because they are annoying or
we do not trust that they won't cause problems.
> Anyway, the driver-specific handling looks like the right solution.
> The big hammer feels like a workaround.
Agreed. Do the 6 call sites even really need the big hammer? I am
guessing yes because there are probably console drivers that do not use
console_stop()/console_start() in their suspend/resume and thus rely on
the whole subsystem being disabled.
> Reasonable semantic:
>
> 1. Rename:
>
> console_suspend() -> console_suspend_all()
> console_resume() -> console_resume_all()
>
> and manipulate a global @consoles_suspended variable agagin.
> It is the big hammer API.
Agreed. As a global variable, it can still rely on SRCU for
synchronization.
> 2. Rename:
>
> console_stop(con) -> console_suspend(con)
> console_start(con) -> console_resume(con)
>
> and manipulare the per-console CON_SUSPENDED flag here.
Agreed.
> 3. Get rid of the ambiguous CON_ENABLED flag. It won't longer
> have any purpose.
>
> Except that it is also used to force console registration.
> But it can be done a better way, e.g. by introducing
> register_console_force() API.
Agreed.
John
next prev parent reply other threads:[~2024-11-05 14:19 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-23 12:00 [PATCH v5 0/6] drm/log: Introduce a new boot logger to draw the kmsg on the screen Jocelyn Falempe
2024-10-23 12:00 ` [PATCH v5 1/6] drm/panic: Move drawing functions to drm_draw Jocelyn Falempe
2024-10-23 12:00 ` [PATCH v5 2/6] drm/log: Introduce a new boot logger to draw the kmsg on the screen Jocelyn Falempe
2024-10-23 12:00 ` [PATCH v5 3/6] drm/log: Do not draw if drm_master is taken Jocelyn Falempe
2024-10-23 12:00 ` [PATCH v5 4/6] drm/log: Color the timestamp, to improve readability Jocelyn Falempe
2024-10-23 12:00 ` [PATCH v5 5/6] drm/log: Implement suspend/resume Jocelyn Falempe
2024-10-24 14:34 ` Petr Mladek
2024-10-24 23:11 ` Jocelyn Falempe
2024-10-25 9:46 ` Jocelyn Falempe
2024-11-01 16:00 ` Petr Mladek
2024-11-04 9:56 ` Jocelyn Falempe
2024-11-04 10:46 ` John Ogness
2024-11-04 14:15 ` Petr Mladek
2024-11-04 14:36 ` Jocelyn Falempe
2024-11-04 15:32 ` John Ogness
2024-11-05 12:19 ` Petr Mladek
2024-11-05 14:19 ` John Ogness [this message]
2024-10-23 12:00 ` [PATCH v5 6/6] drm/log: Add integer scaling support Jocelyn Falempe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=844j4lepak.fsf@jogness.linutronix.de \
--to=john.ogness@linutronix.de \
--cc=airlied@gmail.com \
--cc=bluescreen_avenger@verizon.net \
--cc=caleb.connolly@linaro.org \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=gpiccoli@igalia.com \
--cc=javierm@redhat.com \
--cc=jfalempe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=pmladek@suse.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox