dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2025-10-04 11:01:06 to 2025-10-06 20:40:26 UTC [more...]

[PATCH] drm/nouveau: Fix refcount leak in nouveau_connector_detect
 2025-10-06 20:38 UTC  (2+ messages)

[PATCH] accel/qaic: Replace snprintf() with sysfs_emit() in sysfs show functions
 2025-10-06 20:40 UTC  (2+ messages)

[PATCH v6 0/5] Introduce bitfield and move register macro to rust/kernel/
 2025-10-06 20:36 UTC  (10+ messages)
` [PATCH v6 1/5] nova-core: bitfield: Move bitfield-specific code from register! into new macro
` [PATCH v6 4/5] rust: Move register and bitfield macros out of Nova
` [PATCH v6 5/5] rust: bitfield: Add KUNIT tests for bitfield
  ` [PATCH v7] "

[PATCH v2 00/19 5.15.y] Backport minmax.h updates from v6.17-rc7
 2025-10-06 20:35 UTC  (4+ messages)
` [PATCH v2 07/19 5.15.y] minmax: simplify and clarify min_t()/max_t() implementation

[PATCH v3 00/22] tegra-video: add CSI support for Tegra20 and Tegra30
 2025-10-06 20:31 UTC  (10+ messages)
` [PATCH v3 20/22] dt-bindings: display: tegra: document Tegra20 and Tegra30 CSI
` [PATCH v3 15/22] staging: media: tegra-video: tegra20: simplify format align calculations

[PATCH 0/5] drm/nouveau: Enable variable page sizes and compression
 2025-10-06 20:29 UTC  (9+ messages)
` [PATCH 1/5] drm/nouveau/uvmm: Prepare for larger pages
` [PATCH 2/5] drm/nouveau/uvmm: Allow "
` [PATCH 3/5] drm/nouveau/mmu/gp100: Remove unused/broken support for compression
` [PATCH 4/5] drm/nouveau/mmu/tu102: Add support for compressed kinds
` [PATCH 5/5] drm/nouveau/drm: Bump the driver version to 1.4.1 to report new features

[PATCH 1/2] accel/qaic: Replace kzalloc + copy_from_user with memdup_user
 2025-10-06 20:14 UTC  (6+ messages)
` [PATCH 2/2] accel/qaic: Replace kcalloc + copy_from_user with memdup_array_user

[PATCH] drm/amd/display: Fix unsafe uses of kernel mode FPU
 2025-10-06 19:59 UTC  (4+ messages)

[PATCH v5 0/9] Introduce bitfield and move register macro to rust/kernel/
 2025-10-06 19:50 UTC  (8+ messages)
` [PATCH v5 6/9] rust: bitfield: Add KUNIT tests for bitfield

[PATCH v2 0/8] Verisilicon DC8200 driver (and adaption to TH1520)
 2025-10-06 19:01 UTC  (9+ messages)
` [PATCH v2 2/8] dt-bindings: display: add verisilicon,dc

[PATCH net-next v2 0/6] Add AF_XDP zero copy support
 2025-10-06 18:54 UTC  (4+ messages)
` [PATCH net-next v2 1/6] net: ti: icssg-prueth: Add functions to create and destroy Rx/Tx queues

[PATCH v5 0/3] Virtio-GPU S4 support
 2025-10-06 18:35 UTC  (12+ messages)
` [PATCH v5 2/3] drm/virtio: Add support for saving and restoring virtio_gpu_objects

[PATCH v3 0/3] drm/sitronix/st7920: Add support for the ST7920 controller
 2025-10-06 17:48 UTC  (4+ messages)
` [PATCH v3 1/3] dt-bindings: display: sitronix,st7920: Add DT schema
` [PATCH v3 2/3] drm: Add driver for Sitronix ST7920 LCD displays
` [PATCH v3 3/3] MAINTAINERS: Add entry for Sitronix ST7920 driver

[PATCH v2 0/5] arm64: dts: rockchip: Add device tree for the Orange Pi CM5 Base board
 2025-10-06 16:42 UTC  (13+ messages)
` [PATCH v2 1/5] dt-bindings: display: rk3588-dw-hdmi-qp: Add tmds-enable-gpios property
` [PATCH v2 2/5] drm/rockchip: dw_hdmi_qp: Improve error handling with dev_err_probe()
` [PATCH v2 3/5] drm/rockchip: dw_hdmi_qp: Fixup usage of enable_gpio member in main struct
` [PATCH v2 4/5] dt-bindings: arm: rockchip: Add Orange Pi CM5 Base
` [PATCH v2 5/5] arm64: dts: rockchip: Add rk3588s-orangepi-cm5-base device tree

[PATCH v2] fbdev: mb862xxfbdrv: Make CONFIG_FB_DEVICE optional
 2025-10-06 16:41 UTC 

[PATCH] fbdev: mb862xxfbdrv: Make CONFIG_FB_DEVICE optional
 2025-10-06 16:10 UTC  (4+ messages)

[PATCH v4 00/10] Some Panfrost fixes and improvements
 2025-10-06 16:07 UTC  (3+ messages)
` [PATCH v4 03/10] drm/panfrost: Handle job HW submit errors

[PATCH v3 00/10] drm: Reduce page tables overhead with THP
 2025-10-06 16:01 UTC  (20+ messages)
` [PATCH v3 01/10] drm/shmem-helper: Add huge page fault handler
` [PATCH v3 03/10] drm/gem: Add huge tmpfs mount point helper
` [PATCH v3 05/10] drm/v3d: Use "
` [PATCH v3 06/10] drm/gem: Get rid of *_with_mnt helpers
` [PATCH v3 07/10] drm/panthor: Introduce huge tmpfs mount point option
` [PATCH v3 09/10] drm/panfrost: "
` [PATCH v3 10/10] Documentation/gpu/drm-mm: Add THP paragraph to GEM mapping section

[PATCH v2] drm/connector: hdmi: Add a 'link bpc' property
 2025-10-06 15:43 UTC  (4+ messages)

[PATCH v13 3/4] drm/atomic-helper: Re-order bridge chain pre-enable and post-disable
 2025-10-06 15:30 UTC  (3+ messages)

[PATCH] drm/msm: Fix pgtable prealloc error path
 2025-10-06 15:35 UTC 

[PATCH v2] drm/bridge: sii902x: Fix HDMI detection with DRM_BRIDGE_ATTACH_NO_CONNECTOR
 2025-10-06 15:13 UTC  (2+ messages)

[PATCH] drm/atomic: Change state pointers to a more meaningful name
 2025-10-06 14:48 UTC  (2+ messages)

[PATCH v6 0/7] MT8196 GPU Frequency/Power Control Support
 2025-10-06 14:28 UTC  (12+ messages)
` [PATCH v6 1/7] dt-bindings: gpu: mali-valhall-csf: add mediatek,mt8196-mali variant
` [PATCH v6 2/7] dt-bindings: power: Add MT8196 GPU frequency control binding
` [PATCH v6 7/7] pmdomain: mediatek: Add support for MFlexGraphics

[PATCH] drm/vgem-fence: Fix potential deadlock on release
 2025-10-06 14:21 UTC  (4+ messages)

[PATCH 1/2] dma-buf: replace "#if" with just "if"
 2025-10-06 13:47 UTC  (2+ messages)
` [PATCH 2/2] dma-buf: improve sg_table debugging hack

[RFC PATCH v2 0/4] Fix DRM scheduler layering violations in Xe
 2025-10-06 13:17 UTC  (4+ messages)
` [RFC PATCH v2 1/4] drm/sched: Add pending job list iterator

[PATCH v9 0/6] Add support for DU/DSI clocks and DSI driver support for the Renesas RZ/V2H(P) SoC
 2025-10-06 12:49 UTC  (5+ messages)
` [PATCH v9 2/6] clk: renesas: rzv2h-cpg: Add support for DSI clocks
` [PATCH v9 6/6] drm: renesas: rz-du: mipi_dsi: Add support for RZ/V2H(P) SoC

[PATCH] gpu/trace: add a gpu work period tracepoint
 2025-10-06 11:57 UTC 

[PATCH] nova-core: vbios: Rework BiosImage composition to use AsRef and traits
 2025-10-06 12:23 UTC  (3+ messages)

[PATCH v4 0/2] Defer vm_bo cleanup in GPUVM with DRM_GPUVM_IMMEDIATE_MODE
 2025-10-06 12:05 UTC  (3+ messages)
` [PATCH v4 1/2] drm/gpuvm: add deferred vm_bo cleanup
` [PATCH v4 2/2] panthor: use drm_gpuva_unlink_defer()

[PATCH v5 00/39] drm/atomic: Get rid of existing states (not really)
 2025-10-06 12:02 UTC  (2+ messages)

[PATCH v3 0/2] Defer vm_bo cleanup in GPUVM with DRM_GPUVM_IMMEDIATE_MODE
 2025-10-06 11:49 UTC  (10+ messages)
` [PATCH v3 1/2] drm/gpuvm: add deferred vm_bo cleanup

[Query] amdgpu_dm_crtc_mem_type_changed always compares the same plane state
 2025-10-06 11:28 UTC 

[PATCH] drm/msm: Fix GEM free for imported dma-bufs
 2025-10-06 11:12 UTC  (2+ messages)

[PATCH 0/3] drm/panel: Add support for Novatek NT36532 panel
 2025-10-06 10:49 UTC  (8+ messages)
` [PATCH 3/3] drm/panel: Add Novatek NT36532 panel driver

[PATCH v4 10/11 6.1.y] minmax.h: simplify the variants of clamp()
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: simplify the variants of clamp()" has been added to the 6.1-stable tree

[PATCH v4 08/11 6.1.y] minmax.h: use BUILD_BUG_ON_MSG() for the lo < hi test in clamp()
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: use BUILD_BUG_ON_MSG() for the lo < hi test in clamp()" has been added to the 6.1-stable tree

[PATCH v4 06/11 6.1.y] minmax.h: update some comments
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: update some comments" has been added to the 6.1-stable tree

[PATCH v4 09/11 6.1.y] minmax.h: move all the clamp() definitions after the min/max() ones
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: move all the clamp() definitions after the min/max() ones" has been added to the 6.1-stable tree

[PATCH v4 11/11 6.1.y] minmax.h: remove some #defines that are only expanded once
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: remove some #defines that are only expanded once" has been added to the 6.1-stable tree

[PATCH v4 07/11 6.1.y] minmax.h: reduce the #define expansion of min(), max() and clamp()
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: reduce the #define expansion of min(), max() and clamp()" has been added to the 6.1-stable tree

[PATCH v4 03/11 6.1.y] minmax: improve macro expansion and type checking
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax: improve macro expansion and type checking" has been added to the 6.1-stable tree

[PATCH v4 05/11 6.1.y] minmax.h: add whitespace around operators and after commas
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax.h: add whitespace around operators and after commas" has been added to the 6.1-stable tree

[PATCH v4 02/11 6.1.y] minmax: simplify min()/max()/clamp() implementation
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax: simplify min()/max()/clamp() implementation" has been added to the 6.1-stable tree

[PATCH v4 01/11 6.1.y] minmax: don't use max() in situations that want a C constant expression
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax: don't use max() in situations that want a C constant expression" has been added to the 6.1-stable tree

[PATCH v4 04/11 6.1.y] minmax: fix up min3() and max3() too
 2025-10-06 10:39 UTC  (2+ messages)
` Patch "minmax: fix up min3() and max3() too" has been added to the 6.1-stable tree

[PATCH] drm/mediatek: fix device use-after-free on unbind
 2025-10-06 10:19 UTC  (2+ messages)

[PATCH v2 0/7] Add DSI display support for QCS8300 target
 2025-10-06 10:16 UTC  (14+ messages)
` [PATCH v2 1/7] dt-bindings: display: msm-dsi-phy-7nm: document the QCS8300 DSI PHY
` [PATCH v2 2/7] dt-bindings: msm: dsi-controller-main: document the QCS8300 DSI CTRL
` [PATCH v2 3/7] dt-bindings: display: msm: document DSI controller and phy on QCS8300
` [PATCH v2 4/7] drm/msm/dsi: add DSI PHY configuration "
` [PATCH v2 5/7] drm/msm/dsi: add DSI support for QCS8300
` [PATCH v2 6/7] arm64: dts: qcom: qcs8300: add Display Serial Interface device nodes
` [PATCH v2 7/7] arm64: dts: qcom: qcs8300-ride: add anx7625 DSI to DP bridge node

[PATCH v3 0/4] backlight: add new max25014 backlight driver
 2025-10-06 10:02 UTC  (6+ messages)
` [PATCH v3 1/4] dt-bindings: backlight: Add max25014 bindings
  ` [PATCH v3 1/4] dt-bindings: backlight: Add max25014 bindingsy

[PATCH v2 0/2] drm/panthor: initial mt8196 support
 2025-10-06  9:54 UTC  (2+ messages)

[PATCH v8 1/3] drm/buddy: Optimize free block management with RB tree
 2025-10-06  9:51 UTC  (3+ messages)
` [PATCH v8 2/3] drm/buddy: Separate clear and dirty free block trees
` [PATCH v8 3/3] drm/buddy: Add KUnit tests for allocator performance under fragmentation

[RFC v2 0/5] Improving the worst case TTM large allocation latency
 2025-10-06  9:49 UTC  (5+ messages)
` [RFC v2 1/5] drm/ttm: Add getter for some pool properties
` [RFC v2 4/5] drm/ttm: Allow drivers to specify maximum beneficial TTM pool size

[PATCH] drm/mediatek: Fix refcounting in mtk_drm_get_all_drm_priv
 2025-10-06  9:49 UTC  (2+ messages)

[PATCH] drm/panthor: add query for calibrated timstamp info
 2025-10-06  9:46 UTC  (4+ messages)

[PATCH 0/3] drm/draw: add check API to avoid spurious WARN
 2025-10-06  9:05 UTC  (7+ messages)
` [PATCH 1/3] drm/draw: add drm_draw_can_convert_from_xrgb8888
` [PATCH 2/3] drm/log: avoid WARN when searching for usable format
` [PATCH 3/3] drm/log: avoid WARN when checking format support

[PATCH] Documentation/gpu: Remove duplicate kernel-doc exports in drm-uapi.rst
 2025-10-06 12:00 UTC 

[git pull] drm for 6.18-rc1
 2025-10-05 21:33 UTC  (10+ messages)

[PATCH] MAINTAINERS: Update Jessica Zhang's email address
 2025-10-06  7:02 UTC  (5+ messages)

[PATCH 0/3] Add DSI display support for QCS8300 target
 2025-10-05 23:53 UTC  (6+ messages)
` [PATCH 2/3] arm64: dts: qcom: qcs8300: add Display Serial Interface device nodes

[PATCH v1 0/2] Add support for Tianma TL121BVMS07-00 panel
 2025-10-05 23:21 UTC  (3+ messages)
` [PATCH v1 2/2] drm/panel: Add driver "

[PATCH v7 0/6] MHDP8546 fixes related to DBANC usecase
 2025-10-05 23:12 UTC  (5+ messages)
` [PATCH v7 2/6] drm/bridge: cadence: cdns-mhdp8546*: Change drm_connector from structure to pointer
` [PATCH v7 3/6] drm/bridge: cadence: cdns-mhdp8546-core: Set the mhdp connector earlier in atomic_enable()

[PATCH v7 0/1] [DRIVER] gpu: drm: add support for Yhgc ZX1000 soc chipset
 2025-10-05 23:06 UTC  (5+ messages)
` [PATCH v8 0/1] [DRIVER] gpu: drm: add support for YHGCH "
  ` [PATCH v8 1/1] "

[PATCH v2] drm/display: add hw_params callback function to drm_connector_hdmi_audio_ops
 2025-10-05 15:29 UTC  (8+ messages)

[PATCH] drm/radeon: fix allocation of ring memory in *copy_dma
 2025-10-05 13:04 UTC 

[PATCH v2] rust: pci: Allocate and manage PCI interrupt vectors
 2025-10-05 12:56 UTC  (2+ messages)

[PATCH] drm/meson: add support for 2560x1440 resolution output
 2025-10-05 12:36 UTC  (5+ messages)

[PATCH v3 00/11] drm/rcar-du: dsi: Convert register bits to BIT()/GENMASK() macros
 2025-10-05  3:02 UTC  (12+ messages)
` [PATCH v3 01/11] drm/rcar-du: dsi: Fix missing parameter in RXSETR_...EN macros
` [PATCH v3 02/11] drm/rcar-du: dsi: Document TXVMSETR PIXWDTH as bitfield
` [PATCH v3 03/11] drm/rcar-du: dsi: Document PHTR TESTDOUT "
` [PATCH v3 04/11] drm/rcar-du: dsi: Deduplicate mipi_dsi_pixel_format_to_bpp() usage
` [PATCH v3 05/11] drm/rcar-du: dsi: Clean up VCLKSET register macros
` [PATCH v3 06/11] drm/rcar-du: dsi: Clean up CLOCKSET1 CLKINSEL macros
` [PATCH v3 07/11] drm/rcar-du: dsi: Clean up TXVMPSPHSETR DT macros
` [PATCH v3 08/11] drm/rcar-du: dsi: Respect DSI mode flags
` [PATCH v3 09/11] drm/rcar-du: dsi: Clean up handling of DRM "
` [PATCH v3 10/11] drm/rcar-du: dsi: Convert register bits to BIT() macro
` [PATCH v3 11/11] drm/rcar-du: dsi: Convert register bitfields to GENMASK() macro

[PATCH v17 00/47] DEPT(DEPendency Tracker)
 2025-10-04 16:39 UTC  (3+ messages)
` [PATCH v17 35/47] i2c: rename wait_for_completion callback to wait_for_completion_cb

[PATCH] gpuvm: Fix kernel-doc warning for drm_gpuvm_map_req
 2025-10-04 19:38 UTC 

[PATCH 0/2] Add ADSP and CDSP support on Kaanapali SoC
 2025-10-04 18:36 UTC  (5+ messages)
` [PATCH 1/2] misc: fastrpc: Add support for new DSP IOVA formatting
` [PATCH 2/2] misc: fastrpc: Update dma_mask for CDSP support on Kaanapali SoC

[PATCH] drm/gud: move plane init to gud_pipe.c
 2025-10-04 17:49 UTC 

[PATCH v2] drm/gud: Use kmalloc_array() instead of kmalloc()
 2025-10-04 16:13 UTC  (2+ messages)

[PATCH] drm: renesas: rz-du: Drop ARCH_RZG2L dependency
 2025-10-04 13:56 UTC  (2+ messages)

[PATCH] drm/msm: Add NULL check in vm_op_enqueue
 2025-10-04 11:00 UTC  (2+ messages)
` [PATCH RFT] drm/msm: Add NULL check in vm_op_enqueue()


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox