dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-03-05 19:57:25 to 2026-03-06 12:48:42 UTC [more...]

dma_fence: force users to take the lock manually
 2026-03-06 12:48 UTC  (15+ messages)

[PATCH v2] dt-bindings: display: panel: Document the rotation property
 2026-03-06 12:44 UTC 

[PATCH 00/11] drm/vc4: Switch to DRM GPU scheduler
 2026-03-06 12:45 UTC  (6+ messages)
` [PATCH 06/11] drm/vc4: Add new job submission implementation
` [PATCH 07/11] drm/vc4: Add per-file descriptor seqno tracking

[PATCH v1 00/16] mm: cleanups around unmapping / zapping
 2026-03-06 12:43 UTC  (33+ messages)
` [PATCH v1 01/16] mm/madvise: drop range checks in madvise_free_single_vma()
` [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
` [PATCH v1 03/16] mm/memory: inline unmap_mapping_range_vma() into unmap_mapping_range_tree()
` [PATCH v1 04/16] mm/memory: simplify calculation in unmap_mapping_range_tree()
` [PATCH v1 05/16] mm/oom_kill: use MMU_NOTIFY_CLEAR in __oom_reap_task_mm()
` [PATCH v1 06/16] mm/oom_kill: factor out zapping of VMA into zap_vma_for_reaping()
` [PATCH v1 07/16] mm/memory: rename unmap_single_vma() to __zap_vma_range()
` [PATCH v1 08/16] mm/memory: move adjusting of address range to unmap_vmas()
` [PATCH v1 09/16] mm/memory: convert details->even_cows into details->skip_cows
` [PATCH v1 10/16] mm/memory: use __zap_vma_range() in zap_vma_for_reaping()
` [PATCH v1 11/16] mm/memory: inline unmap_page_range() into __zap_vma_range()
` [PATCH v1 12/16] mm: rename zap_vma_pages() to zap_vma()
` [PATCH v1 13/16] mm: rename zap_page_range_single_batched() to zap_vma_range_batched()
` [PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
` [PATCH v1 15/16] mm: rename zap_vma_ptes() to zap_special_vma_range()
` [PATCH v1 16/16] mm/memory: support VM_MIXEDMAP in zap_special_vma_range()

[PATCH v4 0/9] drm/panthor: Add a GEM shrinker
 2026-03-06 12:30 UTC  (8+ messages)
` [PATCH v4 5/9] drm/panthor: Part ways with drm_gem_shmem_object

[PATCH v3 1/4] mfd: atmel-hlcdc: fetch LVDS PLL clock for LVDS display
 2026-03-06 12:20 UTC  (2+ messages)
` (subset) "

[PATCH 0/5] dt-bindings: display: panel: Few cleanups and fixes
 2026-03-06 12:02 UTC  (6+ messages)
` [PATCH 1/5] dt-bindings: display: samsung,s6d7aa0: Document port
` [PATCH 2/5] dt-bindings: display: innolux,p097pfg: Document ports
` [PATCH 3/5] dt-bindings: display: panel: Drop redundant properties
` [PATCH 4/5] dt-bindings: display: panel: Align style of additionalProperties
` [PATCH 5/5] dt-bindings: display: panel: Align style of "true" properties

drm_sched run_job and scheduling latency
 2026-03-06 11:58 UTC  (16+ messages)

[PATCH] drm/i915: Fix potential overflow of shmem scatterlist length
 2026-03-06 11:55 UTC  (2+ messages)

[PATCH v2 3/4] folio_batch: Rename pagevec.h to folio_batch.h
 2026-03-06 11:45 UTC  (5+ messages)
  ` [PATCH v2 1/4] mm: Remove stray references to struct pagevec
  ` [PATCH v2 2/4] fs: Remove unncessary pagevec.h includes
  ` [PATCH v2 4/4] folio_batch: Rename PAGEVEC_SIZE to FOLIO_BATCH_SIZE

[PATCH] drm/i915/guc: fix corrupted copyright symbols in selftest files
 2026-03-06 11:44 UTC  (2+ messages)

[PATCH v3 0/6] drm/v3d: Improve v3d_stats lifetime and locking
 2026-03-06 11:30 UTC  (7+ messages)
` [PATCH v3 1/6] drm/v3d: Handle error from drm_sched_entity_init()
` [PATCH v3 2/6] drm/v3d: Use raw seqcount helpers instead of fighting with lockdep
` [PATCH v3 3/6] drm/v3d: Refcount v3d_stats
` [PATCH v3 4/6] drm/v3d: Hold v3d_stats references in each job
` [PATCH v3 5/6] drm/v3d: Attach per-fd reset counters to v3d_stats
` [PATCH v3 6/6] drm/v3d: Remove dedicated fence_lock

[PATCH 00/14] firmware: qcom: Add OP-TEE PAS service support
 2026-03-06 11:15 UTC  (16+ messages)
` [PATCH 01/14] arm64: dts: qcom: kodiak: Add EL2 overlay
` [PATCH 02/14] firmware: qcom: Add a generic PAS service
` [PATCH 03/14] firmware: qcom_scm: Migrate to "
` [PATCH 04/14] firmware: qcom: Add a PAS TEE service
` [PATCH 05/14] remoteproc: qcom_q6v5_pas: Switch over to generic PAS TZ APIs
` [PATCH 06/14] remoteproc: qcom_q6v5_mss: Switch "
` [PATCH 07/14] soc: qcom: mdtloader: "
` [PATCH 08/14] remoteproc: qcom_wcnss: "
` [PATCH 09/14] remoteproc: qcom: Select QCOM_PAS_TEE service backend
` [PATCH 10/14] drm/msm: Switch to generic PAS TZ APIs
` [PATCH 11/14] media: qcom: "
` [PATCH 12/14] net: ipa: "
` [PATCH 13/14] wifi: ath12k: "
` [PATCH 14/14] firmware: qcom_scm: Remove SCM PAS wrappers

[PATCH v5 0/9] gpu: nova-core: gsp: add continuation record support
 2026-03-06 11:03 UTC  (9+ messages)
` [PATCH v5 2/9] gpu: nova-core: gsp: add mechanism to wait for space on command queue

[PATCH v10 00/10] gpu: nova-core: add Turing support
 2026-03-06 10:53 UTC  (20+ messages)
` [PATCH v10 01/10] gpu: nova-core: create falcon firmware DMA objects lazily
` [PATCH v10 02/10] gpu: nova-core: falcon: add constant for memory block alignment
` [PATCH v10 04/10] gpu: nova-core: falcon: remove FalconFirmware's dependency on FalconDmaLoadable
` [PATCH v10 05/10] gpu: nova-core: falcon: remove unwarranted safety check in dma_load
` [PATCH v10 06/10] gpu: nova-core: move brom_params and boot_addr to FalconFirmware
` [PATCH v10 07/10] gpu: nova-core: add PIO support for loading firmware images
` [PATCH v10 09/10] gpu: nova-core: make Chipset::arch() const
` [PATCH v10 10/10] gpu: nova-core: add gen_bootloader firmware to ModInfoBuilder

[PATCH v3 0/6] dma-buf: heaps: add coherent reserved-memory heap
 2026-03-06 10:36 UTC  (7+ messages)
` [PATCH v3 1/6] dma-buf: dma-heap: Keep track of the heap device struct
` [PATCH v3 2/6] dma-buf: dma-heap: split dma_heap_add
` [PATCH v3 3/6] of_reserved_mem: add a helper for rmem device_init op
` [PATCH v3 4/6] dma: coherent: store reserved memory coherent regions
` [PATCH v3 5/6] dma-buf: heaps: Add Coherent heap to dmabuf heaps
` [PATCH v3 6/6] dma-buf: heaps: coherent: Turn heap into a module

[PATCH] dt-bindings: display/msm: move DSI PHY bindings to phy/ subdir
 2026-03-06 10:36 UTC  (2+ messages)

[PATCH phy-next 00/22] Split Generic PHY consumer and provider API
 2026-03-06  9:56 UTC  (3+ messages)
` [PATCH phy-next 07/22] net: lan969x: include missing <linux/of.h>

[PATCH] drm: bridge: anx7625: enforce CONFIG_USB_ROLE_SWITCH dependency
 2026-03-06  9:48 UTC  (2+ messages)

[PATCH RFC 0/4] DP: Read LTTPR caps followed by DPRX caps
 2026-03-06  9:46 UTC  (10+ messages)
` [PATCH RFC 1/4] drm/display/dp: Read LTTPR caps without "

[PATCH v2 00/12] media: stm32: dcmi: stability & performance enhancements
 2026-03-06  9:42 UTC  (2+ messages)

[PATCH] drm: bridge: anx7625: correctly detect if PD can be disabled
 2026-03-06  9:36 UTC  (2+ messages)

[PATCH] drm: bridge: anx7625: don't crash if Type-C port is not used
 2026-03-06  9:35 UTC  (2+ messages)

[PATCH] drm/msm/dsi: setup RC model properly
 2026-03-06  9:25 UTC 

[PATCH] drm/msm/dsi: remove bpc > 8 entries from allow list
 2026-03-06  9:25 UTC 

[PATCH] fbdev: macfb: Replace deprecated strcpy with strscpy
 2026-03-06  9:20 UTC  (2+ messages)

[PATCH] drm/sysfb: efidrm: Fix framebuffer mapping error handling
 2026-03-06  9:19 UTC 

[PATCH] drm/msm/a8xx: Fix ubwc config related to swizzling
 2026-03-06  9:04 UTC  (2+ messages)

[PATCH v8 0/9] Add support for i.MX94 DCIF
 2026-03-06  8:46 UTC  (14+ messages)
` [PATCH v8 1/9] dt-bindings: display: fsl,ldb: Add i.MX94 LDB
` [PATCH v8 2/9] drm/bridge: fsl-ldb: Get the next non-panel bridge
` [PATCH v8 3/9] drm/bridge: fsl-ldb: Add support for i.MX94
` [PATCH v8 6/9] dt-bindings: clock: nxp, imx95-blk-ctl: Add ldb child node
  ` [PATCH v8 6/9] dt-bindings: clock: nxp,imx95-blk-ctl: "
` [PATCH v8 7/9] arm64: dts: imx943: Add display pipeline nodes
` [PATCH v8 8/9] arm64: dts: imx943-evk: Add display support using IT6263

[RFC PATCH v3 0/3] Querying errors from drm_syncobj
 2026-03-06  8:42 UTC  (6+ messages)

[PATCH 0/2] Add support for Zhunyi Z40046 LCD panel
 2026-03-06  8:36 UTC  (4+ messages)
` [PATCH 1/2] dt-bindings: display: panel: Add compatibles for Zhunyi Z40046
` [PATCH 2/2] drm/panel: jd9365da: Support for Zhunyi Z40046 panels

[PATCH v9 0/8] Initial support for Samsung Galaxy Tab 2 series
 2026-03-06  1:07 UTC  (2+ messages)

[PATCH v3 00/12] vfs: change inode->i_ino from unsigned long to u64
 2026-03-06  3:09 UTC  (3+ messages)
` [PATCH v3 02/12] audit: widen ino fields "

[PATCH v2 1/3] ARM: dts: ti: Enable overlays for am335x BeagleBoard devicetrees
 2026-03-06  1:07 UTC  (2+ messages)

[PATCH] drm/amd/display: Wrap dcn32_override_min_req_memclk() in DC_FP_{START, END}
 2026-03-06  6:28 UTC 

[PATCH] dt-bindings: display: panel: Document the rotation property
 2026-03-06  8:34 UTC  (2+ messages)

[PATCH 0/6] drm/v3d: Improve v3d_stats lifetime and locking
 2026-03-06  8:34 UTC  (11+ messages)
` [PATCH 5/6] drm/v3d: Attach per-fd reset counters to v3d_stats

[PATCH v3 0/3] replace old wq(s), add WQ_PERCPU to alloc_workqueue
 2026-03-06  8:16 UTC  (5+ messages)

[PATCH v2 00/15] var-som-6ul: improve support for variants
 2026-03-06  8:00 UTC  (3+ messages)
` [PATCH v2 04/15] dt-bindings: arm: fsl: change incorrect VAR-SOM-MX6UL references

[PATCH v2 0/2] drm/panel: Add Himax HX83121A panel driver
 2026-03-06  7:54 UTC  (3+ messages)
` [PATCH v2 1/2] dt-bindings: display: panel: Add Himax HX83121A

[PATCH v6 0/9] gpu: nova-core: gsp: add continuation record support
 2026-03-06  7:22 UTC  (10+ messages)
` [PATCH v6 1/9] gpu: nova-core: gsp: sort `MsgFunction` variants alphabetically
` [PATCH v6 2/9] gpu: nova-core: gsp: add mechanism to wait for space on command queue
` [PATCH v6 3/9] rust: add EMSGSIZE error code
` [PATCH v6 4/9] gpu: nova-core: gsp: add checking oversized commands
` [PATCH v6 5/9] gpu: nova-core: gsp: clarify invariant on command queue
` [PATCH v6 6/9] gpu: nova-core: gsp: unconditionally call variable payload handling
` [PATCH v6 7/9] gpu: nova-core: gsp: add `size` helper to `CommandToGsp`
` [PATCH v6 8/9] gpu: nova-core: gsp: support large RPCs via continuation record
` [PATCH v6 9/9] gpu: nova-core: gsp: add tests for continuation records

[PULL] drm-misc-fixes
 2026-03-06  6:41 UTC 

[RFC PATCH 0/7] queued static-key API reduces IPIs to 134/16154 in dyndbg
 2026-03-06  6:32 UTC  (9+ messages)
` [RFC PATCH 1/7] jump_label: expose queueing API for batched static key updates
` [RFC PATCH 2/7] virtio: use pr_debug_ratelimited to avoid flooding
` [RFC PATCH 3/7] drivers/tty/serial/serial_core: ratelimit uart_wait_until_sent
` [RFC PATCH 4/7] dyndbg: use static-key queueing API in dynamic-debug
` [RFC PATCH 5/7] dyndbg: hoist static_key_apply_queued up
` [RFC PATCH 6/7] lib/dynamic_debug: add negation support to queries
` [RFC PATCH 7/7] dyndbg-test: test keyword !value negation

[PATCH v11 00/12] gpu: nova-core: add Turing support
 2026-03-06  6:23 UTC  (14+ messages)
` [PATCH v11 01/12] gpu: nova-core: create falcon firmware DMA objects lazily
` [PATCH v11 02/12] gpu: nova-core: falcon: add constant for memory block alignment
` [PATCH v11 03/12] gpu: nova-core: falcon: rename load parameters to reflect DMA dependency
` [PATCH v11 04/12] gpu: nova-core: falcon: remove FalconFirmware's dependency on FalconDmaLoadable
` [PATCH v11 05/12] gpu: nova-core: move brom_params and boot_addr to FalconFirmware
` [PATCH v11 06/12] gpu: nova-core: add PIO support for loading firmware images
` [PATCH v11 07/12] gpu: nova-core: falcon: remove unwarranted safety check in dma_load
` [PATCH v11 08/12] gpu: nova-core: firmware: add comments to justify v3 header values
` [PATCH v11 09/12] gpu: nova-core: firmware: fix and explain v2 header offsets computations
` [PATCH v11 10/12] gpu: nova-core: make Chipset::arch() const
` [PATCH v11 11/12] gpu: nova-core: add gen_bootloader firmware to ModInfoBuilder
` [PATCH v11 12/12] gpu: nova-core: use the Generic Bootloader to boot FWSEC on Turing

[PATCH v5 1/2] drm/buddy: Improve offset-aligned allocation handling
 2026-03-06  6:01 UTC  (2+ messages)
` [PATCH v5 2/2] drm/buddy: Add KUnit test for offset-aligned allocations

[RFC PATCH 0/2] Allow storing TTM page limit in EFI variable
 2026-03-06  5:54 UTC  (3+ messages)
` [RFC PATCH 1/2] drm/ttm: Add EFI variable support for page limit configuration
` [RFC PATCH 2/2] tools/drm: Add TTM EFI variable configuration utility

[PATCH v8 25/25] gpu: nova-core: mm: Add PRAMIN aperture self-tests
 2026-03-06  1:49 UTC  (4+ messages)

[PATCH] drm/vc4: platform_get_irq_byname() returns an int
 2026-03-06  0:08 UTC  (2+ messages)

[PATCH v2 0/2] ARM: tegra: document Tegra20 HDMI port
 2026-03-05 23:59 UTC  (3+ messages)
` [PATCH v2 1/2] dt-bindings: display: "

[PATCH v2 0/2] gpu/drm: panel: add support for DSI panel used in Motorola Atrix 4G and Droid X2
 2026-03-05 23:54 UTC  (3+ messages)
` [PATCH v2 1/2] dt-bindings: display: panel: document Atrix 4G and Droid X2 DSI panel

[PATCH RESEND v2] drm/amdgpu: Fix kernel-doc comments for some LUT properties
 2026-03-05 23:52 UTC  (3+ messages)

[PATCH v2 0/6] drm/v3d: Improve v3d_stats lifetime and locking
 2026-03-05 23:25 UTC  (7+ messages)
` [PATCH v2 1/6] drm/v3d: Handle error from drm_sched_entity_init()
` [PATCH v2 2/6] drm/v3d: Use raw seqcount helpers instead of fighting with lockdep
` [PATCH v2 3/6] drm/v3d: Refcount v3d_stats
` [PATCH v2 4/6] drm/v3d: Hold v3d_stats references in each job
` [PATCH v2 5/6] drm/v3d: Attach per-fd reset counters to v3d_stats
` [PATCH v2 6/6] drm/v3d: Remove dedicated fence_lock

[PATCH v2 0/4] ice: use better bitmap API
 2026-03-05 22:40 UTC  (4+ messages)
` [PATCH v2 4/4] drm/xe: switch xe_pagefault_queue_init() to using bitmap_weighted_or()

[PATCH v2] drm: of: Fix drm_of_get_data_lanes_count_ep() return value documentation
 2026-03-05 20:58 UTC 

[PATCH v3 1/2] drm/panel: simple: Add Waveshare 13.3" panel support
 2026-03-05 20:46 UTC  (3+ messages)

[PATCH] drm/bridge: waveshare-dsi: Use temporary signed variable for DSI lanes validation
 2026-03-05 20:44 UTC 

[PATCH v2 00/13] vc,fbcon,fonts: Proper handling of font data
 2026-03-05 20:12 UTC  (5+ messages)
` [PATCH v2 09/13] lib/fonts: Compare font data for equality with font_data_is_equal()

[PATCH v5 0/6] cgroup/dmem,drm/ttm: Improve protection in contended cases
 2026-03-05 20:02 UTC  (4+ messages)
` [PATCH v5 2/6] cgroup,cgroup/dmem: Add (dmem_)cgroup_common_ancestor helper


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox