messages from 2026-06-29 11:23:46 to 2026-06-29 15:52:13 UTC [more...]
[PATCH v3] drm/amdgpu: reject mapping info when BO VA is gone
2026-06-29 15:39 UTC (2+ messages)
[PATCH] drm/amd/powerplay: add NULL check for vega10_ps
2026-06-29 13:26 UTC (2+ messages)
[PATCH] drm/amd/display: Remove unused-but-set variable hubp from
2026-06-29 13:23 UTC (2+ messages)
[PATCH v4] drm/omap: dsi: avoid sending bta sync all the time in writes
2026-06-29 15:50 UTC
[PATCH] [RFC] gpiolib: introduce gpio_name() helper
2026-06-29 15:45 UTC (5+ messages)
[PATCH 0/2] drm/imagination: Remove Matt Coster as maintainer
2026-06-29 15:47 UTC (3+ messages)
` [PATCH 1/2] MAINTAINERS, mailmap: Update address for Matt Coster
` [PATCH 2/2] dt-bindings: gpu: img,powervr-*: Remove Matt Coster as maintainer
[PATCH 5.10/5.15/6.1/6.6/6.12] agp/amd64: Fix broken error propagation in agp_amd64_probe()
2026-06-29 15:40 UTC (2+ messages)
[PATCH] dt-bindings: display: verisilicon, dc: make resets non-optional
2026-06-29 15:28 UTC (2+ messages)
` [PATCH] dt-bindings: display: verisilicon,dc: "
[PATCH] drm/xe: Add creator TID to sched job trace points
2026-06-29 15:27 UTC (2+ messages)
[PATCH 00/37] drm bridge hotplug
2026-06-29 15:23 UTC (12+ messages)
` [PATCH 05/37] drm/display: bridge-connector: split code creating the connector to a subfunction
[PATCH v5 0/7] drm/verisilicon: add Nuvoton MA35D1 DCU Lite support
2026-06-29 15:02 UTC (11+ messages)
` [PATCH v5 1/7] dt-bindings: display: verisilicon, dc: generalize for single-output variants
` [PATCH v5 1/7] dt-bindings: display: verisilicon,dc: "
[PATCH v2 0/3] drm/imagination: Maintainer updates
2026-06-29 15:01 UTC (2+ messages)
[PATCH 00/30] mm: make VMA page offset handling more consistent
2026-06-29 14:56 UTC (33+ messages)
` [PATCH 01/30] mm: move vma_start_pgoff() into mm.h and clean up
` [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
` [PATCH 03/30] tools/testing/vma: use vma_start_pgoff() in merge tests
` [PATCH 04/30] mm: introduce and use vma_end_pgoff()
` [PATCH 05/30] mm/rmap: update mm/interval_tree.c comments
` [PATCH 06/30] mm/rmap: parameterise vma_interval_tree_*() by address_space
` [PATCH 07/30] mm/rmap: elide unnecessary static inline's in interval_tree.c
` [PATCH 08/30] mm/rmap: rename vma_interval_tree_*() to mapping_interval_tree_*()
` [PATCH 09/30] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
` [PATCH 10/30] MAINTAINERS: Move mm/interval_tree.c to rmap section
` [PATCH 11/30] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
` [PATCH 12/30] mm/vma: clean up anon_vma_compatible()
` [PATCH 13/30] mm/vma: refactor vmg_adjust_set_range() for clarity
` [PATCH 14/30] mm/vma: minor cleanup of expand_[upwards, downwards]()
` [PATCH 15/30] mm: introduce and use linear_page_delta()
` [PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
` [PATCH 17/30] mm: prefer vma_[start, end]_pgoff() to vma->vm_pgoff in kernel/
` [PATCH 18/30] mm/vma: remove duplicative vma_pgoff_offset() helper
` [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
` [PATCH 20/30] mm/vma: introduce vma_assert_can_modify()
` [PATCH 21/30] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH 22/30] mm/vma: move __install_special_mapping() to vma.c
` [PATCH 23/30] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
` [PATCH 24/30] mm/vma: update vma_shrink() to not pass unnecessary pgoff parameter
` [PATCH 25/30] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH 26/30] mm/vma: introduce and use vma_set_pgoff()
` [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
` [PATCH 28/30] mm/vma: use guard clauses in can_vma_merge_[before, after]()
` [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
` [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
[PATCH 00/11] drm/panthor: Misc fixes for bugs found by shashiko
2026-06-29 14:55 UTC (9+ messages)
` [PATCH 06/11] drm/panthor: Don't overrule pending immediate ticks in sched_resume_tick()
` [PATCH 11/11] drm/panthor: Keep interrupts masked until they are needed
[PATCH] drm/amd/display: Drop dm_pp_get_static_clocks KUnit tests
2026-06-29 14:52 UTC (2+ messages)
[PATCH 0/5] drm/msm/dp: Add MSM Type-C MST support
2026-06-29 14:48 UTC (6+ messages)
` [PATCH 1/5] drm/bridge: allow hpd_notify() to suppress connector hotplug events
` [PATCH 2/5] drm/bridge_connector: preserve connector status for IRQ-only HPD events
` [PATCH 3/5] drm/msm/dp: suppress bridge hotplug events during MST operation
` [PATCH 4/5] drm/msm/dp: report IRQ_HPD as an IRQ-only notification
` [PATCH 5/5] drm/msm/dp: mark the SST connector disconnected when MST is enabled
[PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-29 14:37 UTC (2+ messages)
[PATCH v4 00/13] gpu: nova-core: consolidate and streamline GSP boot process
2026-06-29 14:27 UTC (21+ messages)
` [PATCH v4 01/13] gpu: nova-core: gsp: sequencer: use GspBootContext
` [PATCH v4 02/13] gpu: nova-core: gsp: sequencer: do not store sequence into GspSequencer
` [PATCH v4 03/13] gpu: nova-core: gsp: replace BootUnloadGuard with local handlers
` [PATCH v4 04/13] gpu: nova-core: gsp: pass GspBootContext to unload methods
` [PATCH v4 05/13] gpu: nova-core: gsp: centralize missing unload bundle warnings
` [PATCH v4 06/13] gpu: nova-core: gsp: fold TU102 unload bundle construction into HAL method
` [PATCH v4 07/13] gpu: nova-core: gsp: turn FWSEC execution "
` [PATCH v4 08/13] gpu: nova-core: gsp: make use of FWSEC bootloader a property of the TU102 HAL
` [PATCH v4 09/13] gpu: nova-core: introduce GspBootMethod
` [PATCH v4 10/13] gpu: nova-core: avoid repeated calls to pci::Device::as_ref
` [PATCH v4 11/13] gpu: nova-core: gsp: pass GspBootContext mutably
` [PATCH v4 12/13] gpu: nova-core: gsp: separate context and GPU lifetimes in GspBootContext
` [PATCH v4 13/13] gpu: nova-core: store Fsp instance in Gpu
[PATCH v2] gpu: nova-core: parse structs via zerocopy
2026-06-29 14:20 UTC
[PATCH RESEND v5 00/25] drm/msm/dp: Add MST support for MSM chipsets
2026-06-29 14:14 UTC (26+ messages)
` [PATCH RESEND v5 01/25] drm/msm/dp: introduce stream_id for each DP panel
` [PATCH RESEND v5 02/25] drm/msm/dp: introduce max_streams for DP controller MST support
` [PATCH RESEND v5 03/25] drm/msm/dp: Add support for programming p1/p2/p3 register blocks
` [PATCH RESEND v5 04/25] drm/msm/dp: use stream_id to change offsets in dp_catalog
` [PATCH RESEND v5 05/25] drm/msm/dp: add support to send ACT packets for MST
` [PATCH RESEND v5 06/25] drm/msm/dp: Add support to enable MST in mainlink control
` [PATCH RESEND v5 07/25] drm/msm/dp: no need to update tu calculation for mst
` [PATCH RESEND v5 08/25] drm/msm/dp: Add support for MST channel slot allocation
` [PATCH RESEND v5 09/25] drm/msm/dp: Add support for sending VCPF packets in DP controller
` [PATCH RESEND v5 10/25] drm/msm/dp: Always program MST_FIFO_CONSTANT_FILL for MST use cases
` [PATCH RESEND v5 11/25] drm/msm/dp: move link-level teardown from display_disable to display_unprepare
` [PATCH RESEND v5 12/25] drm/msm/dp: factor out _helper variants of bridge ops accepting a panel
` [PATCH RESEND v5 13/25] drm/msm/dp: replace power_on with active_stream_cnt for dp_display
` [PATCH RESEND v5 14/25] drm/msm/dp: Mark the SST bridge disconnected when mst is active
` [PATCH RESEND v5 15/25] drm/msm/dp: add an API to initialize MST on sink side
` [PATCH RESEND v5 16/25] drm/msm/dp: add msm_dp_display_get_panel() to initialize DP panel
` [PATCH RESEND v5 17/25] drm/msm/dp: add link_ready to manage link-level operations
` [PATCH RESEND v5 18/25] drm/msm/dpu: initialize encoders per stream for DP MST
` [PATCH RESEND v5 19/25] drm/msm/dp: initialize dp_mst module for each DP MST controller
` [PATCH RESEND v5 20/25] drm/msm/dpu: expose dpu_encoder ops for DP MST reuse
` [PATCH RESEND v5 21/25] drm/msm/dpu: use msm_dp_get_mst_intf_id() to get the intf id
` [PATCH RESEND v5 22/25] drm/msm/dp: wire MST helpers into atomic check and commit paths
` [PATCH RESEND v5 23/25] drm/msm/dp: add dp_mst_drm to manage DP MST encoder operations
` [PATCH RESEND v5 24/25] drm/msm/dp: add connector abstraction for DP MST
` [PATCH RESEND v5 25/25] drm/msm/dp: add HPD callback for dp MST
[PATCH v5 00/20] rust: I/O type generalization and projection
2026-06-29 14:15 UTC (3+ messages)
[PATCH 0/3] drivers: Improve memory management for large object allocations when i915/shmem is used with iommu
2026-06-29 14:14 UTC (6+ messages)
` [PATCH 1/3] drivers/iommu: Unroll unsuccessful mapping
[PATCH] drm/imagination: Fix returned size for DRM_IOCTL_PVR_DEV_QUERY
2026-06-29 14:13 UTC (2+ messages)
[PATCH v2 00/19] driver core: count references of the platform device's fwnode, not OF node
2026-06-29 14:08 UTC (3+ messages)
` [PATCH v2 08/19] iommu/fsl: use platform_device_set_of_node()
[PATCH 0/7] rust: Use kernel style vertical imports in various drivers
2026-06-29 14:06 UTC (4+ messages)
` [PATCH 3/7] cpufreq: rcpufreq_dt: use vertical import style
[PATCH v4] drm/imagination: Fix double call to drm_sched_entity_fini()
2026-06-29 13:48 UTC (2+ messages)
[PATCH v3 0/7] drm/sysfb: simpledrm: Various improvements
2026-06-29 13:29 UTC (9+ messages)
` [PATCH v3 6/7] drm/of: Implement drm_of_get_panel_orientation()
` [PATCH v3 7/7] drm/sysfb: simpledrm: Read panel orientation from DT node
[PATCH v5 00/25] drm/msm/dp: Add MST support for MSM chipsets
2026-06-29 13:16 UTC (26+ messages)
` [PATCH v5 01/25] drm/msm/dp: introduce stream_id for each DP panel
` [PATCH v5 02/25] drm/msm/dp: introduce max_streams for DP controller MST support
` [PATCH v5 03/25] drm/msm/dp: Add support for programming p1/p2/p3 register blocks
` [PATCH v5 04/25] drm/msm/dp: use stream_id to change offsets in dp_catalog
` [PATCH v5 05/25] drm/msm/dp: add support to send ACT packets for MST
` [PATCH v5 06/25] drm/msm/dp: Add support to enable MST in mainlink control
` [PATCH v5 07/25] drm/msm/dp: no need to update tu calculation for mst
` [PATCH v5 08/25] drm/msm/dp: Add support for MST channel slot allocation
` [PATCH v5 09/25] drm/msm/dp: Add support for sending VCPF packets in DP controller
` [PATCH v5 10/25] drm/msm/dp: Always program MST_FIFO_CONSTANT_FILL for MST use cases
` [PATCH v5 11/25] drm/msm/dp: move link-level teardown from display_disable to display_unprepare
` [PATCH v5 12/25] drm/msm/dp: factor out _helper variants of bridge ops accepting a panel
` [PATCH v5 13/25] drm/msm/dp: replace power_on with active_stream_cnt for dp_display
` [PATCH v5 14/25] drm/msm/dp: Mark the SST bridge disconnected when mst is active
` [PATCH v5 15/25] drm/msm/dp: add an API to initialize MST on sink side
` [PATCH v5 16/25] drm/msm/dp: add msm_dp_display_get_panel() to initialize DP panel
` [PATCH v5 17/25] drm/msm/dp: add link_ready to manage link-level operations
` [PATCH v5 18/25] drm/msm/dpu: initialize encoders per stream for DP MST
` [PATCH v5 19/25] drm/msm/dp: initialize dp_mst module for each DP MST controller
` [PATCH v5 20/25] drm/msm/dpu: expose dpu_encoder ops for DP MST reuse
` [PATCH v5 21/25] drm/msm/dpu: use msm_dp_get_mst_intf_id() to get the intf id
` [PATCH v5 22/25] drm/msm/dp: wire MST helpers into atomic check and commit paths
` [PATCH v5 23/25] drm/msm/dp: add dp_mst_drm to manage DP MST encoder operations
` [PATCH v5 24/25] drm/msm/dp: add connector abstraction for DP MST
` [PATCH v5 25/25] drm/msm/dp: add HPD callback for dp MST
[PATCH v3 00/12] gpu: nova-core: consolidate and streamline GSP boot process
2026-06-29 13:05 UTC (14+ messages)
` [PATCH v3 01/12] gpu: nova-core: gsp: sequencer: use GspBootContext
` [PATCH v3 02/12] gpu: nova-core: gsp: sequencer: do not store sequence into GspSequencer
` [PATCH v3 03/12] gpu: nova-core: gsp: replace BootUnloadGuard with local handlers
` [PATCH v3 04/12] gpu: nova-core: gsp: pass GspBootContext to unload methods
` [PATCH v3 05/12] gpu: nova-core: gsp: centralize missing unload bundle warnings
` [PATCH v3 06/12] gpu: nova-core: gsp: fold TU102 unload bundle construction into HAL method
` [PATCH v3 07/12] gpu: nova-core: gsp: turn FWSEC execution "
` [PATCH v3 08/12] gpu: nova-core: gsp: make use of FWSEC bootloader a property of the TU102 HAL
` [PATCH v3 09/12] gpu: nova-core: introduce GspBootMethod
` [PATCH v3 10/12] gpu: nova-core: avoid repeated calls to pci::Device::as_ref
` [PATCH v3 11/12] gpu: nova-core: gsp: pass GspBootContext mutably
` [PATCH v3 12/12] gpu: nova-core: store Fsp instance in Gpu
[PATCH v2] drm/i915: fix kref leak in __live_active_setup error path
2026-06-29 13:04 UTC (2+ messages)
[PATCH v2] gpu: nova-core: falcon: store bar and dev in falcon
2026-06-29 13:00 UTC (4+ messages)
[PATCH v2 00/12] rust: driver: use pointers instead of indices for ID info
2026-06-29 12:41 UTC (2+ messages)
[PATCH v2 00/11] rust: driver: use pointers instead of indices for ID info
2026-06-29 12:39 UTC (12+ messages)
` [PATCH v2 01/11] rust: driver: remove `IdTable::id`
` [PATCH v2 02/11] rust: driver: simplify `IdArray::new_without_index`
` [PATCH v2 03/11] rust: pci: use `Option<&IdInfo>` for device ID info
` [PATCH v2 04/11] rust: usb: "
` [PATCH v2 05/11] rust: net/phy: remove expansion from doc
` [PATCH v2 06/11] rust: driver: centralize device ID handling
` [PATCH v2 07/11] rust: driver: remove `$module_table_name` from `module_device_table`
` [PATCH v2 08/11] rust: driver: store pointers in `DeviceId`
` [PATCH v2 09/11] rust: driver: remove open-coded matching logic
` [PATCH v2 10/11] rust: driver: remove duplicate ID table
` [PATCH v2 11/11] RFC: rust: driver: support map-like syntax for "
[PATCH] drm/amdgpu: reject mapping info for unmapped BOs
2026-06-29 12:33 UTC (4+ messages)
` [PATCH v2] drm/amdgpu: reject mapping info when BO VA is gone
[PATCH] drm/virtio: warn when virtqueue has no free space for too long
2026-06-29 12:11 UTC (2+ messages)
[PATCH 1/2] drm/sched: Guard sched->ready with ACCESS_ONCE()
2026-06-29 12:09 UTC (4+ messages)
` [PATCH 2/2] drm/sched: Deprecate drm_sched_wqueue_ready()
[PATCH v2] drm/ttm: add generic drvparam[] alias for ttm_place::fpfn/lpfn
2026-06-29 12:06 UTC (3+ messages)
[PATCH v3] drm/omap: dsi: avoid sending bta sync all the time in writes
2026-06-29 12:00 UTC (3+ messages)
[PATCH v1] udmabuf: Ensure to perform cache synchronisation in begin_cpu_udmabuf()
2026-06-29 11:58 UTC (5+ messages)
[PATCH] dma-fence: Make dma_fence_dedup_array() robust against 0-count input
2026-06-29 11:51 UTC (8+ messages)
[PATCH v2] dma-buf: dma-fence: Fix potential NULL pointer dereference
2026-06-29 11:25 UTC (4+ messages)
[PATCH RFC 0/4] rust: dma: bridge zerocopy-derived types into the transmute byte-safety bound
2026-06-29 11:16 UTC (8+ messages)
` [PATCH RFC 4/4] gpu: nova-core: gsp: convert GspMem to zerocopy via the transmute bridge
[PATCH v5 0/5] nouveau/gsp: Clean up IS_ERR vs IS_ERR_OR_NULL usage
2026-06-29 8:36 UTC
[PATCH v15 0/9] Add Type-C DP support for RK3399 EVB IND board
2026-06-29 8:26 UTC (5+ messages)
` [PATCH v15 1/9] drm/bridge: Implement generic USB Type-C DP HPD bridge
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox