dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-07-20 05:29:48 to 2026-07-20 12:22:12 UTC [more...]

[PATCH v6 1/2] gpu/buddy: replace dual-tree/force_merge with decoupled dirty tracker
 2026-07-20 12:22 UTC  (3+ messages)
` [PATCH v6 2/2] gpu/tests/buddy: add dirty tracker performance KUnit test

[PATCH v2 0/2] drm/drm_crtc: dma_fence_ops fixes
 2026-07-20 12:04 UTC  (6+ messages)
` [PATCH v2 1/2] drm/drm_crtc: ensure dma_fence_ops remain valid during device unbind

[PATCH] drm/panthor: validate firmware interface structure sizes
 2026-07-20 12:03 UTC  (2+ messages)

[PATCH v2 0/7] vga_switcheroo, drm: Push fbcon handling into DRM clients
 2026-07-20 11:58 UTC  (3+ messages)

[PATCH v3 0/2] PHY: Add support for MT8196 DSI PHY
 2026-07-20 11:43 UTC  (2+ messages)

[PATCH v3 0/7] don't allow changes to inactive colorops
 2026-07-20 11:40 UTC  (10+ messages)
` [PATCH v3 1/7] drm/atomic: only add states of active or transient active colorops
` [PATCH v3 2/7] drm/atomic: reject colorop update from inactive color pipeline
` [PATCH v3 3/7] drm/amd/display: don't check colorop status if its in an inactive pipeline

[PATCH RFC 0/8] drm: Add DRM_MODE_ATOMIC_RESET flag
 2026-07-20 11:40 UTC  (5+ messages)

[PATCH 0/2] drm/imagination: update BXM-4-64 MC1 support status & GPU support docs
 2026-07-20 11:37 UTC  (3+ messages)
` [PATCH 1/2] drm/imagination: update GPU support documentation
` [PATCH 2/2] drm/imagination: promote BXM-4-64 MC1 (36.52.104.182) to supported status

[PATCH] drm/amdgpu: Consistently define pci_device_ids using named initializers
 2026-07-20 11:34 UTC  (3+ messages)

[PATCH] drm/panthor: harden firmware build-info bounds checks
 2026-07-20 11:32 UTC 

[PATCH] drm/panthor: reject zero-sized firmware sections
 2026-07-20 11:30 UTC 

[PATCH] mailmap: Update Maíra Canal's email address
 2026-07-20 11:28 UTC  (2+ messages)

[PATCH v2 0/3] drm: Use named initializers for arrays of i2c_device_data
 2026-07-20 11:25 UTC  (4+ messages)
` [PATCH v2 1/3] drm/bridge: "
` [PATCH v2 2/3] drm/sitronix/st7571-i2c: Drop unused assignment of i2c_device_id driver data
` [PATCH v2 3/3] drm/nouveau: Use named initializers for i2c_device_id arrays

[RFC PATCH v2 00/11] KVM: Allow alternative providers of guest_memfd backed by PFNMAP memory
 2026-07-20 11:03 UTC  (12+ messages)
` [RFC PATCH v2 01/11] KVM: selftests: sev_smoke_test: Only run VM types the host offers
  ` [RFC PATCH v2 02/11] KVM: selftests: sev_init2_tests: Derive SEV availability from KVM
  ` [RFC PATCH v2 03/11] KVM: SEV: Remove struct page dependency from SNP gmem paths
  ` [RFC PATCH v2 04/11] KVM: guest_memfd: Introduce guest memory ops and route native gmem through them
  ` [RFC PATCH v2 05/11] iommufd: Look up private-interconnect phys via exporter symbols
  ` [RFC PATCH v2 06/11] iommufd: Plumb dma-buf memory-type (RAM vs MMIO) through the phys map
  ` [RFC PATCH v2 07/11] KVM: guest_memfd: Add ops-driven page revocation
  ` [RFC PATCH v2 08/11] samples/kvm: Add guest_memfd backing sample
  ` [RFC PATCH v2 09/11] selftests/kvm: gmem_provider KVM-only tests
  ` [RFC PATCH v2 10/11] selftests/kvm: gmem_provider iommufd tests
  ` [RFC PATCH v2 11/11] samples/kvm, selftests/kvm: Allow the gmem_provider NVMe DMA test on arm64

[PATCH 00/15] drm/drm_simple: remove drm_simple_encoder_init
 2026-07-20 11:05 UTC  (3+ messages)
` [PATCH 01/15] drm/exynos: remove dependency on DRM simple helpers

[PATCH 0/2] drm/v3d: Idle AXI transactions before cutting the clock on suspend
 2026-07-20 10:52 UTC  (5+ messages)
` [PATCH 2/2] drm/v3d: Idle AXI transactions before disabling "

[PATCH v11 0/3] Introduce cold reset recovery method
 2026-07-20 10:48 UTC  (6+ messages)
` [PATCH v11 1/3] drm: Add DRM_WEDGE_RECOVERY_COLD_RESET "
` [PATCH v11 2/3] drm/doc: Document "
` [PATCH v11 3/3] drm/xe: Handle PUNIT errors by requesting cold-reset recovery

[PATCH] drm/i915/psr: Disable eDP Panel Replay on XPS 16 DA16260 (LG 0x07C5)
 2026-07-20 10:31 UTC  (2+ messages)

[RFC PATCH 0/4] Xe driver asynchronous notification mechanism
 2026-07-20 10:24 UTC  (4+ messages)
` [PATCH 4/4] drm/xe: Add watch_queue-based device event notification

[PATCH v3 0/5] drivers: Improve memory management for large object allocations when i915/shmem is used with iommu
 2026-07-20 10:19 UTC  (18+ messages)
` [PATCH v3 1/5] drm/i915/gem: Count mapped pages in a folio
` [PATCH v3 2/5] iommu/dma: Catch scatterlist length overflows
` [PATCH v3 3/5] drm/i915/gem: Pull out size validation into a separate function
` [PATCH v3 4/5] drm/i915/gem: Read and shrink memory in "
` [PATCH v3 5/5] drm/i915/gem: Remove iterator and use while loop

[RFC PATCH v1 0/8] Arm Core Local Accelerator Driver
 2026-07-20  9:54 UTC  (6+ messages)
` [RFC PATCH v1 1/8] misc/arm-cla: Add driver skeleton and documentation

[PATCH] fbdev: arkfb: Move a variable assignment behind a condition check in ics5342_init()
 2026-07-20  9:52 UTC  (5+ messages)
  `  "

[PATCH 00/11] drm/panthor: Misc fixes for bugs found by shashiko
 2026-07-20  9:47 UTC  (3+ messages)
` [PATCH 03/11] drm/panthor: Fix UAF on works queued to panthor_cleanup_wq

[PATCH 0/3] drm/vc4: Fix binner overflow-memory corruption and GPU hangs
 2026-07-20  9:32 UTC  (2+ messages)

[PATCH 1/6] drm/dp_tunnel: Add UHBR tunneling support
 2026-07-20  9:15 UTC  (3+ messages)

[PATCH 0/3] drm/msm: Enable dual MDSS power domains
 2026-07-20  9:05 UTC  (8+ messages)
` [PATCH 1/3] dt-bindings: display: msm: Allow two "
` [PATCH 2/3] drm/msm/mdss: Enable INT2_GDSC alongside CORE_GDSC
` [PATCH 3/3] arm64: dts: qcom: Add INT2_GDSC to MDSS on Kaanapali and Glymur

[PATCH] drm/vc4: Shut down BO cache timer before teardown
 2026-07-20  8:55 UTC  (2+ messages)

[PATCH v5 0/3] Add drm_ras netlink error event support
 2026-07-20  8:22 UTC  (4+ messages)
` [PATCH v5 1/3] drm/drm_ras: Add drm_ras netlink error event
` [PATCH v5 2/3] drm/xe/xe_ras: Report correctable error events to userspace
` [PATCH v5 3/3] drm/xe/xe_ras: Report uncorrectable "

[PATCH] drm/msm/dpu: Fix DMA SSPP REC block offsets on DPU v13
 2026-07-20  7:56 UTC 

[PATCH v2 00/12] misc: Improvements around *_device_id defintions
 2026-07-20  7:50 UTC  (3+ messages)
` [PATCH v2 11/12] misc: Unify style of of_device_id arrays

[PATCH v2 0/2] drm/panel-edp: take i2c adapter module reference
 2026-07-20  7:46 UTC  (4+ messages)
` [PATCH v2 1/2] drm/panel-edp: fix i2c adapter leak on probe failure

[PATCH] drm/fb-helper: guard against NULL fb_helper->funcs in restore path
 2026-07-20  7:35 UTC  (2+ messages)

[RFC PATCH 0/9] accel/rocket: RK3576 NPU (RKNN) enablement
 2026-07-17  8:50 UTC  (10+ messages)
` [RFC PATCH 1/9] dt-bindings: npu: rockchip: add rockchip, rk3576-rknn-core
` [RFC PATCH 2/9] pmdomain/rockchip: add optional per-domain power-on settle delay
` [RFC PATCH 3/9] pmdomain/rockchip: cycle optional power-domain resets on power-on
` [RFC PATCH 4/9] iommu/rockchip: skip orphaned-fault banks in rk_iommu_is_stall_active
` [RFC PATCH 5/9] iommu/rockchip: skip orphaned-fault banks in CMD_ENABLE_STALL dispatch
` [RFC PATCH 6/9] iommu/rockchip: take all DT clocks
` [RFC PATCH 7/9] accel/rocket: add RK3576 NPU (RKNN) support
` [RFC PATCH 8/9] arm64: dts: rockchip: rk3576: add NPU (RKNN) nodes
` [RFC PATCH 9/9] arm64: dts: rockchip: rk3576-rock-4d: enable NPU

[PATCH v2 00/33] mm: make VMA page offset handling more consistent
 2026-07-19 23:27 UTC  (50+ messages)
` [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
` [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
` [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
` [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
` [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
` [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
` [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
` [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
` [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
` [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
` [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
` [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
` [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
` [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
` [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
` [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
` [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
` [PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()

[PATCH 0/4] drm/rockchip: add RK3568 LVDS support
 2026-07-20  5:39 UTC  (6+ messages)
` [PATCH 1/4] drm/rockchip: lvds: propagate bus_flags to the CRTC state
` [PATCH 2/4] dt-bindings: display: rockchip,lvds: add RK3568
` [PATCH 3/4] drm/rockchip: lvds: add RK3568 support
` [PATCH 4/4] arm64: dts: rockchip: rk356x: add LVDS node

[RFC PATCH net-next 00/13] net: knod: in-kernel network offload device
 2026-07-19 17:58 UTC  (4+ messages)
` [RFC PATCH net-next 08/13] drm/amdkfd: add GPU instruction emitter and disassembler
` [RFC PATCH net-next 09/13] drm/amdkfd: add BPF-to-GPU JIT offload
` [RFC PATCH net-next 13/13] drm/amdkfd: add IPsec full-packet offload

[PATCH v5 0/3] drm/bridge: ti-sn65dsi83: Add reverse lvds lanes support
 2026-07-20  6:55 UTC  (8+ messages)
` [PATCH v5 1/3] drm/bridge: ti-sn65dsi83: Simplify error condition logic
` [PATCH v5 2/3] dt-bindings: display: sn65dsi83: Add output data-lanes property
` [PATCH v5 3/3] drm/bridge: ti-sn65dsi83: Add reversed lvds lanes support

[RFC PATCH v2 0/8] accel/rocket: RK3576 NPU (RKNN) enablement
 2026-07-18  3:11 UTC  (9+ messages)
` [RFC PATCH v2 1/8] dt-bindings: npu: rockchip: add rockchip, rk3576-rknn-core
` [RFC PATCH v2 2/8] pmdomain/rockchip: add optional per-domain power-on settle delay
` [RFC PATCH v2 3/8] pmdomain/rockchip: cycle optional power-domain resets on power-on
` [RFC PATCH v2 4/8] iommu/rockchip: take all DT clocks
` [RFC PATCH v2 5/8] iommu/rockchip: clear stale page faults before enabling stall
` [RFC PATCH v2 6/8] accel/rocket: add RK3576 NPU (RKNN) support
` [RFC PATCH v2 7/8] arm64: dts: rockchip: rk3576: add NPU (RKNN) nodes
` [RFC PATCH v2 8/8] arm64: dts: rockchip: rk3576-rock-4d: enable NPU

[RFC PATCH 0/2] drm/meson: add HDMI support for GXLX2
 2026-07-18 11:15 UTC  (3+ messages)
` [RFC PATCH 1/2] dt-bindings: display: meson-dw-hdmi: add GXLX2 compatible
` [RFC PATCH 2/2] drm/meson: add GXLX2 HDMI register support

[PATCH v2 0/3] dt-bindings: Convert TI TPS65217 to DT schema
 2026-07-20  6:54 UTC  (7+ messages)
` [PATCH v2 1/3] ARM: dts: ti: am335x-guardian: Drop unused isink-en property
` [PATCH v2 2/3] dt-bindings: input: Convert TI TPS65217 power button to DT schema
` [PATCH v2 3/3] dt-bindings: leds: backlight: Convert TPS65217 "

[PATCH v2] drm/panel: panel-edp: Adjust T8 timing for AUO B116XAK01.6
 2026-07-20  2:53 UTC 

[PATCH 0/6] configfs: Allow the registration of const struct configfs_attribute
 2026-07-17  8:43 UTC  (7+ messages)
` [PATCH 2/6] configfs: Constify is_visible/is_visible_bin in configfs_group_operations
` [PATCH 5/6] configfs: Allow the registration of const struct configfs_attribute
` [PATCH 6/6] samples: configfs: constify the configfs_attribute structures

[PATCH] staging: fbtft: fix checkpatch errors in fbtft-bus.c
 2026-07-18 18:23 UTC 

[PATCH v2 0/3] drm/panel: ilitek-ili9805: convert to *_multi API
 2026-07-19 19:03 UTC  (4+ messages)
` [PATCH v2 1/3] drm/panel: ilitek-ili9805: Use _multi variants
` [PATCH v2 2/3] drm/panel: ilitek-ili9805: Use dsi_multi in init
` [PATCH v2 3/3] drm/panel: ilitek-ili9805: make cleanup funcs void

[RFC v2 1/2] workqueue: Add support for real-time workers
 2026-07-17 11:55 UTC  (4+ messages)

[PATCH v6 1/2] drm/atomic: attempt full modeset on page flip timeout
 2026-07-17 16:44 UTC  (4+ messages)
` [PATCH v6 2/2] drm/amd/display: add DMU timeout recovery support

[PATCH] drm/meson: constrain the DW-HDMI regmap range
 2026-07-18  9:07 UTC 

linux-next: manual merge of the drm tree with the drm-fixes tree
 2026-07-17 14:40 UTC 

[PATCH] [PATCH] drm/vkms: Advertise PREMULTI blend mode
 2026-07-20  0:17 UTC 

[PATCH] rust: io: convert ResourceSize into a transparent newtype
 2026-07-19 20:09 UTC  (4+ messages)
` [PATCH v2] "

[PATCH v1] drm/panel: panel-edp: Adjust T8 timing for AUO B116XAK01.6 and B140XTK02.4
 2026-07-17  2:59 UTC 

[PATCH] drm/panel: ilitek-ili9805: Use _multi variants
 2026-07-17 10:12 UTC  (3+ messages)

[PATCH] drm/nouveau/disp: Prevent division-by-zero during DisplayPort link training transitions
 2026-07-17  8:15 UTC  (3+ messages)

[PATCH] drm/i915/quirks: Disable PSR2 on Lenovo ThinkPad P15 Gen 1
 2026-07-17 12:47 UTC 

[PATCH v11 0/7] User readable error codes on atomic_ioctl failure
 2026-07-20  7:03 UTC  (4+ messages)
` [PATCH v11 1/7] drm: Define user readable error codes for atomic ioctl

[PATCH] drm/mediatek: Check CRTC state before freeing
 2026-07-20  6:47 UTC  (2+ messages)

[PATCH v8 00/15] drm/msm/dp: Prerequisite cleanup for upcoming MST support
 2026-07-20  6:33 UTC  (24+ messages)
` [PATCH v8 01/15] drm/msm/dp: remove cached drm_edid from panel
` [PATCH v8 02/15] drm/msm/dp: drop deprecated .mode_set() and use .atomic_enable
` [PATCH v8 03/15] drm/msm/dp: move mode setup into msm_dp_panel_init_panel_info()
` [PATCH v8 04/15] drm/msm/dp: split msm_dp_ctrl_config_ctrl() into link parts and stream parts
` [PATCH v8 05/15] drm/msm/dp: extract MISC1_MISC0 configuration into a separate function
` [PATCH v8 06/15] drm/msm/dp: split link setup from source params
` [PATCH v8 07/15] drm/msm/dp: move the pixel clock control to its own API
` [PATCH v8 08/15] drm/msm/dp: break up dp_display_enable into two parts
` [PATCH v8 09/15] drm/msm/dp: re-arrange dp_display_disable() into functional parts
` [PATCH v8 10/15] drm/msm/dp: allow dp_ctrl stream APIs to use any panel passed to it
` [PATCH v8 11/15] drm/msm/dp: split dp_ctrl_off() into stream and link parts
` [PATCH v8 12/15] drm/msm/dp: simplify link and clock disable sequence
` [PATCH v8 13/15] drm/msm/dp: make bridge helpers use dp_display to allow re-use
` [PATCH v8 14/15] drm/msm/dp: separate dp_display_prepare() into its own API
` [PATCH v8 15/15] drm/msm/dp: pass panel to display enable/disable helpers

[v5 00/14] drm/i915/color: Enable SDR plane color pipeline
 2026-07-20  5:39 UTC  (7+ messages)
` [v5 02/14] drm/i915/color: Add CSC on "
` [v5 08/14] drm/i915/color: Add YUV range correction to SDR plane pipeline
` [v5 14/14] drm/i915/color: Add color pipeline support for SDR planes


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox